summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-30 05:17:17 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-30 06:48:12 -0400
commitc663d76d498d34d84edd2ecf23ebc6be911f327d (patch)
tree99f42f21752bed9699185c49bf2e091df2115d45
parentx11-misc/xfishtank: force gcc -E for imake's generation (diff)
downloadgentoo-c663d76d.tar.gz
gentoo-c663d76d.tar.bz2
gentoo-c663d76d.zip
x11-misc/xkeycaps: force gcc -E for imake's generation
Requires traditional cpp support and is broken in all sort of ways with clang-cpp / -E. Can still use clang & friends for everything else. Ideally these packages need to be built another way or last rited, imake will just accumulate more problems. Closes: https://bugs.gentoo.org/871129 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--x11-misc/xkeycaps/xkeycaps-2.47_p7.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/x11-misc/xkeycaps/xkeycaps-2.47_p7.ebuild b/x11-misc/xkeycaps/xkeycaps-2.47_p7.ebuild
index cbac2508a679..be540734790a 100644
--- a/x11-misc/xkeycaps/xkeycaps-2.47_p7.ebuild
+++ b/x11-misc/xkeycaps/xkeycaps-2.47_p7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -23,10 +23,12 @@ RDEPEND="
x11-libs/libXt
x11-misc/xbitmaps
"
-DEPEND="${RDEPEND}"
-BDEPEND="
- >=sys-apps/sed-4
+DEPEND="
+ ${RDEPEND}
x11-base/xorg-proto
+"
+BDEPEND="
+ sys-devel/gcc
>=x11-misc/imake-1.0.8-r1
"
@@ -47,7 +49,7 @@ src_prepare() {
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
- IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
+ IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
sed -i \
-e "s,all:: xkeycaps.\$(MANSUFFIX).html,all:: ,g" \
Makefile || die