summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-10 17:32:49 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-10 18:01:55 +0200
commitc6697a69b77e42340328b9c7dc29e08240967447 (patch)
tree944fc7673dcb8cdfa79aa8866d054ad503833025
parentdev-ros/dwa_local_planner: Bump to 1.17.0. (diff)
downloadgentoo-c6697a69b77e42340328b9c7dc29e08240967447.tar.gz
gentoo-c6697a69b77e42340328b9c7dc29e08240967447.tar.bz2
gentoo-c6697a69b77e42340328b9c7dc29e08240967447.zip
dev-ros/fake_localization: Bump to 1.17.0.
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/fake_localization/Manifest1
-rw-r--r--dev-ros/fake_localization/fake_localization-1.17.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ros/fake_localization/Manifest b/dev-ros/fake_localization/Manifest
index 8d1b02930a42..78b2227f5604 100644
--- a/dev-ros/fake_localization/Manifest
+++ b/dev-ros/fake_localization/Manifest
@@ -1 +1,2 @@
DIST navigation-1.16.6.tar.gz 346529 BLAKE2B ed2d7ddd0ca9525f0ae22711d65fc2ede5f3046fd320e5016b93505616c4d476d65128695ff8830c4fa0b8dbdc276a1ec5951fdb4d0516f4d5f70897e4759f31 SHA512 c6bc3db39457c6bccba7ee2646504c4e1c91840a3297bdb9b92b28d93c608c0de113eb92527d4f499232de628d5b49816ec42522043500b20fb04056e2a7c97f
+DIST navigation-1.17.0.tar.gz 347660 BLAKE2B 8345dccf8ac5e24d1017631bb621ebaa472cc492d6361f29938501a149555771e03a6a46e16fdcc508bbe5c206ead80e9b79e9168b873685fca50a78ea7a7e13 SHA512 a536c8826bd88151ff8f51f83661282f8ccf1b19872bd91ed32987ef372797b94489380262e79ee2560ecb4d9e290c5b4f8d52c17721e2a41126eaea909bce26
diff --git a/dev-ros/fake_localization/fake_localization-1.17.0.ebuild b/dev-ros/fake_localization/fake_localization-1.17.0.ebuild
new file mode 100644
index 000000000000..1634273142ee
--- /dev/null
+++ b/dev-ros/fake_localization/fake_localization-1.17.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+
+inherit ros-catkin
+
+DESCRIPTION="A ROS node that simply forwards odometry information"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/boost:=
+ dev-ros/angles
+ dev-ros/roscpp
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rosconsole
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_ros
+ dev-ros/message_filters
+"
+DEPEND="${RDEPEND}
+ dev-ros/tf2_geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/nav_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"