summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-10-16 15:58:40 +0200
committerDavid Seifert <soap@gentoo.org>2021-10-16 15:58:40 +0200
commitc671b43a3b97bfaf4bd06df7406f815a3c33695b (patch)
treecbb33cb8a44bbf969a897fb3f3fe522976e59f65
parentdev-util/regexxer: port to EAPI 8 (diff)
downloadgentoo-c671b43a.tar.gz
gentoo-c671b43a.tar.bz2
gentoo-c671b43a.zip
media-gfx/sfftobmp: port to EAPI 8
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--media-gfx/sfftobmp/files/sfftobmp-3.1.1-gcc44-and-boost-1_37.patch17
-rw-r--r--media-gfx/sfftobmp/files/sfftobmp-3.1.2-Wformat.patch11
-rw-r--r--media-gfx/sfftobmp/files/sfftobmp-3.1.2-boost_fs3.patch4
-rw-r--r--media-gfx/sfftobmp/sfftobmp-3.1.2-r1.ebuild32
4 files changed, 39 insertions, 25 deletions
diff --git a/media-gfx/sfftobmp/files/sfftobmp-3.1.1-gcc44-and-boost-1_37.patch b/media-gfx/sfftobmp/files/sfftobmp-3.1.1-gcc44-and-boost-1_37.patch
index 3ba832afaed6..226b717431de 100644
--- a/media-gfx/sfftobmp/files/sfftobmp-3.1.1-gcc44-and-boost-1_37.patch
+++ b/media-gfx/sfftobmp/files/sfftobmp-3.1.1-gcc44-and-boost-1_37.patch
@@ -1,8 +1,5 @@
-Only in sfftobmp3_1_1: Makefile.am.orig
-Only in sfftobmp3_1_1: Makefile.am.rej
-diff -ur sfftobmp3_1_1.orig/src/cmdline.cpp sfftobmp3_1_1/src/cmdline.cpp
---- sfftobmp3_1_1.orig/src/cmdline.cpp 2007-10-07 22:01:21.000000000 +0300
-+++ sfftobmp3_1_1/src/cmdline.cpp 2009-05-09 00:33:06.000000000 +0300
+--- a/src/cmdline.cpp
++++ b/src/cmdline.cpp
@@ -35,6 +35,7 @@
---RCS-Info--------------------------------------------------*/
@@ -11,9 +8,8 @@ diff -ur sfftobmp3_1_1.orig/src/cmdline.cpp sfftobmp3_1_1/src/cmdline.cpp
#include <vector>
#include <cassert>
#include <iostream>
-diff -ur sfftobmp3_1_1.orig/src/common.cpp sfftobmp3_1_1/src/common.cpp
---- sfftobmp3_1_1.orig/src/common.cpp 2007-10-07 22:01:20.000000000 +0300
-+++ sfftobmp3_1_1/src/common.cpp 2009-05-09 00:28:37.000000000 +0300
+--- a/src/common.cpp
++++ b/src/common.cpp
@@ -49,6 +49,7 @@
#include <sys/utime.h>
#endif
@@ -22,9 +18,8 @@ diff -ur sfftobmp3_1_1.orig/src/common.cpp sfftobmp3_1_1/src/common.cpp
#include <cassert>
#include <iostream>
-diff -ur sfftobmp3_1_1.orig/src/Makefile.am sfftobmp3_1_1/src/Makefile.am
---- sfftobmp3_1_1.orig/src/Makefile.am 2006-10-24 23:14:19.000000000 +0300
-+++ sfftobmp3_1_1/src/Makefile.am 2009-05-09 00:27:42.000000000 +0300
+--- a/src/Makefile.am
++++ b/src/Makefile.am
@@ -3,4 +3,4 @@
INCLUDES = -I$(top_builddir) -I$(top_srcdir)
bin_PROGRAMS = sfftobmp
diff --git a/media-gfx/sfftobmp/files/sfftobmp-3.1.2-Wformat.patch b/media-gfx/sfftobmp/files/sfftobmp-3.1.2-Wformat.patch
new file mode 100644
index 000000000000..a7ab1c185751
--- /dev/null
+++ b/media-gfx/sfftobmp/files/sfftobmp-3.1.2-Wformat.patch
@@ -0,0 +1,11 @@
+--- a/src/output.cpp
++++ b/src/output.cpp
+@@ -163,7 +163,7 @@
+ m_pFile->Write(acBuf, strlen(acBuf));
+ sprintf(acBuf, "%s", "# generated with SffToBmp\n");
+ m_pFile->Write(acBuf, strlen(acBuf));
+- sprintf(acBuf, "%ld %ld\n", aWidth, aHeight);
++ sprintf(acBuf, "%u %u\n", aWidth, aHeight);
+ m_pFile->Write(acBuf, strlen(acBuf));
+ }
+
diff --git a/media-gfx/sfftobmp/files/sfftobmp-3.1.2-boost_fs3.patch b/media-gfx/sfftobmp/files/sfftobmp-3.1.2-boost_fs3.patch
index f39d157e1972..7ae13855def7 100644
--- a/media-gfx/sfftobmp/files/sfftobmp-3.1.2-boost_fs3.patch
+++ b/media-gfx/sfftobmp/files/sfftobmp-3.1.2-boost_fs3.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/425364
---- src/cmdline.cpp
-+++ src/cmdline.cpp
+--- a/src/cmdline.cpp
++++ b/src/cmdline.cpp
@@ -264,14 +264,14 @@
}
do {
diff --git a/media-gfx/sfftobmp/sfftobmp-3.1.2-r1.ebuild b/media-gfx/sfftobmp/sfftobmp-3.1.2-r1.ebuild
index 4f2ebeb017fe..1bc93102d377 100644
--- a/media-gfx/sfftobmp/sfftobmp-3.1.2-r1.ebuild
+++ b/media-gfx/sfftobmp/sfftobmp-3.1.2-r1.ebuild
@@ -1,37 +1,45 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools epatch flag-o-matic
+EAPI=8
+
+inherit autotools flag-o-matic
MY_P=${PN}${PV//./_}
DESCRIPTION="sff to bmp converter"
HOMEPAGE="http://sfftools.sourceforge.net/"
SRC_URI="mirror://sourceforge/sfftools/${MY_P}_src.zip"
+S="${WORKDIR}/${MY_P}"
LICENSE="HPND MIT"
SLOT="0"
KEYWORDS="amd64 ~hppa ppc x86"
-IUSE=""
-RDEPEND=">=dev-libs/boost-1.49
+RDEPEND="
+ dev-libs/boost:=
media-libs/tiff:0
virtual/jpeg:0"
-DEPEND="${RDEPEND}
- app-arch/unzip"
+DEPEND="${RDEPEND}"
+BDEPEND="app-arch/unzip"
-S=${WORKDIR}/${MY_P}
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.1.1-gcc44-and-boost-1_37.patch
+ "${FILESDIR}"/${PN}-3.1.2-boost_fs3.patch
+ "${FILESDIR}"/${PN}-3.1.2-Wformat.patch
+)
src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-3.1.1-gcc44-and-boost-1_37.patch \
- "${FILESDIR}"/${PN}-3.1.2-boost_fs3.patch
- append-cppflags -DBOOST_FILESYSTEM_VERSION=3
+ default
eautoreconf
}
+src_configure() {
+ append-cppflags -DBOOST_FILESYSTEM_VERSION=3
+ default
+}
+
src_install() {
- emake DESTDIR="${D}" install
+ default
dodoc doc/{changes,credits,readme}
}