summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-07-18 00:35:30 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-07-18 01:14:51 -0400
commitc68e16f09df0e8228802e35151f10363a7b97662 (patch)
treea99c69d72109684369aa5a6ff3afedfb7da580d2
parentgames-rpg/pcgen: add 6.06.01 (diff)
downloadgentoo-c68e16f09df0e8228802e35151f10363a7b97662.tar.gz
gentoo-c68e16f09df0e8228802e35151f10363a7b97662.tar.bz2
gentoo-c68e16f09df0e8228802e35151f10363a7b97662.zip
games-rpg/avadon: EAPI 6->7, tidy a bit
Do not own this game, so only doing (hopefully) safe changes. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild b/games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild
index 4a9ff4f3cecd..794827ce5ff1 100644
--- a/games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild
+++ b/games-rpg/avadon/avadon-1.0.4_p1331768904.ebuild
@@ -1,26 +1,26 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit desktop gnome2-utils unpacker
+inherit desktop unpacker
DESCRIPTION="Epic fantasy role-playing adventure in an enormous and unique world"
HOMEPAGE="https://www.spiderwebsoftware.com/avadon"
SRC_URI="avadon-linux-${PV#*_p}-bin.txt" # .txt is odd but that's what Humble Bundle sends.
+S="${WORKDIR}/data"
+
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
-RESTRICT="fetch bindist"
+RESTRICT="bindist fetch"
QA_PREBUILT="opt/${PN}/Avadon"
-RDEPEND="media-libs/libsdl[opengl,video]
+RDEPEND="
+ media-libs/libsdl[opengl,video]
media-libs/openal"
-
-DEPEND="app-arch/unzip"
-
-S="${WORKDIR}/data"
+BDEPEND="app-arch/unzip"
pkg_nofetch() {
einfo "Please buy and download ${SRC_URI} from:"
@@ -35,19 +35,15 @@ src_unpack() {
src_install() {
local dir=/opt/${PN}
- insinto "${dir}"
+ insinto ${dir}
doins -r "avadon files" icon.bmp
- exeinto "${dir}"
+ exeinto ${dir}
newexe Avadon-$(usex amd64 amd64 x86) Avadon
- dosym "../..${dir}"/Avadon /usr/bin/${PN}
+ dosym ../..${dir}/Avadon /usr/bin/${PN}
- newicon -s 512 Avadon.png ${PN}.png
+ newicon Avadon.png ${PN}.png
make_desktop_entry ${PN} "Avadon: The Black Fortress"
dodoc README-linux.txt
}
-
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }