summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-18 23:01:16 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-18 23:44:26 +0100
commitc69d21e8dc810e15600cdc4206f78f011112d115 (patch)
tree10cf585323a5423db0702e0b2cf8ab9a5196c2a1
parentdev-python/sphinx-autodoc-typehints: Bump to 1.15.3 (diff)
downloadgentoo-c69d21e8.tar.gz
gentoo-c69d21e8.tar.bz2
gentoo-c69d21e8.zip
dev-python/frozenlist: Bump to 1.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/frozenlist/Manifest1
-rw-r--r--dev-python/frozenlist/frozenlist-1.3.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/frozenlist/Manifest b/dev-python/frozenlist/Manifest
index bf51b5a40783..b1b0399d6861 100644
--- a/dev-python/frozenlist/Manifest
+++ b/dev-python/frozenlist/Manifest
@@ -1 +1,2 @@
DIST frozenlist-1.2.0.gh.tar.gz 29062 BLAKE2B cc82db759906ad3e0be1806cacd6815377f264ed07ed272abb7da4753c11561564cf1cb4dfc0154abaeb4005f5607c26e602410a4ef45dd8e94e26583caa2ab7 SHA512 e5dda13e173db0b1c6e8c5a61949534f4eb30211cc4fcd102d0be1b55ee48e2db90d52fd770a2c6d6076f3a0d9e11289629a7a115c1270377636eda35d107e7a
+DIST frozenlist-1.3.0.gh.tar.gz 27669 BLAKE2B d09e18455893f7ede59c37a080e79ea5e085cc3362e53bc7016db64338b2cf26baf44e95ec0c691535527b0eef4a40ec1fbe814e5d4ae238300125438d21b467 SHA512 780f0ec0e1a701b009e5afcd7f62b2950eda5365140ad5842c09db85b0a3cf282ab70ff9ba752ea6dc7a97542fc7399023aaaca8fdd8ecbd5c26bf64f305f5f4
diff --git a/dev-python/frozenlist/frozenlist-1.3.0.ebuild b/dev-python/frozenlist/frozenlist-1.3.0.ebuild
new file mode 100644
index 000000000000..40b055eeefa2
--- /dev/null
+++ b/dev-python/frozenlist/frozenlist-1.3.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="A list-like structure which implements collections.abc.MutableSequence"
+HOMEPAGE="
+ https://pypi.org/project/frozenlist/
+ https://github.com/aio-libs/frozenlist/"
+SRC_URI="
+ https://github.com/aio-libs/frozenlist/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+BDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/cython[${PYTHON_USEDEP}]
+ ' 'python*')"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/addopts/d' pytest.ini || die
+ distutils-r1_src_prepare
+}
+
+python_configure() {
+ # pypy is not using the C extension
+ if [[ ${EPYTHON} == python* ]]; then
+ > .install-cython || die
+ emake cythonize
+ fi
+}