summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-08-28 09:20:17 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-08-28 11:15:59 +0300
commitc6d9742b85bc233bf29b6f4308ba5089609f749b (patch)
tree1badfe66471241c1bc8249bebc54af66b448bb80
parentdev-python/sphinx-aiohttp-theme: enable py3.10 (diff)
downloadgentoo-c6d9742b85bc233bf29b6f4308ba5089609f749b.tar.gz
gentoo-c6d9742b85bc233bf29b6f4308ba5089609f749b.tar.bz2
gentoo-c6d9742b85bc233bf29b6f4308ba5089609f749b.zip
dev-python/sphinxcontrib-spelling: enable py3.10
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild17
1 files changed, 5 insertions, 12 deletions
diff --git a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
index 668e2c8538ae..e499df72fce5 100644
--- a/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
+++ b/dev-python/sphinxcontrib-spelling/sphinxcontrib-spelling-7.2.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
@@ -16,9 +16,6 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux"
RDEPEND="
- $(python_gen_cond_dep '
- >=dev-python/importlib_metadata-1.7.0[${PYTHON_USEDEP}]
- ' python3_{6,7})
dev-python/pyenchant[${PYTHON_USEDEP}]
dev-python/sphinx[${PYTHON_USEDEP}]
"
@@ -32,6 +29,10 @@ BDEPEND="
# The doc can only be built from a git repository
distutils_enable_tests pytest
+EPYTEST_DESELECT=(
+ tests/test_filter.py::test_contributors
+)
+
# We don't want distutils_enable_tests to add the namespace
# package to BDEPEND under "test?". Therefore we add it to RDEPEND
# after running distutils_enable_tests.
@@ -39,14 +40,6 @@ RDEPEND+="
dev-python/namespace-sphinxcontrib[${PYTHON_USEDEP}]
"
-python_test() {
- local deselect=(
- tests/test_filter.py::test_contributors
- )
-
- epytest ${deselect[@]/#/--deselect }
-}
-
python_install_all() {
distutils-r1_python_install_all
find "${ED}" -name '*.pth' -delete || die