summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 08:06:03 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 08:34:08 +0200
commitc6dd558a37a00570b87e60328780729682d954c8 (patch)
tree666501b5aaf2cc8886f781adffd52c8c6a52de34
parentdev-python/pkgconfig: Enable py3.11 (diff)
downloadgentoo-c6dd558a.tar.gz
gentoo-c6dd558a.tar.bz2
gentoo-c6dd558a.zip
dev-python/lz4: Bump to 4.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lz4/Manifest1
-rw-r--r--dev-python/lz4/lz4-4.0.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/lz4/Manifest b/dev-python/lz4/Manifest
index 43834ab0a337..f2cbe6f71ed6 100644
--- a/dev-python/lz4/Manifest
+++ b/dev-python/lz4/Manifest
@@ -1 +1,2 @@
DIST lz4-4.0.0.tar.gz 163729 BLAKE2B ce617f2aea3f45cf9fb0bf642599a1d872d9532ab465d32602b63987081a7e78ab4ac4373a41c6a97ec50eb6f2debc078288554966390651325ba166faa79c0d SHA512 885d215dd4caadc84d1e2a9575be9972a33a43af089f0788192c9f4f53382c0937f9d67aac412e2860c9ba393ee3bb15dfe273865acb6a3cf8aecdce8292ecc9
+DIST lz4-4.0.1.tar.gz 164309 BLAKE2B 6338c2d74dedf1dc92f455378ef87c691291fdd16faebff8992aa927bf95c707b346af6bb35c512d8095b60a1878615d1081ba64f99c083e580eeacfb5cf11a5 SHA512 caa08a8a531ca2887ce7e596b7a3d9d8f8f2b93c6ea48c3fb0f8bbe6e6f2a18fb6b3c055e57841f8ce74f70367738a28dbb5fb1f07cbf785434642e6034b558e
diff --git a/dev-python/lz4/lz4-4.0.1.ebuild b/dev-python/lz4/lz4-4.0.1.ebuild
new file mode 100644
index 000000000000..55d987ab74fc
--- /dev/null
+++ b/dev-python/lz4/lz4-4.0.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ app-arch/lz4:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # lz4.stream is not officially supported and not installed by default
+ # (we do not support installing it at the moment)
+ tests/stream
+)