summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-11-04 00:22:56 +0000
committerSam James <sam@gentoo.org>2022-11-04 00:23:25 +0000
commitc6e1c019205cf536a6522e9d99acbaa05873d8a7 (patch)
tree37b6f8a3e468f605fd4387c5f4c67e040e94eeef
parentwww-plugins/pdfjs: drop 2.10.377 (diff)
downloadgentoo-c6e1c019.tar.gz
gentoo-c6e1c019.tar.bz2
gentoo-c6e1c019.zip
dev-python/scipy: fix pkg_setup optionality for fortran, rename USE=pythran
This still doesn't fix USE=-fortran builds, but reported that upstream now. Bug: https://bugs.gentoo.org/878361 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/scipy/scipy-1.9.3.ebuild7
-rw-r--r--dev-python/scipy/scipy-1.9.9999.ebuild7
2 files changed, 8 insertions, 6 deletions
diff --git a/dev-python/scipy/scipy-1.9.3.ebuild b/dev-python/scipy/scipy-1.9.3.ebuild
index 3b6adf392e6b..0f38a0cb37a1 100644
--- a/dev-python/scipy/scipy-1.9.3.ebuild
+++ b/dev-python/scipy/scipy-1.9.3.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+FORTRAN_NEEDED=fortran
DISTUTILS_USE_PEP517=meson-python
PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="threads(+)"
@@ -44,7 +45,7 @@ fi
LICENSE="BSD LGPL-2"
SLOT="0"
-IUSE="doc +pythran"
+IUSE="doc +fortran"
# umfpack is technically optional but it's preferred to have it available.
DEPEND="
@@ -66,7 +67,7 @@ BDEPEND="
dev-util/patchelf
virtual/pkgconfig
doc? ( app-arch/unzip )
- pythran? ( dev-python/pythran[${PYTHON_USEDEP}] )
+ fortran? ( dev-python/pythran[${PYTHON_USEDEP}] )
test? ( dev-python/pytest-xdist[${PYTHON_USEDEP}] )"
PATCHES=(
@@ -89,7 +90,7 @@ src_unpack() {
}
python_configure_all() {
- export SCIPY_USE_PYTHRAN=$(usex pythran 1 0)
+ export SCIPY_USE_PYTHRAN=$(usex fortran 1 0)
}
python_test() {
diff --git a/dev-python/scipy/scipy-1.9.9999.ebuild b/dev-python/scipy/scipy-1.9.9999.ebuild
index 3b6adf392e6b..0f38a0cb37a1 100644
--- a/dev-python/scipy/scipy-1.9.9999.ebuild
+++ b/dev-python/scipy/scipy-1.9.9999.ebuild
@@ -3,6 +3,7 @@
EAPI=8
+FORTRAN_NEEDED=fortran
DISTUTILS_USE_PEP517=meson-python
PYTHON_COMPAT=( python3_{8..11} )
PYTHON_REQ_USE="threads(+)"
@@ -44,7 +45,7 @@ fi
LICENSE="BSD LGPL-2"
SLOT="0"
-IUSE="doc +pythran"
+IUSE="doc +fortran"
# umfpack is technically optional but it's preferred to have it available.
DEPEND="
@@ -66,7 +67,7 @@ BDEPEND="
dev-util/patchelf
virtual/pkgconfig
doc? ( app-arch/unzip )
- pythran? ( dev-python/pythran[${PYTHON_USEDEP}] )
+ fortran? ( dev-python/pythran[${PYTHON_USEDEP}] )
test? ( dev-python/pytest-xdist[${PYTHON_USEDEP}] )"
PATCHES=(
@@ -89,7 +90,7 @@ src_unpack() {
}
python_configure_all() {
- export SCIPY_USE_PYTHRAN=$(usex pythran 1 0)
+ export SCIPY_USE_PYTHRAN=$(usex fortran 1 0)
}
python_test() {