summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-05-14 18:02:23 +0200
committerDavid Seifert <soap@gentoo.org>2023-05-14 18:02:23 +0200
commitc6e5b4b23706b8af8fd9743bce842b9b7f215ce9 (patch)
treeedfef4245d0e205bb4918580734b87b0d08c50b1
parentdev-vcs/colorcvs: update EAPI 6 -> 8 (diff)
downloadgentoo-c6e5b4b23706b8af8fd9743bce842b9b7f215ce9.tar.gz
gentoo-c6e5b4b23706b8af8fd9743bce842b9b7f215ce9.tar.bz2
gentoo-c6e5b4b23706b8af8fd9743bce842b9b7f215ce9.zip
dev-vcs/colorsvn: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-vcs/colorsvn/colorsvn-0.3.3-r1.ebuild (renamed from dev-vcs/colorsvn/colorsvn-0.3.3.ebuild)24
-rw-r--r--dev-vcs/colorsvn/files/colorsvn-0.3.3-prefix-fhs.patch37
-rw-r--r--dev-vcs/colorsvn/files/colorsvn-0.3.3-use-open2-not-open3.patch (renamed from dev-vcs/colorsvn/files/use-open2-not-open3.patch)4
3 files changed, 47 insertions, 18 deletions
diff --git a/dev-vcs/colorsvn/colorsvn-0.3.3.ebuild b/dev-vcs/colorsvn/colorsvn-0.3.3-r1.ebuild
index ef47c0be9bd2..0aaf21156588 100644
--- a/dev-vcs/colorsvn/colorsvn-0.3.3.ebuild
+++ b/dev-vcs/colorsvn/colorsvn-0.3.3-r1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
DESCRIPTION="Subversion output colorizer"
HOMEPAGE="http://colorsvn.tigris.org"
@@ -10,22 +10,16 @@ SRC_URI="http://colorsvn.tigris.org/files/documents/4414/49311/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ~x64-macos"
-IUSE=""
-RDEPEND="dev-lang/perl
+RDEPEND="
+ dev-lang/perl
dev-vcs/subversion"
-DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}/use-open2-not-open3.patch" )
-
-src_prepare() {
- default
- # Fix confdir location for Prefix, #435434
- sed -i \
- -e '/^confdir/d' \
- -e 's/$(confdir)/$(sysconfdir)/g' \
- Makefile.in || die
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-use-open2-not-open3.patch
+ "${FILESDIR}"/${P}-prefix-fhs.patch
+)
src_compile() {
# bug 335134
diff --git a/dev-vcs/colorsvn/files/colorsvn-0.3.3-prefix-fhs.patch b/dev-vcs/colorsvn/files/colorsvn-0.3.3-prefix-fhs.patch
new file mode 100644
index 000000000000..e379372d40b0
--- /dev/null
+++ b/dev-vcs/colorsvn/files/colorsvn-0.3.3-prefix-fhs.patch
@@ -0,0 +1,37 @@
+Fix confdir location for Prefix
+https://bugs.gentoo.org/435434
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -13,7 +13,6 @@
+ mandir=@mandir@
+ sysconfdir=@sysconfdir@
+
+-confdir=/etc
+
+ CP=@CP@
+ PERL=@PERL@
+@@ -36,10 +35,10 @@
+ install: colorsvn
+ $(INSTALL) -d $(DESTDIR)$(bindir) && \
+ $(INSTALL) -m 755 $(PACKAGE) $(DESTDIR)$(bindir)/$(PACKAGE) && \
+- $(INSTALL) -d $(DESTDIR)/$(confdir) && \
+- $(INSTALL) -m 644 $(CONFIGFILE) $(DESTDIR)/$(confdir)/$(CONFIGFILE) && \
+- $(INSTALL) -d $(DESTDIR)/$(confdir)/profile.d && \
+- $(INSTALL) -m 755 $(PROFFILE) $(DESTDIR)/$(confdir)/profile.d/$(PROFFILE) && \
++ $(INSTALL) -d $(DESTDIR)/$(sysconfdir) && \
++ $(INSTALL) -m 644 $(CONFIGFILE) $(DESTDIR)/$(sysconfdir)/$(CONFIGFILE) && \
++ $(INSTALL) -d $(DESTDIR)/$(sysconfdir)/profile.d && \
++ $(INSTALL) -m 755 $(PROFFILE) $(DESTDIR)/$(sysconfdir)/profile.d/$(PROFFILE) && \
+ if [ -f $(srcdir)/colorsvn.1 ] ; then \
+ $(INSTALL) -d $(DESTDIR)$(mandir)/man1/ ; \
+ $(INSTALL) -m 644 $(srcdir)/colorsvn.1 $(DESTDIR)$(mandir)/man1/ ; \
+@@ -54,6 +53,6 @@
+
+ uninstall:
+ $(RM) $(DESTDIR)$(bindir)/$(PACKAGE) && \
+- $(RM) $(DESTDIR)/$(confdir)/$(CONFIGFILE) && \
+- $(RM) $(DESTDIR)/$(confdir)/profile.d/$(PROFFILE)
++ $(RM) $(DESTDIR)/$(sysconfdir)/$(CONFIGFILE) && \
++ $(RM) $(DESTDIR)/$(sysconfdir)/profile.d/$(PROFFILE)
+
diff --git a/dev-vcs/colorsvn/files/use-open2-not-open3.patch b/dev-vcs/colorsvn/files/colorsvn-0.3.3-use-open2-not-open3.patch
index cb295dc15878..32757fb9e95e 100644
--- a/dev-vcs/colorsvn/files/use-open2-not-open3.patch
+++ b/dev-vcs/colorsvn/files/colorsvn-0.3.3-use-open2-not-open3.patch
@@ -1,7 +1,5 @@
-This is idl0r's fix for bug 326279, rerolled for v0.3.3.
+https://bugs.gentoo.org/326279
-diff --git a/colorsvn-original b/colorsvn-original
-index 4236121..4edf3c8 100644
--- a/colorsvn-original
+++ b/colorsvn-original
@@ -56,7 +56,7 @@