summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPPed72 <paolo.pedroni@iol.it>2018-07-06 15:18:35 +0200
committerMichał Górny <mgorny@gentoo.org>2018-07-10 23:15:22 +0200
commitc74caf635cd0485b39e9be44d00a01c740789848 (patch)
treeccc6fdd34ca6c5f5a7507e8b13a4bc9c11a83704
parentmedia-video/vlc: Drop no-op USE=microdns (diff)
downloadgentoo-c74caf635cd0485b39e9be44d00a01c740789848.tar.gz
gentoo-c74caf635cd0485b39e9be44d00a01c740789848.tar.bz2
gentoo-c74caf635cd0485b39e9be44d00a01c740789848.zip
dev-python/slimit: revbump to silence warning on module import
Closes: https://bugs.gentoo.org/660510 Closes: https://github.com/gentoo/gentoo/pull/9068 Package-Manager: Portage-2.3.40, Repoman-2.3.9
-rw-r--r--dev-python/slimit/slimit-0.8.1-r1.ebuild (renamed from dev-python/slimit/slimit-0.8.1.ebuild)13
1 files changed, 12 insertions, 1 deletions
diff --git a/dev-python/slimit/slimit-0.8.1.ebuild b/dev-python/slimit/slimit-0.8.1-r1.ebuild
index 6eb5f29a6146..b4561d3f8de2 100644
--- a/dev-python/slimit/slimit-0.8.1.ebuild
+++ b/dev-python/slimit/slimit-0.8.1-r1.ebuild
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="test"
-RDEPEND="dev-python/ply[${PYTHON_USEDEP}]
+RDEPEND="dev-python/ply:=[${PYTHON_USEDEP}]
dev-python/setuptools[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
test? (
@@ -25,6 +25,17 @@ DEPEND="${RDEPEND}
PATCHES=( "${FILESDIR}/${P}-fix-python3.patch" )
+python_compile() {
+ distutils-r1_python_compile
+
+ rm "${BUILD_DIR}"/lib/slimit/*tab.py || die
+
+ # Regenerate yacctab.py and lextab.py files to avoid warnings whenever
+ # the module is imported. See https://github.com/rspivak/slimit/issues/97
+ # for details
+ "${EPYTHON}" -B -c 'import slimit;slimit.minify("")' || die
+}
+
python_test() {
esetup.py pytest --addopts "${BUILD_DIR}" || die "Testing failed with ${EPYTHON}"
}