summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-17 20:36:22 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-18 14:23:30 +0100
commitc7529dec37244b0ec42848d1fe4effe70b9f4cf9 (patch)
tree1b4ddf530ad26395ca3d782e828eaf6737ac1def
parentsys-devel/llvm: Fix myst-parser dep for manpage builds in 18+ (diff)
downloadgentoo-c7529dec.tar.gz
gentoo-c7529dec.tar.bz2
gentoo-c7529dec.zip
sys-devel/clang: Fix missing myst-parser dep for manpage builds
Bug: https://bugs.gentoo.org/924706 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--sys-devel/clang/clang-18.1.0_rc2.ebuild13
-rw-r--r--sys-devel/clang/clang-19.0.0.9999.ebuild13
-rw-r--r--sys-devel/clang/clang-19.0.0_pre20240210.ebuild13
3 files changed, 27 insertions, 12 deletions
diff --git a/sys-devel/clang/clang-18.1.0_rc2.ebuild b/sys-devel/clang/clang-18.1.0_rc2.ebuild
index d351f9774a48..189ad24d33b1 100644
--- a/sys-devel/clang/clang-18.1.0_rc2.ebuild
+++ b/sys-devel/clang/clang-18.1.0_rc2.ebuild
@@ -33,10 +33,6 @@ RDEPEND="
"
BDEPEND="
${PYTHON_DEPS}
- doc? ( $(python_gen_cond_dep '
- dev-python/myst-parser[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- ') )
xml? ( virtual/pkgconfig )
"
PDEPEND="
@@ -55,6 +51,15 @@ LLVM_TEST_COMPONENTS=(
LLVM_USE_TARGETS=llvm
llvm.org_set_globals
+[[ -n ${LLVM_MANPAGE_DIST} ]] && BDEPEND+=" doc? ( "
+BDEPEND+="
+ $(python_gen_cond_dep '
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+"
+[[ -n ${LLVM_MANPAGE_DIST} ]] && BDEPEND+=" ) "
+
# Multilib notes:
# 1. ABI_* flags control ABIs libclang* is built for only.
# 2. clang is always capable of compiling code for all ABIs for enabled
diff --git a/sys-devel/clang/clang-19.0.0.9999.ebuild b/sys-devel/clang/clang-19.0.0.9999.ebuild
index d351f9774a48..189ad24d33b1 100644
--- a/sys-devel/clang/clang-19.0.0.9999.ebuild
+++ b/sys-devel/clang/clang-19.0.0.9999.ebuild
@@ -33,10 +33,6 @@ RDEPEND="
"
BDEPEND="
${PYTHON_DEPS}
- doc? ( $(python_gen_cond_dep '
- dev-python/myst-parser[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- ') )
xml? ( virtual/pkgconfig )
"
PDEPEND="
@@ -55,6 +51,15 @@ LLVM_TEST_COMPONENTS=(
LLVM_USE_TARGETS=llvm
llvm.org_set_globals
+[[ -n ${LLVM_MANPAGE_DIST} ]] && BDEPEND+=" doc? ( "
+BDEPEND+="
+ $(python_gen_cond_dep '
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+"
+[[ -n ${LLVM_MANPAGE_DIST} ]] && BDEPEND+=" ) "
+
# Multilib notes:
# 1. ABI_* flags control ABIs libclang* is built for only.
# 2. clang is always capable of compiling code for all ABIs for enabled
diff --git a/sys-devel/clang/clang-19.0.0_pre20240210.ebuild b/sys-devel/clang/clang-19.0.0_pre20240210.ebuild
index d351f9774a48..189ad24d33b1 100644
--- a/sys-devel/clang/clang-19.0.0_pre20240210.ebuild
+++ b/sys-devel/clang/clang-19.0.0_pre20240210.ebuild
@@ -33,10 +33,6 @@ RDEPEND="
"
BDEPEND="
${PYTHON_DEPS}
- doc? ( $(python_gen_cond_dep '
- dev-python/myst-parser[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
- ') )
xml? ( virtual/pkgconfig )
"
PDEPEND="
@@ -55,6 +51,15 @@ LLVM_TEST_COMPONENTS=(
LLVM_USE_TARGETS=llvm
llvm.org_set_globals
+[[ -n ${LLVM_MANPAGE_DIST} ]] && BDEPEND+=" doc? ( "
+BDEPEND+="
+ $(python_gen_cond_dep '
+ dev-python/myst-parser[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ ')
+"
+[[ -n ${LLVM_MANPAGE_DIST} ]] && BDEPEND+=" ) "
+
# Multilib notes:
# 1. ABI_* flags control ABIs libclang* is built for only.
# 2. clang is always capable of compiling code for all ABIs for enabled