summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-09-16 00:20:38 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-09-16 00:39:28 +0200
commitc75350d290e3c1c35036e7896f894bd5d4d7b7f5 (patch)
tree3bcc616385715b11966943ebdfe0d7033fdf6975
parentsys-fs/eudev: remove older version (diff)
downloadgentoo-c75350d2.tar.gz
gentoo-c75350d2.tar.bz2
gentoo-c75350d2.zip
media-libs/waffle: Bump live to EAPI-6, switch to git-r3
Sort deps, drop implicit inherit, consolidate 9999/non-9999 conditionals. Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--media-libs/waffle/waffle-9999.ebuild49
1 files changed, 20 insertions, 29 deletions
diff --git a/media-libs/waffle/waffle-9999.ebuild b/media-libs/waffle/waffle-9999.ebuild
index 23384f2ecadf..dc2a60608875 100644
--- a/media-libs/waffle/waffle-9999.ebuild
+++ b/media-libs/waffle/waffle-9999.ebuild
@@ -1,26 +1,20 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-EGIT_REPO_URI="https://github.com/waffle-gl/${PN}.git"
-
-if [[ ${PV} = 9999* ]]; then
- GIT_ECLASS="git-2"
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/waffle-gl/${PN}.git"
+ GIT_ECLASS="git-r3"
+else
+ SRC_URI="https://people.freedesktop.org/~chadversary/${PN}/files/release/${P}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
fi
-
-inherit cmake-utils cmake-multilib ${GIT_ECLASS}
+inherit cmake-multilib ${GIT_ECLASS}
DESCRIPTION="Library that allows selection of GL API and of window system at runtime"
HOMEPAGE="https://people.freedesktop.org/~chadversary/waffle/"
-if [[ $PV = 9999* ]]; then
- KEYWORDS=""
-else
- SRC_URI="https://people.freedesktop.org/~chadversary/${PN}/files/release/${P}/${P}.tar.xz"
- KEYWORDS="~amd64 ~arm ~x86"
-fi
-
LICENSE="BSD-2"
SLOT="0"
IUSE="doc egl gbm test wayland"
@@ -28,31 +22,28 @@ IUSE="doc egl gbm test wayland"
RDEPEND="
>=media-libs/mesa-9.1.6[egl?,gbm?,${MULTILIB_USEDEP}]
>=virtual/opengl-7.0-r1[${MULTILIB_USEDEP}]
- wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )
- gbm? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
>=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
- >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]"
+ >=x11-libs/libxcb-1.9.1[${MULTILIB_USEDEP}]
+ gbm? ( >=virtual/libudev-208:=[${MULTILIB_USEDEP}] )
+ wayland? ( >=dev-libs/wayland-1.0.6[${MULTILIB_USEDEP}] )
+"
DEPEND="${RDEPEND}
>=x11-base/xcb-proto-1.8-r3[${MULTILIB_USEDEP}]
doc? (
dev-libs/libxslt
app-text/docbook-xml-dtd:4.2
- )"
-
-src_unpack() {
- default
- [[ $PV = 9999* ]] && git-2_src_unpack
-}
+ )
+"
src_configure() {
local mycmakeargs=(
-Dwaffle_has_glx=ON
-Dwaffle_build_examples=OFF
- $(cmake-utils_use doc waffle_build_manpages)
- $(cmake-utils_use egl waffle_has_x11_egl)
- $(cmake-utils_use gbm waffle_has_gbm)
- $(cmake-utils_use test waffle_build_tests)
- $(cmake-utils_use wayland waffle_has_wayland)
+ -Dwaffle_build_manpages=$(usex doc )
+ -Dwaffle_has_x11_egl=$(usex egl)
+ -Dwaffle_has_gbm=$(usex gbm)
+ -Dwaffle_build_tests=$(usex test)
+ -Dwaffle_has_wayland=$(usex wayland)
)
cmake-multilib_src_configure