summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-30 10:33:33 +0100
committerSam James <sam@gentoo.org>2022-07-30 10:33:36 +0100
commitc777f31282345233eee26152a9553dd05ae75f6a (patch)
treee7cd40c98702d9b0d6b4978ff1cb3c8539821432
parentapp-admin/awscli: add 1.25.41 (diff)
downloadgentoo-c777f312.tar.gz
gentoo-c777f312.tar.bz2
gentoo-c777f312.zip
dev-python/scipy: skip known test failures
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-python/scipy/scipy-1.9.0.ebuild5
-rw-r--r--dev-python/scipy/scipy-1.9.9999.ebuild5
2 files changed, 10 insertions, 0 deletions
diff --git a/dev-python/scipy/scipy-1.9.0.ebuild b/dev-python/scipy/scipy-1.9.0.ebuild
index 577f837b091c..ccb8c752ed10 100644
--- a/dev-python/scipy/scipy-1.9.0.ebuild
+++ b/dev-python/scipy/scipy-1.9.0.ebuild
@@ -70,6 +70,11 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.9.9999-meson-options-lapack.patch
)
+EPYTEST_DESELECT=(
+ linalg/tests/test_decomp.py::TestSchur::test_sort
+ linalg/tests/test_solvers.py::test_solve_discrete_are
+)
+
distutils_enable_tests pytest
python_test() {
diff --git a/dev-python/scipy/scipy-1.9.9999.ebuild b/dev-python/scipy/scipy-1.9.9999.ebuild
index 577f837b091c..ccb8c752ed10 100644
--- a/dev-python/scipy/scipy-1.9.9999.ebuild
+++ b/dev-python/scipy/scipy-1.9.9999.ebuild
@@ -70,6 +70,11 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.9.9999-meson-options-lapack.patch
)
+EPYTEST_DESELECT=(
+ linalg/tests/test_decomp.py::TestSchur::test_sort
+ linalg/tests/test_solvers.py::test_solve_discrete_are
+)
+
distutils_enable_tests pytest
python_test() {