summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2023-12-26 18:38:07 +0700
committerAndrey Grozin <grozin@gentoo.org>2023-12-26 18:38:07 +0700
commitc7810bdba04523ac774b591b40e7fc366e138249 (patch)
tree6f51b44ebf3eaa7fb31beea57387bc821f60c636
parentdev-ada/aws: block templates-parser (diff)
downloadgentoo-c7810bdba04523ac774b591b40e7fc366e138249.tar.gz
gentoo-c7810bdba04523ac774b591b40e7fc366e138249.tar.bz2
gentoo-c7810bdba04523ac774b591b40e7fc366e138249.zip
app-text/crqt-ng: bump to 1.0.12
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
-rw-r--r--app-text/crqt-ng/Manifest1
-rw-r--r--app-text/crqt-ng/crqt-ng-1.0.12.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/app-text/crqt-ng/Manifest b/app-text/crqt-ng/Manifest
index 112ee333ded4..b9ac89ace2d7 100644
--- a/app-text/crqt-ng/Manifest
+++ b/app-text/crqt-ng/Manifest
@@ -1 +1,2 @@
DIST crqt-ng-1.0.11.tar.bz2 442916 BLAKE2B 3eb4c73f1c3b3c88d92cb6ed5bf4895329caab1391c7be05dc0ccc1a65546f7761ee7af6246045be70137fd8683e2bfc5fb41df3dad604177ae4c0351f44c74e SHA512 62bb4b8a3dec3dd9fba5e1a2795f384e5310b87800d89e15b7f4fe258eb923481f1264ec23645b09f5ae89822e332d1499aeca0a79efab21124b43deec3ada44
+DIST crqt-ng-1.0.12.tar.bz2 443646 BLAKE2B 338c96a9c34d6a05ed6fa9cd1d6fe63665518e8c12e835a7fba22b81585116f9e579b326c9fc22a67d7225f0ca4cc15035179be923507b0af7032666f05d972e SHA512 24258c32dac6ba24833d7a6a227cef6dfb39ff415781921c90e57cd9c73ce187255bcffee3b38719b38dde2f6cb8a0569f5b25db88688c105f8b24246676207d
diff --git a/app-text/crqt-ng/crqt-ng-1.0.12.ebuild b/app-text/crqt-ng/crqt-ng-1.0.12.ebuild
new file mode 100644
index 000000000000..17278e64b54d
--- /dev/null
+++ b/app-text/crqt-ng/crqt-ng-1.0.12.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PLOCALES="bg cs hu nl ru uk"
+inherit cmake plocale xdg
+
+DESCRIPTION="Cross-platform e-book reader"
+HOMEPAGE="https://gitlab.com/coolreader-ng/crqt-ng"
+SRC_URI="https://gitlab.com/coolreader-ng/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+gif +svg +chm +harfbuzz +libunibreak +fribidi +zstd +libutf8proc"
+
+CDEPEND=">=app-text/crengine-ng-0.9.7:0=[png,jpeg,fontconfig,gif=,svg=,chm=,harfbuzz=,fribidi=,zstd=,libutf8proc=]
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5"
+RDEPEND="${CDEPEND}"
+BDEPEND="${CDEPEND}
+ dev-qt/linguist-tools:5"
+
+src_prepare() {
+ cmake_src_prepare
+ xdg_environment_reset
+
+ # locales
+ plocale_find_changes "${S}"/src/i18n 'crqt_' '.ts'
+ sed -e "s|set(LANGUAGES .*)|set(LANGUAGES $(plocale_get_locales))|i" \
+ -i "${S}"/src/CMakeLists.txt \
+ || die "sed CMakeLists.txt failed"
+}
+
+src_configure() {
+ CMAKE_USE_DIR="${S}"
+ CMAKE_BUILD_TYPE="Release"
+ local mycmakeargs=(-DUSE_QT=QT5)
+ cmake_src_configure
+}