summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-26 06:15:10 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-26 06:42:08 +0200
commitc78f372f5bca7f0db40a66bff206a7f330bb6b27 (patch)
treed4137980277c1ef43ccfa265f85d322f68a6096b
parentdev-python/google-api-core: Bump to 2.12.0 (diff)
downloadgentoo-c78f372f.tar.gz
gentoo-c78f372f.tar.bz2
gentoo-c78f372f.zip
dev-python/weasyprint: Bump to 60.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/weasyprint/Manifest1
-rw-r--r--dev-python/weasyprint/weasyprint-60.0.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index 05670d3eda90..c000e58b0975 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1 +1,2 @@
DIST weasyprint-59.0.tar.gz 438338 BLAKE2B 8cad25b3d5bc30d5c13ed550b9ddf40f7657689e80e75996bf8fddbd51cbe7a967824b22b1e81ed413a5bcd8371bca2ed7c00dd98da9dc2e3c3bc24aa45c3c5b SHA512 58f81a1b3e3f1315caebd08f2cb556c89cb1aa818c13310998e72c436479c1a0d10031c7792502970490e73bd6fd769c836bd4e87be384fd83179957e71496e1
+DIST weasyprint-60.0.tar.gz 440912 BLAKE2B d4bea67398e8f39ae2d51f6295ac696b4076c250ad24768bc19ecaa0eb09e88d505635f669e34dd77693c60e36f7d6e701a456a87ecc429f7fa534223ccef89f SHA512 94abcd19a5798395ba8f9c5ddde616e877b359e5938f2c0247bb61550889af14aa00b1093ac547ecc94bb3a733ef5604daf251dad41a8418778ffb0aa561ab8a
diff --git a/dev-python/weasyprint/weasyprint-60.0.ebuild b/dev-python/weasyprint/weasyprint-60.0.ebuild
new file mode 100644
index 000000000000..1fdac2dc5e5b
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-60.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="
+ https://weasyprint.org/
+ https://github.com/Kozea/WeasyPrint/
+ https://pypi.org/project/weasyprint/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.1[${PYTHON_USEDEP}]
+ >=dev-python/pillow-4.0.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.8.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.0.0[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ || (
+ >=app-text/ghostscript-gpl-9.56.1-r3
+ <app-text/ghostscript-gpl-9.56.0
+ )
+ media-fonts/ahem
+ )
+"
+
+distutils_enable_tests pytest