summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2020-05-28 14:57:57 +0300
committerJoonas Niilola <juippis@gentoo.org>2020-05-28 14:58:11 +0300
commitc79dc83abcca018e4d42af61e755ab5e24359f76 (patch)
tree1e1926ce31e631d556b51438195d223e9b203a15
parentllvm.eclass: Fix prepending LLVM path before system paths (diff)
downloadgentoo-c79dc83abcca018e4d42af61e755ab5e24359f76.tar.gz
gentoo-c79dc83abcca018e4d42af61e755ab5e24359f76.tar.bz2
gentoo-c79dc83abcca018e4d42af61e755ab5e24359f76.zip
net-misc/eventd: disable wayland support due to missing dep
Closes: https://bugs.gentoo.org/702820 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-misc/eventd/eventd-0.27.0-r1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/net-misc/eventd/eventd-0.27.0-r1.ebuild b/net-misc/eventd/eventd-0.27.0-r1.ebuild
index 5805963615d5..e533b5124a7e 100644
--- a/net-misc/eventd/eventd-0.27.0-r1.ebuild
+++ b/net-misc/eventd/eventd-0.27.0-r1.ebuild
@@ -13,8 +13,7 @@ LICENSE="GPL-3+ LGPL-3+ ISC MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug fbcon +introspection ipv6 libcanberra libnotify +notification
- pulseaudio purple speech systemd test upnp wayland webhook websocket
- +X zeroconf"
+ pulseaudio purple speech systemd test upnp webhook websocket +X zeroconf"
RESTRICT="!test? ( test )"
REQUIRED_USE="
@@ -51,7 +50,6 @@ COMMON_DEPEND="
speech? ( app-accessibility/speech-dispatcher )
systemd? ( sys-apps/systemd:= )
upnp? ( >=net-libs/gssdp-1.2:0= )
- wayland? ( dev-libs/wayland )
webhook? ( net-libs/libsoup:2.4 )
websocket? ( net-libs/libsoup:2.4 )
zeroconf? ( net-dns/avahi[dbus] )
@@ -78,17 +76,18 @@ pkg_setup() {
}
src_configure() {
+ # wayland disabled due to missing dep in ::gentoo, wayland-wall
local emesonargs=(
-Dsystemduserunitdir="$(systemd_get_userunitdir)"
-Dsystemdsystemunitdir="$(systemd_get_systemunitdir)"
-Ddbussessionservicedir="${EPREFIX}/usr/share/dbus-1/services"
+ -Dnd-wayland=false
$(meson_feature websocket)
$(meson_feature zeroconf dns-sd)
$(meson_feature upnp ssdp)
$(meson_use ipv6)
$(meson_use systemd)
$(meson_use notification notification-daemon)
- $(meson_use wayland nd-wayland)
$(meson_use X nd-xcb)
$(meson_use fbcon nd-fbdev)
$(meson_use purple im)