summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2022-11-03 13:59:05 -0700
committerPatrick McLean <chutzpah@gentoo.org>2022-11-03 13:59:48 -0700
commitc7a8cf1d75e09370f5b7c35fffc115d63a3bbbae (patch)
treeebf902683d3ff34f449e242ffc1fbbebf9504a6e
parentdev-java/logback-classic: add 1.4.1 enabling tests (diff)
downloadgentoo-c7a8cf1d.tar.gz
gentoo-c7a8cf1d.tar.bz2
gentoo-c7a8cf1d.zip
sys-libs/libnvme: Revbump, fix python deps (bug #878935), swig dep
Closes: https://bugs.gentoo.org/878935 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--sys-libs/libnvme/libnvme-1.2-r1.ebuild (renamed from sys-libs/libnvme/libnvme-1.2.ebuild)12
1 files changed, 9 insertions, 3 deletions
diff --git a/sys-libs/libnvme/libnvme-1.2.ebuild b/sys-libs/libnvme/libnvme-1.2-r1.ebuild
index ab243c0836c3..afe0173da916 100644
--- a/sys-libs/libnvme/libnvme-1.2.ebuild
+++ b/sys-libs/libnvme/libnvme-1.2-r1.ebuild
@@ -23,6 +23,10 @@ DEPEND="
"
RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-lang/swig
+"
+
REQUIRED_USE="
python? ( ${PYTHON_REQUIRED_USE} )
"
@@ -44,14 +48,16 @@ python_compile() {
src_compile() {
meson_src_compile
- python_copy_sources
- use python && python_foreach_impl python_compile
+ if use python; then
+ python_copy_sources
+ python_foreach_impl python_compile
+ fi
}
python_install() {
meson_src_install
- python_optimize
+ use python && python_optimize
}
src_install() {