summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-13 08:05:49 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-13 08:10:06 +0200
commitc7b91b8c83404ba255623b71b0be5137f957b8cb (patch)
treed9fac95ffcce6aa1d103ebde49ff687a0c0faa0c
parentdev-python/path-py: Bump to 16.0.0 (diff)
downloadgentoo-c7b91b8c.tar.gz
gentoo-c7b91b8c.tar.bz2
gentoo-c7b91b8c.zip
dev-python/requests-cache: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/requests-cache/Manifest4
-rw-r--r--dev-python/requests-cache/requests-cache-0.5.2.ebuild70
-rw-r--r--dev-python/requests-cache/requests-cache-0.6.0.ebuild68
-rw-r--r--dev-python/requests-cache/requests-cache-0.6.1.ebuild49
-rw-r--r--dev-python/requests-cache/requests-cache-0.6.2.ebuild49
5 files changed, 0 insertions, 240 deletions
diff --git a/dev-python/requests-cache/Manifest b/dev-python/requests-cache/Manifest
index 01307336593a..c504192b9645 100644
--- a/dev-python/requests-cache/Manifest
+++ b/dev-python/requests-cache/Manifest
@@ -1,6 +1,2 @@
-DIST requests-cache-0.5.2.tar.gz 31159 BLAKE2B 4fca146a751064baf70954a71df64dbb7f8c9a4e27fec5dbea3620496ce78e7ccfb3785fb63705f513ff6fa938376b0c6acc4a2f584856060b1bc8388517df46 SHA512 355cc571a46b768615606a907a69ed065b3c4b5e74bb6c311abc7a28d9406f32fdea1db0dfd2b1c32dcdc82ed817ef7e0b30086c069de57307254617604c5177
-DIST requests-cache-0.6.0.tar.gz 52342 BLAKE2B 12af89721fcf1ae2e4ab14d7ac377f119ef312c64d3b9e5d80a36f26f3a9a798cf090835ee2c9bf886d0baa9b472f4c439d5a032573d442feecbbad930c239fd SHA512 b5b32b9cb99ec51cee67defde715df66b7c50a26f4124cbaf893685048fe188af0cf664232150e3b4fafe3b7a927716966efafadd711be01118d67ad802acef6
-DIST requests-cache-0.6.1.gh.tar.gz 47919 BLAKE2B 022fd94a332feae043cf646cefc368fdb6ca1833dcd58621a07425bfb0d7bcb5ff9913c8b53f2bc0769fd23e8f364c437ee10f16fd37d1d340e8c46bcba9d53e SHA512 f8bea03b05b2f1e55fe6c975b5f5caacff55250d81f41cf953052c77101fc726ff39f9d95e1fd2829ddb59215226026bdddfd93918feb478395375ac0e0a4439
-DIST requests-cache-0.6.2.gh.tar.gz 47962 BLAKE2B f0597f3c5f4a678b94f3b15023e3aba5247de3d79043e7e1cbd4ab0f2d4457e2f5feab130665129ae87baba56576312b1420ae16c2a34b44dc780bf05351615c SHA512 c97119127b1e80e6eec02938b2e0e8de785875f46d348215e05ee2d668feb77ed40f0dad4ed4a3ae53fb8e6708c8d7b13788e54694a38cef3ce22e83f13f97e2
DIST requests-cache-0.6.3.gh.tar.gz 50303 BLAKE2B e8507a19f3883c050e1d819bf9ce8ebf720a5c6517e4004ecf745f5a197a8feac9cbca18ffa99001be0baffbad41d2ebfba5b63d90b55eda1d754d279242bbc6 SHA512 1fa801f60623dce0a5cd834272a74acf80b6ae52a602ae81fbd7e3653467800d9a58fb8220e30d53ef1b896aa01f2017f93dcbc2dacfd685ee9ae286f47077f5
DIST requests-cache-0.6.4.gh.tar.gz 50322 BLAKE2B c9a6cae957604bdfa6057621e028fad83476e5d918bbf9c58e73f09f8615398946f3cf6e3737c9ff916cba68d82ed66a674557fb733c74b874b0f68e2430d9a0 SHA512 31e2217e54892d8ec5fc9fcf60f650960621b1f97029c90deca925b9a1be9eb5a3ddb6ae68e581c805f20136f93eefa70d51e7e9f086ecbae76f8e550bbe3f1a
diff --git a/dev-python/requests-cache/requests-cache-0.5.2.ebuild b/dev-python/requests-cache/requests-cache-0.5.2.ebuild
deleted file mode 100644
index a64e64005f9e..000000000000
--- a/dev-python/requests-cache/requests-cache-0.5.2.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7,8,9} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-HOMEPAGE="https://pypi.org/project/requests-cache/"
-DESCRIPTION="Persistent cache for requests library"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-RDEPEND="dev-python/requests[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx docs
-distutils_enable_tests pytest
-
-src_prepare() {
- # Ships with incorrect mock import
- sed -e 's/import mock/import unittest.mock as mock/' -i tests/test_cache.py || die
- default
-}
-
-python_test() {
- local skipped_tests=(
- # Slew of tests that violate network-sandbox
- tests/test_cache.py::CacheTestCase::test_attr_from_cache_in_hook
- tests/test_cache.py::CacheTestCase::test_cache_unpickle_errors
- tests/test_cache.py::CacheTestCase::test_close_response
- tests/test_cache.py::CacheTestCase::test_content_and_cookies
- tests/test_cache.py::CacheTestCase::test_delete_urls
- tests/test_cache.py::CacheTestCase::test_disabled
- tests/test_cache.py::CacheTestCase::test_enabled
- tests/test_cache.py::CacheTestCase::test_expire_cache
- tests/test_cache.py::CacheTestCase::test_from_cache_attribute
- tests/test_cache.py::CacheTestCase::test_get_parameters_normalization
- tests/test_cache.py::CacheTestCase::test_get_params_as_argument
- tests/test_cache.py::CacheTestCase::test_gzip_response
- tests/test_cache.py::CacheTestCase::test_headers_in_get_query
- tests/test_cache.py::CacheTestCase::test_hooks
- tests/test_cache.py::CacheTestCase::test_https_support
- tests/test_cache.py::CacheTestCase::test_ignore_parameters_get
- tests/test_cache.py::CacheTestCase::test_ignore_parameters_post
- tests/test_cache.py::CacheTestCase::test_ignore_parameters_post_json
- tests/test_cache.py::CacheTestCase::test_ignore_parameters_post_raw
- tests/test_cache.py::CacheTestCase::test_post
- tests/test_cache.py::CacheTestCase::test_post_data
- tests/test_cache.py::CacheTestCase::test_post_parameters_normalization
- tests/test_cache.py::CacheTestCase::test_post_params
- tests/test_cache.py::CacheTestCase::test_remove_expired_entries
- tests/test_cache.py::CacheTestCase::test_response_history
- tests/test_cache.py::CacheTestCase::test_response_history_simple
- tests/test_cache.py::CacheTestCase::test_return_old_data_on_error
- tests/test_cache.py::CacheTestCase::test_stream_requests_support
- tests/test_monkey_patch.py::MonkeyPatchTestCase::test_requests_from_cache
-
- # This throws many errors with network-sandbox, but doesn't fail the
- # build
- tests/test_thread_safety::test_thread_safety
- )
-
- # Redis tests need a redis server running
- pytest -vv --ignore tests/test_redisdict.py ${skipped_tests[@]/#/--deselect } || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/requests-cache/requests-cache-0.6.0.ebuild b/dev-python/requests-cache/requests-cache-0.6.0.ebuild
deleted file mode 100644
index cfb8a2d6b048..000000000000
--- a/dev-python/requests-cache/requests-cache-0.6.0.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-HOMEPAGE="https://pypi.org/project/requests-cache/"
-DESCRIPTION="Persistent cache for requests library"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- $(python_gen_any_dep '
- dev-python/httpbin[${PYTHON_USEDEP}]
- www-servers/gunicorn[${PYTHON_USEDEP}]
- ')
- )"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-test-install.patch
-)
-
-python_check_deps() {
- use test || return 0
-
- has_version -b "dev-python/httpbin[${PYTHON_USEDEP}]" &&
- has_version -b "www-servers/gunicorn[${PYTHON_USEDEP}]"
-}
-
-src_test() {
- local hostport="127.0.0.1:23125"
- python_setup
- einfo "Starting httpbin on ${hostport}"
- gunicorn -b "${hostport}" -D -p gunicorn.pid httpbin:app || die
-
- local -x HTTPBIN_URL="http://${hostport}/"
- distutils-r1_src_test
- kill $(<gunicorn.pid) || die
-}
-
-python_test() {
- local skipped_tests=(
- # These require extra servers running
- tests/integration/test_dynamodb.py
- tests/integration/test_gridfs.py
- tests/integration/test_mongodb.py
- tests/integration/test_redis.py
-
- # TODO
- 'tests/integration/test_cache.py::test_all_response_formats[json]'
- )
-
- epytest ${skipped_tests[@]/#/--deselect }
-}
diff --git a/dev-python/requests-cache/requests-cache-0.6.1.ebuild b/dev-python/requests-cache/requests-cache-0.6.1.ebuild
deleted file mode 100644
index dcaf77d008de..000000000000
--- a/dev-python/requests-cache/requests-cache-0.6.1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-HOMEPAGE="
- https://pypi.org/project/requests-cache/
- https://github.com/reclosedev/requests-cache/"
-DESCRIPTION="Persistent cache for requests library"
-SRC_URI="
- https://github.com/reclosedev/requests-cache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/timeout-decorator[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local skipped_tests=(
- # These require extra servers running
- tests/integration/test_dynamodb.py
- tests/integration/test_gridfs.py
- tests/integration/test_mongodb.py
- tests/integration/test_redis.py
-
- # TODO
-# 'tests/integration/test_cache.py::test_all_response_formats[json]'
- )
-
- local -x USE_PYTEST_HTTPBIN=true
- epytest ${skipped_tests[@]/#/--deselect }
-}
diff --git a/dev-python/requests-cache/requests-cache-0.6.2.ebuild b/dev-python/requests-cache/requests-cache-0.6.2.ebuild
deleted file mode 100644
index dcaf77d008de..000000000000
--- a/dev-python/requests-cache/requests-cache-0.6.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{7..9} )
-PYTHON_REQ_USE="sqlite"
-
-inherit distutils-r1
-
-HOMEPAGE="
- https://pypi.org/project/requests-cache/
- https://github.com/reclosedev/requests-cache/"
-DESCRIPTION="Persistent cache for requests library"
-SRC_URI="
- https://github.com/reclosedev/requests-cache/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- dev-python/itsdangerous[${PYTHON_USEDEP}]
- >=dev-python/requests-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/url-normalize-1.4[${PYTHON_USEDEP}]"
-BDEPEND="
- test? (
- dev-python/pytest-httpbin[${PYTHON_USEDEP}]
- dev-python/timeout-decorator[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_test() {
- local skipped_tests=(
- # These require extra servers running
- tests/integration/test_dynamodb.py
- tests/integration/test_gridfs.py
- tests/integration/test_mongodb.py
- tests/integration/test_redis.py
-
- # TODO
-# 'tests/integration/test_cache.py::test_all_response_formats[json]'
- )
-
- local -x USE_PYTEST_HTTPBIN=true
- epytest ${skipped_tests[@]/#/--deselect }
-}