summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-04-22 15:49:04 -0400
committerMike Gilbert <floppym@gentoo.org>2021-04-22 15:49:04 -0400
commitc7bc3f0d07449fe4f86c9065cf9ffa5f2644a02d (patch)
tree7fd4b779362949c99c12b5b489aa93de541f23bb
parentdev-lua/luadbi: keyworded 0.7.2-r102 for hppa/sparc, bug #783420 (diff)
downloadgentoo-c7bc3f0d.tar.gz
gentoo-c7bc3f0d.tar.bz2
gentoo-c7bc3f0d.zip
sys-boot/grub: move eclass vars before first inherit
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-boot/grub/grub-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/sys-boot/grub/grub-9999.ebuild b/sys-boot/grub/grub-9999.ebuild
index 4f50f14c6ff7..8046d169817d 100644
--- a/sys-boot/grub/grub-9999.ebuild
+++ b/sys-boot/grub/grub-9999.ebuild
@@ -8,13 +8,14 @@ if [[ ${PV} == 9999 ]]; then
GRUB_BOOTSTRAP=1
fi
+PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} )
+WANT_LIBTOOL=none
+
if [[ -n ${GRUB_AUTOGEN} || -n ${GRUB_BOOTSTRAP} ]]; then
- PYTHON_COMPAT=( python{2_7,3_{6,7,8,9}} )
inherit python-any-r1
fi
if [[ -n ${GRUB_AUTORECONF} ]]; then
- WANT_LIBTOOL=none
inherit autotools
fi