summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-08-22 12:09:28 +0100
committerMarek Szuba <marecki@gentoo.org>2023-08-22 12:09:28 +0100
commitc7c10e597da1219b2350f3dd5118efe1cc1a26ac (patch)
tree3e0d4a66dac190983f19a125c2a87388e8f3e584
parentapp-misc/ola: let configure handle >=dev-libs/protobuf-23 version scheme (diff)
downloadgentoo-c7c10e597da1219b2350f3dd5118efe1cc1a26ac.tar.gz
gentoo-c7c10e597da1219b2350f3dd5118efe1cc1a26ac.tar.bz2
gentoo-c7c10e597da1219b2350f3dd5118efe1cc1a26ac.zip
Revert "app-misc/ola: let configure handle >=dev-libs/protobuf-23 version scheme"
Either the patch fucks something else up or more work is needed. Full revert rather than another revbump because with CI having spotted the issue so quickly, it hasn't been propagated to the user repo yet. This reverts commit 8ec0c08491c69b89eeed62918be5a4badea1f6d2. Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-misc/ola/files/ola-0.10.9-protobuf_versioning.patch42
-rw-r--r--app-misc/ola/ola-0.10.9-r1.ebuild (renamed from app-misc/ola/ola-0.10.9-r2.ebuild)3
2 files changed, 1 insertions, 44 deletions
diff --git a/app-misc/ola/files/ola-0.10.9-protobuf_versioning.patch b/app-misc/ola/files/ola-0.10.9-protobuf_versioning.patch
deleted file mode 100644
index 835568e2d603..000000000000
--- a/app-misc/ola/files/ola-0.10.9-protobuf_versioning.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From d4414feefd95adf9c91d7eaf1e94380296c35f7a Mon Sep 17 00:00:00 2001
-From: Peter Newman <peternewman@users.noreply.github.com>
-Date: Fri, 7 Jul 2023 15:57:35 +0100
-Subject: [PATCH 1/2] Fix protoc version checking, since v20.x (cherry picked
- from commit 2e55aa88756718d8ab4a4c8fde97d620542c2c98)
-
---- a/config/ola.m4
-+++ b/config/ola.m4
-@@ -44,7 +44,14 @@ if test -z "$PROTOC" ; then
- AC_MSG_ERROR([cannot find 'protoc' program]);
- elif test -n "$1" ; then
- AC_MSG_CHECKING([protoc version])
-- [protoc_version=`$PROTOC --version 2>&1 | grep 'libprotoc' | sed 's/.*\([0-9][0-9]*\.[0-9][0-9]*\.[0-9][0-9]*\).*/\1/g'`]
-+ # Since v20.x we only get effectively the minor and patch versions out of protoc.
-+ # Treat them as major and minor and everything should keep working indefinitely.
-+ # See https://protobuf.dev/support/version-support/
-+ # So we've got either of these:
-+ # libprotoc 2.4.1
-+ # libprotoc 23.3
-+ # The first sed ensures all versions have major, minor, patch, by adding a .0 on the end of ones missing it
-+ [protoc_version=`$PROTOC --version 2>&1 | grep 'libprotoc' | sed 's/\([^\.0-9][0-9][0-9]*\.[0-9][0-9]*\)$/\1\.0/g' | sed 's/.*\([0-9][0-9]*\.[0-9][0-9]*\.[0-9][0-9]*\).*/\1/g'`]
- [required=$1]
- [required_major=`echo $required | sed 's/[^0-9].*//'`]
- [required_minor=`echo $required | sed 's/[0-9][0-9]*\.\([0-9][0-9]*\)\.[0-9][0-9]*/\1/'`]
-
-From 546d9ee8d970c4e5b33d9d28b4acf6eb34f27a5d Mon Sep 17 00:00:00 2001
-From: Peter Newman <peternewman@users.noreply.github.com>
-Date: Fri, 7 Jul 2023 16:14:21 +0100
-Subject: [PATCH 2/2] Protoc check - correctly match multi-digit major versions
- (cherry picked from commit 69a2946622cdfce54cb6ed7f2210df2be0ec5576)
-
---- a/config/ola.m4
-+++ b/config/ola.m4
-@@ -51,7 +51,7 @@ elif test -n "$1" ; then
- # libprotoc 2.4.1
- # libprotoc 23.3
- # The first sed ensures all versions have major, minor, patch, by adding a .0 on the end of ones missing it
-- [protoc_version=`$PROTOC --version 2>&1 | grep 'libprotoc' | sed 's/\([^\.0-9][0-9][0-9]*\.[0-9][0-9]*\)$/\1\.0/g' | sed 's/.*\([0-9][0-9]*\.[0-9][0-9]*\.[0-9][0-9]*\).*/\1/g'`]
-+ [protoc_version=`$PROTOC --version 2>&1 | grep 'libprotoc' | sed 's/\([^\.0-9][0-9][0-9]*\.[0-9][0-9]*\)$/\1\.0/g' | sed 's/[^0-9]*\([0-9][0-9]*\.[0-9][0-9]*\.[0-9][0-9]*\).*/\1/g'`]
- [required=$1]
- [required_major=`echo $required | sed 's/[^0-9].*//'`]
- [required_minor=`echo $required | sed 's/[0-9][0-9]*\.\([0-9][0-9]*\)\.[0-9][0-9]*/\1/'`]
diff --git a/app-misc/ola/ola-0.10.9-r2.ebuild b/app-misc/ola/ola-0.10.9-r1.ebuild
index 968caddebd07..c2e2066ba149 100644
--- a/app-misc/ola/ola-0.10.9-r2.ebuild
+++ b/app-misc/ola/ola-0.10.9-r1.ebuild
@@ -22,7 +22,7 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
RESTRICT="!test? ( test )"
-RDEPEND="dev-libs/protobuf:=
+RDEPEND="<dev-libs/protobuf-23:=
sys-apps/util-linux
sys-libs/ncurses
ftdi? ( dev-embedded/libftdi:1 )
@@ -64,7 +64,6 @@ BDEPEND="sys-devel/bison
PATCHES=(
"${FILESDIR}"/${PN}-0.10.9-nullptr.patch
- "${FILESDIR}"/${PN}-0.10.9-protobuf_versioning.patch
)
src_prepare() {