summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-01-21 16:29:26 -0500
committerSam James <sam@gentoo.org>2024-01-22 05:54:52 +0000
commitc7c79fb1ae1a3805fe5cb9b4c09e498ff1e8d3c5 (patch)
treea3f365e81506ac43b9de9f1b260a977f3a2006db
parentnet-p2p/qbittorrent: add verify-sig support (diff)
downloadgentoo-c7c79fb1ae1a3805fe5cb9b4c09e498ff1e8d3c5.tar.gz
gentoo-c7c79fb1ae1a3805fe5cb9b4c09e498ff1e8d3c5.tar.bz2
gentoo-c7c79fb1ae1a3805fe5cb9b4c09e498ff1e8d3c5.zip
net-p2p/qbittorrent: add 4.6.3
Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-p2p/qbittorrent/Manifest2
-rw-r--r--net-p2p/qbittorrent/qbittorrent-4.6.3.ebuild145
2 files changed, 147 insertions, 0 deletions
diff --git a/net-p2p/qbittorrent/Manifest b/net-p2p/qbittorrent/Manifest
index f04c83f371e8..f6548b3aa494 100644
--- a/net-p2p/qbittorrent/Manifest
+++ b/net-p2p/qbittorrent/Manifest
@@ -5,3 +5,5 @@ DIST qbittorrent-4.5.5.tar.xz 4352524 BLAKE2B 16252e43ca7dc5090bd385079ee2116cb0
DIST qbittorrent-4.5.5.tar.xz.asc 849 BLAKE2B d9d3d18c0c26898eccbad2c92b62f4f72f71f132cfbad5aa7ecefe0bde70f1e5890a2b6051178e98eacafb770a58ec3f55d6d0f5d29c5c32ffc33b4b47667b54 SHA512 3a7215d711fa89e88c47cebdfed57d059dad93836b2dd75b89e39ea46c97820212efb01334eee6149adca3b8dc0eec88f0be6ed71fca8764871428a992409d66
DIST qbittorrent-4.6.2.tar.xz 4506224 BLAKE2B 74c2fa8ffdb6e0787559e943dd6e2c4d09b4d6bc6c72db01e47a001a99599bf7d6b12c0cd954b8db3bdacd2db5bb445d28e04d6abe6114b05242c3f5b5b2b56d SHA512 e4363a30bd722d4bd8144c484830caad5610ca273d40395e593e5b37b94f11f4a786481a770b847ee24517cb355d9bc2e27d07f2c66d4e852d1061a8edb7a75f
DIST qbittorrent-4.6.2.tar.xz.asc 849 BLAKE2B 639dc8a75a926c9ec7ff42e52c93d33aa5494b6c64848778ad885d059c0272239c92fa935bcdab6477c4a20329d2c7538bdb9df5893a5e4264a604e264ed911e SHA512 ced33ae194a18c82c39318c07f160d5cc4a4f7ebebffb03cb16a555e4f277ad8d1305ec0e7c476bb51c5c50004501dbde6a729d05f1b557138414bab52ee21f9
+DIST qbittorrent-4.6.3.tar.xz 4512004 BLAKE2B b97022d2380e4cc1c4fdd06e7365136978f64b3ed98a4521e34197dcfa86c6e4032e0f9f7de1310a100a924f9a5250b145236d87f28317c4a79fe5d130d858b6 SHA512 13a7952bc8d0e57c24fcfb00ab8c7e5a1fdcb9c4755cb50f7f6b94a5cb01657e3b21996ff581366d957eaa36d90e14003c544c2376150d6041f14f42c4a03adc
+DIST qbittorrent-4.6.3.tar.xz.asc 849 BLAKE2B 34f61400fd340dd3770c600e57be36a434c5fcfed1d2d8ad9e050e7112a141f7aec3e6f94d3bcd7a893a7969344f6d7120aa908a3c8ed9451a475bd25a98a53a SHA512 0d2420be78fd66a7f1e0e8797f73fcbe462f08640adbc0c681f9321423eefb7805d3267ab144e8934f00a7ebeac0931f16c9fef199196e222b57a0153916696e
diff --git a/net-p2p/qbittorrent/qbittorrent-4.6.3.ebuild b/net-p2p/qbittorrent/qbittorrent-4.6.3.ebuild
new file mode 100644
index 000000000000..c52bd5d5331f
--- /dev/null
+++ b/net-p2p/qbittorrent/qbittorrent-4.6.3.ebuild
@@ -0,0 +1,145 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake edo multibuild systemd verify-sig xdg
+
+DESCRIPTION="BitTorrent client in C++ and Qt"
+HOMEPAGE="https://www.qbittorrent.org"
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/qbittorrent/qBittorrent.git"
+ inherit git-r3
+else
+ SRC_URI="
+ mirror://sourceforge/qbittorrent/${P}.tar.xz
+ verify-sig? ( mirror://sourceforge/qbittorrent/${P}.tar.xz.asc )
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+ BDEPEND="verify-sig? ( sec-keys/openpgp-keys-qbittorrent )"
+ VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/qBittorrent.asc
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+dbus +gui qt6 systemd test webui"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="|| ( gui webui )
+ dbus? ( gui )
+"
+
+RDEPEND="
+ >=dev-libs/openssl-1.1.1:=
+ >=net-libs/libtorrent-rasterbar-1.2.19:=
+ >=sys-libs/zlib-1.2.11
+ qt6? ( >=dev-qt/qtbase-6.2:6[network,ssl,sql,sqlite,xml] )
+ !qt6? (
+ dev-qt/qtcore:5
+ dev-qt/qtnetwork:5[ssl]
+ dev-qt/qtsql:5[sqlite]
+ dev-qt/qtxml:5
+ )
+ gui? (
+ !qt6? (
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dbus? ( dev-qt/qtdbus:5 )
+ )
+ qt6? (
+ >=dev-qt/qtbase-6.2:6[dbus?,gui,widgets]
+ >=dev-qt/qtsvg-6.2:6
+ )
+ )
+ webui? (
+ acct-group/qbittorrent
+ acct-user/qbittorrent
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ >=dev-libs/boost-1.71
+ test? (
+ !qt6? ( dev-qt/qttest:5 )
+ )"
+BDEPEND+="
+ !qt6? ( dev-qt/linguist-tools:5 )
+ qt6? ( >=dev-qt/qttools-6.2:6[linguist] )
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS Changelog CONTRIBUTING.md README.md )
+
+src_prepare() {
+ MULTIBUILD_VARIANTS=()
+ use gui && MULTIBUILD_VARIANTS+=( gui )
+ use webui && MULTIBUILD_VARIANTS+=( nogui )
+
+ cmake_src_prepare
+}
+
+src_configure() {
+ my_src_configure() {
+ local mycmakeargs=(
+ # musl lacks execinfo.h
+ -DSTACKTRACE=$(usex !elibc_musl)
+ # More verbose build logs are preferable for bug reports
+ -DVERBOSE_CONFIGURE=ON
+ -DQT6=$(usex qt6)
+ -DWEBUI=$(usex webui)
+ -DTESTING=$(usex test)
+ )
+
+ if [[ ${MULTIBUILD_VARIANT} == "gui" ]]; then
+ # We do this in multibuild, see bug #839531 for why.
+ # Fedora has to do the same thing.
+ mycmakeargs+=(
+ -DGUI=ON
+ -DDBUS=$(usex dbus)
+ -DSYSTEMD=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DGUI=OFF
+ -DDBUS=OFF
+ )
+
+ use systemd && mycmakeargs+=(
+ # The systemd service calls qbittorrent-nox, which is only
+ # installed when GUI=OFF.
+ -DSYSTEMD=ON
+ -DSYSTEMD_SERVICES_INSTALL_DIR="$(systemd_get_systemunitdir)"
+ )
+ fi
+
+ cmake_src_configure
+ }
+
+ multibuild_foreach_variant my_src_configure
+}
+
+src_compile() {
+ multibuild_foreach_variant cmake_src_compile
+}
+
+src_test() {
+ my_src_test() {
+ # cmake does not detect tests by default, if you use enable_testing
+ # in a subdirectory instead of the root CMakeLists.txt
+ cd "${BUILD_DIR}"/test || die
+ edo ctest .
+ }
+
+ multibuild_foreach_variant my_src_test
+}
+
+src_install() {
+ multibuild_foreach_variant cmake_src_install
+ einstalldocs
+
+ if use webui; then
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ fi
+}