summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-03 00:24:47 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-03 00:24:47 +0100
commitc7c99a87b5926bae9a1757c52c96a9c376883d22 (patch)
treed04713c2f7e13ece9d34165e689a882c4b9e1d3c
parentdev-python/wcmatch: Add python@ as backup (diff)
downloadgentoo-c7c99a87b5926bae9a1757c52c96a9c376883d22.tar.gz
gentoo-c7c99a87b5926bae9a1757c52c96a9c376883d22.tar.bz2
gentoo-c7c99a87b5926bae9a1757c52c96a9c376883d22.zip
dev-python/pillow: Bump to 8.1.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pillow/Manifest1
-rw-r--r--dev-python/pillow/pillow-8.1.0.ebuild98
2 files changed, 99 insertions, 0 deletions
diff --git a/dev-python/pillow/Manifest b/dev-python/pillow/Manifest
index 235ce1b38d3a..d179222e844c 100644
--- a/dev-python/pillow/Manifest
+++ b/dev-python/pillow/Manifest
@@ -1,3 +1,4 @@
DIST pillow-7.0.0.tar.gz 37880130 BLAKE2B be940cbdced884c33f2b3979be113b1bc8974814c9532fe80203395184f90eccba1cd9a5017fec1f0c30a21ff06abc46560d5c6d67938dbf640f2e8e08b7e554 SHA512 187173a525d4f3f01b4898633263b53a311f337aa7b159c64f79ba8c7006fd44798a058e7cc5d8f1116bad008e4142ff303456692329fe73b0e115ef5c225d73
DIST pillow-7.2.0.tar.gz 39125407 BLAKE2B f49015922c34473590740c9fa63435f85f9a517b3295abd2e758941b95162cef0fb1fa2a0e6ee0ac86323709ee3af02888f6e029a1905f13698e82c1f38d5d94 SHA512 ac9c7c8f445b3f67f51bea13fad118d1612c45272c26d33bec286f3c2e198912b934378c4bf986b409aaa2a83d92ff176ee4d25f28701d61746c9cb86d0f412b
DIST pillow-8.0.1.tar.gz 44614653 BLAKE2B 0f8ec178e92a57a55d575fac61779d39e79ff18032a02ad93aa6eca1211436342944b1a5bbd29979b52f0e2df756936ade4bf637ac3c153b5dda5838b58087ac SHA512 41b4ea786990c834f77ad06b64f465bc8f3a65911cf14bb05f452316fdf504e5e49b2bb50a9346f207187e79f83c5b6d310d703d1588f678b606584b1f27ce6a
+DIST pillow-8.1.0.tar.gz 44929704 BLAKE2B 6b8100f26a746c625851521d7aa3696c4de30b05d2debc07cfcc038c1bc1e73ab1136676d22fccdf17b8d0ecfeb21479168580e5f5a93488c50cbaf1c6533d79 SHA512 1014271d29e98c465e6882ed3f2f915f8955f5ada2a762c671a1f79389b25576ead2d144c6eaf42b4777f14438d15979d78d34dc32d984fd7defb53f0d209957
diff --git a/dev-python/pillow/pillow-8.1.0.ebuild b/dev-python/pillow/pillow-8.1.0.ebuild
new file mode 100644
index 000000000000..bae148368387
--- /dev/null
+++ b/dev-python/pillow/pillow-8.1.0.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+PYTHON_REQ_USE='tk?,threads(+)'
+
+inherit distutils-r1 toolchain-funcs virtualx
+
+MY_PN=Pillow
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="Python Imaging Library (fork)"
+HOMEPAGE="https://python-pillow.org/"
+SRC_URI="https://github.com/python-pillow/Pillow/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="HPND"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp xcb zlib"
+REQUIRED_USE="test? ( jpeg tiff )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ imagequant? ( media-gfx/libimagequant:0 )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2= )
+ tiff? ( media-libs/tiff:0=[jpeg,zlib] )
+ truetype? ( media-libs/freetype:2= )
+ webp? ( media-libs/libwebp:0= )
+ xcb? ( x11-libs/libxcb )
+ zlib? ( sys-libs/zlib:0= )"
+RDEPEND="${DEPEND}
+ dev-python/olefile[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ media-gfx/imagemagick[png]
+ )
+"
+
+python_configure_all() {
+ # It's important that these flags are also passed during the install phase
+ # as well. Make sure of that if you change the lines below. See bug 661308.
+ mydistutilsargs=(
+ build_ext
+ --disable-platform-guessing
+ $(use_enable truetype freetype)
+ $(use_enable jpeg)
+ $(use_enable jpeg2k jpeg2000)
+ $(use_enable lcms)
+ $(use_enable tiff)
+ $(use_enable imagequant)
+ $(use_enable webp)
+ $(use_enable webp webpmux)
+ $(use_enable xcb)
+ $(use_enable zlib)
+ )
+
+ # setup.py sucks at adding the right toolchain paths but it does
+ # accept additional ones from INCLUDE and LIB so set these. You
+ # wouldn't normally need these at all as the toolchain should look
+ # here anyway but this setup.py does stupid things.
+ export \
+ INCLUDE=${ESYSROOT}/usr/include \
+ LIB=${ESYSROOT}/usr/$(get_libdir)
+
+ # We have patched in this env var.
+ tc-export PKG_CONFIG
+}
+
+src_test() {
+ virtx distutils-r1_src_test
+}
+
+python_test() {
+ "${EPYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
+ # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
+ pytest -vv -p no:relaxed || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ python_doheader src/libImaging/*.h
+ distutils-r1_python_install
+}
+
+python_install_all() {
+ if use examples ; then
+ docinto example
+ dodoc docs/example/*
+ docompress -x /usr/share/doc/${PF}/example
+ fi
+ distutils-r1_python_install_all
+}