summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2022-09-19 17:22:36 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2022-09-19 17:22:56 -0700
commitc7df688193b8ef219acba6c4be9d28b057746c7c (patch)
treea79f611cf954df66eac98e5c4acddf261035f2c2
parentsys-apps/fd: add 8.4.0 (diff)
downloadgentoo-c7df688193b8ef219acba6c4be9d28b057746c7c.tar.gz
gentoo-c7df688193b8ef219acba6c4be9d28b057746c7c.tar.bz2
gentoo-c7df688193b8ef219acba6c4be9d28b057746c7c.zip
app-shells/fish: add 3.5.1
Closes: https://bugs.gentoo.org/863341 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--app-shells/fish/Manifest1
-rw-r--r--app-shells/fish/fish-3.5.1.ebuild108
2 files changed, 109 insertions, 0 deletions
diff --git a/app-shells/fish/Manifest b/app-shells/fish/Manifest
index bb92772d4c31..d956f27aa0b7 100644
--- a/app-shells/fish/Manifest
+++ b/app-shells/fish/Manifest
@@ -1,3 +1,4 @@
DIST fish-3.4.0.tar.xz 3292216 BLAKE2B 3691e5387a8392d7d43b3b0f8b893e83e246c3532684e95a19c7b2eb4ebe80bcf04aaa1b965f5c4f6d782d0ae52269bb1cdafef76845b02f9f99d4c82ea77ce3 SHA512 463ee8d86815520c6de9777fd2b5975f06cc0842137c86cca7ae0331e95d74e755bf6f4b0bdea7e96c11371436ff9f97ce483ae026daa1e8d385f6cad8860ed4
DIST fish-3.4.1.tar.xz 3293068 BLAKE2B 5edcd59445e6d928fb2183deb68fb0a305f6f80c134fef48ea79d91b79af1da6b31a1e870a9df963bb27dfc5985f326d9b6d53d64b16c79f9c303aa8edfa4423 SHA512 20a2892ec0c413c4c3fcfe5fbf52fb2398de35a9172758728bd2ccdccc5fb6e0e18712a664d02db67543d47180a4d04f3998a6297d23088926b6d03baefdf981
DIST fish-3.5.0.tar.xz 3326276 BLAKE2B ac8fa514a728af5bc02ea02f57344d92d3d897c5dda3a2a32b6dbaab81c795828da0cc6938f19bb6d538aa1e620b67de72225fa73b52405c94e1eecab2299faa SHA512 ccec4abcdb425563688c6112f3c9c57add16aa3a05c121d2633b655d27185e1c96c263d51d6af7d83c068580d7d0723c072f1a4853fa8b6736291beeab64b859
+DIST fish-3.5.1.tar.xz 3329900 BLAKE2B 960ee4036dd44bda93300a377e44f5c3db19f2c24ee60112c3e8b886cc434e9bc08c65dd99ab13aefde6c7cb66e027f446064bc6b7f20f9a85b16753ea7b50c3 SHA512 328e3d972f9e7cffe161515540f00a97c5cbe11b43ec293090bedb96a6a8e689e07ceafecb3efcd0e378edea59811adb0acc011d5885ac28d98838387c678235
diff --git a/app-shells/fish/fish-3.5.1.ebuild b/app-shells/fish/fish-3.5.1.ebuild
new file mode 100644
index 000000000000..936ed237ea77
--- /dev/null
+++ b/app-shells/fish/fish-3.5.1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit cmake python-any-r1 readme.gentoo-r1
+
+DESCRIPTION="Friendly Interactive SHell"
+HOMEPAGE="http://fishshell.com/"
+
+MY_PV="${PV/_beta/b}"
+MY_P="${PN}-${MY_PV}"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/${PN}-shell/${PN}-shell.git"
+else
+ SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${MY_PV}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="+doc nls test"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libpcre2-10.32:=[pcre32]
+ sys-apps/coreutils
+ sys-libs/ncurses:=[unicode(+)]
+"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ test? (
+ ${PYTHON_DEPS}
+ dev-tcltk/expect
+ $(python_gen_any_dep '
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ ')
+ )
+"
+# we don't need shpinx dep for release tarballs
+[[ ${PV} == 9999 ]] && DEPEND+=" doc? ( dev-python/sphinx )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_check_deps() {
+ use test || return 0
+ python_has_version "dev-python/pexpect[${PYTHON_USEDEP}]"
+}
+
+src_prepare() {
+ # workaround for https://github.com/fish-shell/fish-shell/issues/4883
+ sed -i 's#${TEST_INSTALL_DIR}/${CMAKE_INSTALL_PREFIX}#${TEST_INSTALL_DIR}#' \
+ cmake/Tests.cmake || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_INSTALL_BINDIR="${EPREFIX}/bin"
+ -DCMAKE_INSTALL_SYSCONFDIR="${EPREFIX}/etc"
+ -DCURSES_NEED_NCURSES=ON
+ -DINSTALL_DOCS="$(usex doc)"
+ -DWITH_GETTEXT="$(usex nls)"
+ )
+ # release tarballs ship pre-built docs // -DHAVE_PREBUILT_DOCS=TRUE
+ if [[ ${PV} == 9999 ]]; then
+ mycmakeargs+=( -DBUILD_DOCS="$(usex doc)" )
+ else
+ mycmakeargs+=( -DBUILD_DOCS=OFF )
+ fi
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+ keepdir /usr/share/fish/vendor_{completions,conf,functions}.d
+ readme.gentoo_create_doc
+}
+
+src_test() {
+ # some tests are fragile, sanitize environment
+ local -x COLUMNS=80
+ local -x LINES=24
+
+ # very fragile, depends on terminal, size, tmux, screen and timing
+ if [[ ${PV} != 9999 ]]; then
+ rm -v tests/pexpects/terminal.py || die
+ fi
+
+ # zfs completion test will fail with "Permission denied the ZFS utilities must be run as root."
+ mv "${S}"/share/completions/zfs.{fish,disabled} || die
+
+ cmake_build test
+
+ # now restore zfs completions
+ mv "${S}"/share/completions/zfs.{disabled,fish} || die
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}