summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-10 13:03:22 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-10 13:03:22 +0200
commitc7faefb272f683d4cfed44289f0825e86da9715e (patch)
tree5a656373852b28ce6b82d7b91b4cb4b69fb48eaa
parentdev-libs/boost: fix build with libcxx (diff)
downloadgentoo-c7faefb2.tar.gz
gentoo-c7faefb2.tar.bz2
gentoo-c7faefb2.zip
dev-python/frozenlist: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/frozenlist/Manifest1
-rw-r--r--dev-python/frozenlist/frozenlist-1.3.0.ebuild44
2 files changed, 0 insertions, 45 deletions
diff --git a/dev-python/frozenlist/Manifest b/dev-python/frozenlist/Manifest
index c3d29e9413a3..0e7bba037a96 100644
--- a/dev-python/frozenlist/Manifest
+++ b/dev-python/frozenlist/Manifest
@@ -1,2 +1 @@
-DIST frozenlist-1.3.0.gh.tar.gz 27669 BLAKE2B d09e18455893f7ede59c37a080e79ea5e085cc3362e53bc7016db64338b2cf26baf44e95ec0c691535527b0eef4a40ec1fbe814e5d4ae238300125438d21b467 SHA512 780f0ec0e1a701b009e5afcd7f62b2950eda5365140ad5842c09db85b0a3cf282ab70ff9ba752ea6dc7a97542fc7399023aaaca8fdd8ecbd5c26bf64f305f5f4
DIST frozenlist-1.3.1.gh.tar.gz 27705 BLAKE2B 7428d936926978acb90a857e0f76b303dddea684c3e815b3fd583e888102e114cc629fcd8e862a4e72775f8525193becfd4b9cd844a36f5b2c7964605008bb84 SHA512 4986f3635ebd2d3ca9623299a66375b03938a7be72f7a1d3437b1bf8c0739513942e6babf00476b61055c9ebee3638ec807dad521c52990104d4d57017efdfb2
diff --git a/dev-python/frozenlist/frozenlist-1.3.0.ebuild b/dev-python/frozenlist/frozenlist-1.3.0.ebuild
deleted file mode 100644
index 941f0285c9b7..000000000000
--- a/dev-python/frozenlist/frozenlist-1.3.0.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A list-like structure which implements collections.abc.MutableSequence"
-HOMEPAGE="
- https://pypi.org/project/frozenlist/
- https://github.com/aio-libs/frozenlist/
-"
-SRC_URI="
- https://github.com/aio-libs/frozenlist/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-BDEPEND="
- $(python_gen_cond_dep '
- dev-python/cython[${PYTHON_USEDEP}]
- ' 'python*')
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e '/addopts/d' pytest.ini || die
- distutils-r1_src_prepare
-}
-
-python_configure() {
- # pypy is not using the C extension
- if [[ ${EPYTHON} == python* ]]; then
- > .install-cython || die
- emake cythonize
- fi
-}