summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2017-06-28 19:31:18 -0400
committerAaron Bauman <bman@gentoo.org>2017-07-09 20:16:34 -0400
commitc80147d5d0dc55c71fdba0054cd4c5671db02100 (patch)
treed0a61276366bdaa5c76955278000819682a7f9cf
parentnet-misc/gns3-gui: bump to 2.0.3 (diff)
downloadgentoo-c80147d5d0dc55c71fdba0054cd4c5671db02100.tar.gz
gentoo-c80147d5d0dc55c71fdba0054cd4c5671db02100.tar.bz2
gentoo-c80147d5d0dc55c71fdba0054cd4c5671db02100.zip
dev-python/aiohttp: add 1.3.5 for net-misc/gns3-server dependency
Closes: https://github.com/gentoo/gentoo/pull/5007
-rw-r--r--dev-python/aiohttp/Manifest1
-rw-r--r--dev-python/aiohttp/aiohttp-1.3.5.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 264d210c3efe..c7b6065e7d17 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -7,5 +7,6 @@ DIST aiohttp-1.1.2.tar.gz 576160 SHA256 8be33ad39522d5fbc06ce527da4615bf93e6c5d4
DIST aiohttp-1.1.5.tar.gz 577346 SHA256 8f4c31a10b0a96667ac8a13e3756a3505e040c423c3c4075b99745056b3537d8 SHA512 44b1474a64ce150164045f30734da119a1848a3677d885493f99f2d724d20884dac9a24adce4b90017e203fc67b295443f91d14f1af9eb20d657a3cd4b69d747 WHIRLPOOL 036265681123f902aaa2000fd6ddd83980c3b1a48d67b583b5e1da7e7079d381a9c92669c12040c1494ba3890c2a849cd1f190003a1ec611df7a72843242bcec
DIST aiohttp-1.2.0.tar.gz 589818 SHA256 b2fa11df067207ff15813be84b78910f6f9d897f02e9c345993b9962802a6bea SHA512 4101f0aad0d6bb8caf931dbd7f9e07bfdaa445796af92c84ea999538c2767f3cd62740ea9c7e07f255eb57b52e967e5343461809a5d5f4e8b12cd4383753bd77 WHIRLPOOL 239f802ce1dde24b3e1c6fba39357822564256f1aae167b44164d9bab3e67113400534df0835ca6b5245b8229dcab752149774c7adde1e1aef2a0f549d2d33ad
DIST aiohttp-1.3.3.tar.gz 526273 SHA256 103433f594442b98ed4af9db02331e548a0ef2d4cfd02207ea24ed9eb85862e4 SHA512 39342270f615f7e5e01889ad50ccb60335151e94631007b105acda9930038d2fb66128469ca44043280c9f737130e2361129e2fa1c857a7654a1151b98a19a69 WHIRLPOOL c6689d990f31ce45e012ca26a459993505d264fdb36f87481588eb747e5cd5c5aa38dd2e08c10f2d9b7bfd16622a7b312e08c7fb7c33929e0bdf872fac2e92bf
+DIST aiohttp-1.3.5.tar.gz 527432 SHA256 cd14a45da385b5e860849ffaff3ecee56f9b37bf9e7f3f7bc5ce3f17556cf842 SHA512 b99630fa9006163d61e0e010972aee8daad021c5ad0152b04fb6f8b661f18ea03fcfa8d35603ecfcdaef4ecbaff0159b49e2f40164241bb5def48b2847e2d966 WHIRLPOOL b39e5a5081cadb497aa982b8bee1a24615a2e382071755586c52855529c7984c9140c04239fe9ef81e51f3e11a1ea7b1c021f6b8a4dd58c4d826f934394b5576
DIST aiohttp-2.1.0.tar.gz 748642 SHA256 3e80d944e9295b1360e422d89746b99e23a99118420f826f990a632d284e21df SHA512 bd8eea366d380b88ba2c88d2aab722cd0970d2239dd0057cf4596f472a1b1bf38aebbd6cc707379ad9b5f901f93a56c1c4dd32584cb2636af0e013aa11388e25 WHIRLPOOL 45cf17ea7db2eb385d922cd4cdf5aac40244939066a6632f453fa2545fe1a73dfe0d0c43c3dcd60936a403174a69a8fd027dae2e55fc901594d388bd4b5c4cc3
DIST aiohttp-2.2.0.tar.gz 781951 SHA256 1558ba6896c2ed4e1b3cbdc4ba479b4a03a0c1433af2fe23704d2959a0c5191e SHA512 547f7484651aa5df43174cede2537c120ebf10b913ab506cdcbbe8d8702492a9e3374cf772c5d11969ca7a7e3d2602d794e98878ed43d05ae4a8324613138ea4 WHIRLPOOL 5c97f0ccbc2015e6fb7ac31ff0539d123c445673b4444d7ab3b5098c94496b42b8880b8612e6bf3ee0604309aed4ec5d80c3020ed940cd28df0adac5cff28720
diff --git a/dev-python/aiohttp/aiohttp-1.3.5.ebuild b/dev-python/aiohttp/aiohttp-1.3.5.ebuild
new file mode 100644
index 000000000000..739051416f14
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-1.3.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://pypi.python.org/pypi/aiohttp"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz -> ${P}.tar.gz"
+EGIT_REPO_URI="https://github.com/aio-libs/aiohttp"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+CDEPEND="
+ dev-python/async_timeout[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/multidict-2.1.4[${PYTHON_USEDEP}]
+ >=dev-python/yarl-0.9.8[${PYTHON_USEDEP}]
+ <dev-python/yarl-0.10[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/alabaster-0.6.2[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-asyncio[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-newsfeed[${PYTHON_USEDEP}]
+ dev-python/sphinxcontrib-spelling[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${CDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ PYTHONPATH="${PWD}:${PYTHONPATH}" ${PYTHON} -m pytest tests/ || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}