summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2017-06-15 07:45:49 +0200
committerHans de Graaff <graaff@gentoo.org>2017-06-15 07:45:49 +0200
commitc80205f3073bc75cb370f4b921427e761773cb55 (patch)
tree98faf7b2d5d36fefdd3b7ec046a1d43b3de80fa2
parentgames-simulation/flightgear: Version bump 2017.2.1 (diff)
downloadgentoo-c80205f3073bc75cb370f4b921427e761773cb55.tar.gz
gentoo-c80205f3073bc75cb370f4b921427e761773cb55.tar.bz2
gentoo-c80205f3073bc75cb370f4b921427e761773cb55.zip
dev-ruby/selenium-webdriver: add 3.4.2
Package-Manager: Portage-2.3.5, Repoman-2.3.1
-rw-r--r--dev-ruby/selenium-webdriver/Manifest1
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-3.4.2.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/selenium-webdriver/Manifest b/dev-ruby/selenium-webdriver/Manifest
index e1a2cee85a38..8e276713d360 100644
--- a/dev-ruby/selenium-webdriver/Manifest
+++ b/dev-ruby/selenium-webdriver/Manifest
@@ -2,3 +2,4 @@ DIST selenium-webdriver-2.53.4.gem 897536 SHA256 44b38d9b6a97b39c7d2aa5185ff9585
DIST selenium-webdriver-3.3.0.gem 823808 SHA256 3605ceed7093ac503a0dbf0d64820b9111424dccb9937dcc8faacc5d5880202b SHA512 de4ac22fd360f550b60be0f44ac03ac209d1333c340211d82f3c3a1e6ea056c2ecdb01dbc9ce39b1f5e523caecb7d42472cdf5e5a1848bc209f24a5291668996 WHIRLPOOL bd6f3a69d6bb7562131d79df5805858bc7ad61eb70cdd62077208db4b69bf2368a71722dae04b5d948cd4d878210960e473a96c2ac32a0d46da4b4c77896fc38
DIST selenium-webdriver-3.4.0.gem 834560 SHA256 80cb651a6e403f976c1d5d01539f6e70dc6e1ba0645bcc1d47e170327f704a17 SHA512 fef7552929ee4c703c14244957274d0d9b58e326789ffb641bab009315150b93fc5b7ea76f9dff80d8d98d6385375edbddf861440b889f8a33827db29fd8afda WHIRLPOOL 8f2ee764ffba9168e0b836fdcbd0cd1ee16ff023670813066d3c5238742844204f1ad1056e8858bd49da53e6e46f4af1209f2c133f092db25a05294bdc66a013
DIST selenium-webdriver-3.4.1.gem 837632 SHA256 7b38d3b6cf2f379e2b9c50c9db38f5437f7a667a040c95c9ec91133b965934da SHA512 c461411d6f44a37c3eb9bd080326e7046df70de5743ee1dd7bc27d9afa795e8c9dddaf3aebf1cc909cba1fa5262fdb706539972785495e1e80b3a6eebaa49557 WHIRLPOOL 4f9f80751b7a25ff9e44648aa74b9736a0716dd65f19f22ad7a57f433fd8cac710e0c5bcf1469c15b8f18f16b27fb7d8e10252100fb69a93278d1035694b853d
+DIST selenium-webdriver-3.4.2.gem 837632 SHA256 78b2f9a4e79bb503528f297ea59f39d5d8f859e28ca175b1fb5d26e815ee6e22 SHA512 e46d50b11326e17e8e81569e25f33074fcc4677aad8d891864ff922b84c68897adecee13194cb589901e66c72a24076744111e210d07584a33cb8b1a6107032f WHIRLPOOL 28cfe54cb1209c24406048b56d2788c9fab2b8534f60c16ef68aaabd06975b812b64839aca5c9cae5d6b3f6a0560147ef86f2d9a87948c0d1b9c80db3522fa0f
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-3.4.2.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-3.4.2.ebuild
new file mode 100644
index 000000000000..423d9a25852d
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-3.4.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby21 ruby22 ruby23"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at https://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+QA_PREBUILT="*/x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver"
+HOMEPAGE="https://github.com/seleniumhq/selenium"
+
+LICENSE="Apache-2.0"
+SLOT="3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.5.0
+ dev-ruby/rubyzip:1"