summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-08-25 19:06:22 +0100
committerSam James <sam@gentoo.org>2020-08-25 19:06:22 +0100
commitc80641abc3235b680c260707ee42a4e14948a4c6 (patch)
tree3046a27646413c1f7622524ba70ace9f0b5ab44b
parentmedia-gfx/openvdb: add missing dependencies (diff)
downloadgentoo-c80641ab.tar.gz
gentoo-c80641ab.tar.bz2
gentoo-c80641ab.zip
media-gfx/openvdb: cleanup old
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-gfx/openvdb/openvdb-4.0.2-r3.ebuild110
-rw-r--r--media-gfx/openvdb/openvdb-5.2.0-r1.ebuild105
-rw-r--r--media-gfx/openvdb/openvdb-6.2.1.ebuild102
-rw-r--r--media-gfx/openvdb/openvdb-7.0.0.ebuild123
-rw-r--r--media-gfx/openvdb/openvdb-7.1.0.ebuild121
5 files changed, 0 insertions, 561 deletions
diff --git a/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild b/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild
deleted file mode 100644
index f6705df69633..000000000000
--- a/media-gfx/openvdb/openvdb-4.0.2-r3.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-inherit cmake flag-o-matic python-single-r1
-
-DESCRIPTION="Library for the efficient manipulation of volumetric data"
-HOMEPAGE="https://www.openvdb.org"
-SRC_URI="https://github.com/AcademySoftwareFoundation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
- https://dev.gentoo.org/~dracwyrm/patches/${P}-patchset-02.tar.xz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~x86"
-IUSE="abi3-compat +abi4-compat doc python test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- ^^ ( abi3-compat abi4-compat )
-"
-
-RDEPEND="
- dev-libs/boost:=
- dev-libs/c-blosc:=
- dev-libs/jemalloc:=
- dev-libs/log4cplus:=
- media-libs/glfw
- media-libs/openexr:=
- sys-libs/zlib:=
- x11-libs/libXcursor
- x11-libs/libXi
- x11-libs/libXinerama
- x11-libs/libXrandr
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-libs/boost:=[python?,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- ')
- )
-"
-
-DEPEND="
- ${RDEPEND}
- dev-cpp/tbb
-"
-
-BDEPEND="
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- )
- test? ( dev-util/cppunit )
-"
-
-PATCHES=(
- "${WORKDIR}/${P}-patchset-02/0001-use-gnuinstalldirs.patch"
- "${WORKDIR}/${P}-patchset-02/0002-use-pkgconfig-for-ilmbase-and-openexr.patch"
- "${WORKDIR}/${P}-patchset-02/0003-boost-1.65-numpy-support.patch"
- "${FILESDIR}/${P}-findboost-fix.patch"
- "${FILESDIR}/${P}-fix-const-correctness-for-unittest.patch"
- "${FILESDIR}/${P}-fix-build-docs.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local myprefix="${EPREFIX}/usr/"
-
- # To stay in sync with Boost
- append-cxxflags -std=c++14
-
- local version
- if use abi3-compat; then
- version=3
- elif use abi4-compat; then
- version=4
- else
- die "Openvdb abi version is not compatible"
- fi
-
- local mycmakeargs=(
- -DBLOSC_LOCATION="${myprefix}"
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
- -DGLFW3_LOCATION="${myprefix}"
- -DOPENVDB_BUILD_DOCS=$(usex doc)
- -DOPENVDB_BUILD_PYTHON_MODULE=$(usex python)
- -DOPENVDB_BUILD_UNITTESTS=$(usex test)
- -DOPENVDB_ENABLE_3_ABI_COMPATIBLE=$(usex abi3-compat)
- -DOPENVDB_ENABLE_RPATH=OFF
- -DTBB_LOCATION="${myprefix}"
- -DUSE_GLFW3=ON
- )
-
- use python && mycmakeargs+=( -DPYOPENVDB_INSTALL_DIRECTORY="$(python_get_sitedir)" )
- use test && mycmakeargs+=( -DCPPUNIT_LOCATION="${myprefix}" )
-
- cmake_src_configure
-}
diff --git a/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild b/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
deleted file mode 100644
index a176389a2a05..000000000000
--- a/media-gfx/openvdb/openvdb-5.2.0-r1.ebuild
+++ /dev/null
@@ -1,105 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-inherit cmake flag-o-matic python-single-r1
-
-DESCRIPTION="Library for the efficient manipulation of volumetric data"
-HOMEPAGE="https://www.openvdb.org"
-SRC_URI="https://github.com/AcademySoftwareFoundation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="abi3-compat abi4-compat +abi5-compat doc python test"
-RESTRICT="!test? ( test )"
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- ^^ ( abi3-compat abi4-compat abi5-compat )
-"
-
-RDEPEND="
- dev-libs/boost:=
- dev-libs/c-blosc:=
- dev-libs/jemalloc:=
- dev-libs/log4cplus:=
- media-libs/glfw
- media-libs/openexr:=
- sys-libs/zlib:=
- x11-libs/libXcursor
- x11-libs/libXi
- x11-libs/libXinerama
- x11-libs/libXrandr
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-libs/boost:=[python?,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- ')
- )
-"
-
-DEPEND="
- ${RDEPEND}
- dev-cpp/tbb
-"
-
-BDEPEND="
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- )
- test? ( dev-util/cppunit )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-use-gnuinstalldirs.patch"
- "${FILESDIR}/${P}-use-pkgconfig-for-ilmbase-and-openexr.patch"
- "${FILESDIR}/${PN}-4.0.2-fix-const-correctness-for-unittest.patch"
- "${FILESDIR}/${PN}-4.0.2-fix-build-docs.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local myprefix="${EPREFIX}/usr/"
-
- local version
- if use abi3-compat; then
- version=3
- elif use abi4-compat; then
- version=4
- elif use abi5-compat; then
- version=5
- else
- die "Openvdb ABI version not specified"
- fi
-
- local mycmakeargs=(
- -DBLOSC_LOCATION="${myprefix}"
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
- -DGLFW3_LOCATION="${myprefix}"
- -DOPENVDB_ABI_VERSION_NUMBER="${version}"
- -DOPENVDB_BUILD_DOCS=$(usex doc)
- -DOPENVDB_BUILD_PYTHON_MODULE=$(usex python)
- -DOPENVDB_BUILD_UNITTESTS=$(usex test)
- -DOPENVDB_ENABLE_RPATH=OFF
- -DTBB_LOCATION="${myprefix}"
- -DUSE_GLFW3=ON
- )
-
- use python && mycmakeargs+=( -DPYOPENVDB_INSTALL_DIRECTORY="$(python_get_sitedir)" )
- use test && mycmakeargs+=( -DCPPUNIT_LOCATION="${myprefix}" )
-
- cmake_src_configure
-}
diff --git a/media-gfx/openvdb/openvdb-6.2.1.ebuild b/media-gfx/openvdb/openvdb-6.2.1.ebuild
deleted file mode 100644
index ebade646417c..000000000000
--- a/media-gfx/openvdb/openvdb-6.2.1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-inherit cmake flag-o-matic python-single-r1
-
-DESCRIPTION="Library for the efficient manipulation of volumetric data"
-HOMEPAGE="https://www.openvdb.org"
-SRC_URI="https://github.com/AcademySoftwareFoundation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="abi4-compat abi5-compat +abi6-compat doc python test"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- python? ( ${PYTHON_REQUIRED_USE} )
- ^^ ( abi4-compat abi5-compat abi6-compat )
-"
-
-RDEPEND="
- dev-libs/boost:=
- dev-libs/c-blosc:=
- dev-libs/jemalloc:=
- dev-libs/log4cplus:=
- media-libs/glfw
- media-libs/openexr:=
- sys-libs/zlib:=
- x11-libs/libXcursor
- x11-libs/libXi
- x11-libs/libXinerama
- x11-libs/libXrandr
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-libs/boost:=[python?,${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- ')
- )"
-
-DEPEND="
- ${RDEPEND}
- dev-cpp/tbb
-"
-
-BDEPEND="
- >=dev-util/cmake-3.16.2-r1
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- )
- test? ( dev-util/cppunit )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-multilib-header-source.patch"
- "${FILESDIR}/${PN}-4.0.2-fix-const-correctness-for-unittest.patch"
- "${FILESDIR}/${P}-use-gnuinstalldirs.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local myprefix="${EPREFIX}/usr/"
-
- local version
- if use abi4-compat; then
- version=4
- elif use abi5-compat; then
- version=5
- elif use abi6-compat; then
- version=6
- else
- die "Openvdb ABI version not specified"
- fi
-
- local mycmakeargs=(
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}"
- -DOPENVDB_ABI_VERSION_NUMBER="${version}"
- -DOPENVDB_BUILD_DOCS=$(usex doc)
- -DOPENVDB_BUILD_PYTHON_MODULE=$(usex python)
- -DOPENVDB_BUILD_UNITTESTS=$(usex test)
- -DOPENVDB_ENABLE_RPATH=OFF
- -DCHOST="${CHOST}"
- )
-
- use python && mycmakeargs+=( -DPYOPENVDB_INSTALL_DIRECTORY="$(python_get_sitedir)" )
- use test && mycmakeargs+=( -DCPPUNIT_LOCATION="${myprefix}" )
-
- cmake_src_configure
-}
diff --git a/media-gfx/openvdb/openvdb-7.0.0.ebuild b/media-gfx/openvdb/openvdb-7.0.0.ebuild
deleted file mode 100644
index db984b8cdbfb..000000000000
--- a/media-gfx/openvdb/openvdb-7.0.0.ebuild
+++ /dev/null
@@ -1,123 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-inherit cmake flag-o-matic python-single-r1
-
-DESCRIPTION="Library for the efficient manipulation of volumetric data"
-HOMEPAGE="https://www.openvdb.org"
-SRC_URI="https://github.com/AcademySoftwareFoundation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cpu_flags_x86_avx cpu_flags_x86_sse4_2 doc numpy python static-libs test utils abi5-compat abi6-compat +abi7-compat"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- numpy? ( python )
- ^^ ( abi5-compat abi6-compat abi7-compat )
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-RDEPEND="
- dev-libs/boost:=
- dev-libs/c-blosc:=
- dev-libs/jemalloc:=
- dev-libs/log4cplus:=
- media-libs/glfw
- media-libs/openexr:=
- sys-libs/zlib:=
- x11-libs/libXcursor
- x11-libs/libXi
- x11-libs/libXinerama
- x11-libs/libXrandr
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-libs/boost:=[numpy?,python?,${PYTHON_USEDEP}]
- numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
- ')
- )
-"
-
-DEPEND="
- ${RDEPEND}
- dev-cpp/tbb
-"
-
-BDEPEND="
- >=dev-util/cmake-3.16.2-r1
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- )
- test? ( dev-util/cppunit )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-7.1.0-0001-Fix-multilib-header-source.patch"
- "${FILESDIR}/${PN}-7.1.0-0002-Fix-doc-install-dir.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local myprefix="${EPREFIX}/usr/"
-
- local version
- if use abi5-compat; then
- version=5
- elif use abi6-compat; then
- version=6
- elif use abi7-compat; then
- version=7
- else
- die "Openvdb abi version is not compatible"
- fi
-
- local mycmakeargs=(
- -DCHOST="${CHOST}"
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/"
- -DOPENVDB_ABI_VERSION_NUMBER="${version}"
- -DOPENVDB_BUILD_DOCS=$(usex doc)
- -DOPENVDB_BUILD_UNITTESTS=$(usex test)
- -DOPENVDB_BUILD_VDB_LOD=$(usex !utils)
- -DOPENVDB_BUILD_VDB_RENDER=$(usex !utils)
- -DOPENVDB_BUILD_VDB_VIEW=$(usex !utils)
- -DOPENVDB_CORE_SHARED=ON
- -DOPENVDB_CORE_STATIC=$(usex static-libs)
- -DOPENVDB_ENABLE_RPATH=OFF
- -DUSE_CCACHE=OFF
- -DUSE_COLORED_OUTPUT=ON
- -DUSE_EXR=ON
- -DUSE_LOG4CPLUS=ON
- )
-
- if use python; then
- mycmakeargs+=(
- -DOPENVDB_BUILD_PYTHON_MODULE=ON
- -DUSE_NUMPY=$(usex numpy)
- -DPYOPENVDB_INSTALL_DIRECTORY="$(python_get_sitedir)"
- -DPython_EXECUTABLE="${EPYTHON}"
- )
- fi
-
- if use cpu_flags_x86_avx; then
- mycmakeargs+=( -DOPENVDB_SIMD=AVX )
- elif use cpu_flags_x86_sse4_2; then
- mycmakeargs+=( -DOPENVDB_SIMD=SSE42 )
- fi
-
- cmake_src_configure
-}
diff --git a/media-gfx/openvdb/openvdb-7.1.0.ebuild b/media-gfx/openvdb/openvdb-7.1.0.ebuild
deleted file mode 100644
index 912824ece66d..000000000000
--- a/media-gfx/openvdb/openvdb-7.1.0.ebuild
+++ /dev/null
@@ -1,121 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8,9} )
-
-inherit cmake flag-o-matic python-single-r1
-
-DESCRIPTION="Library for the efficient manipulation of volumetric data"
-HOMEPAGE="https://www.openvdb.org"
-SRC_URI="https://github.com/AcademySoftwareFoundation/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="cpu_flags_x86_avx cpu_flags_x86_sse4_2 doc numpy python static-libs test utils abi6-compat +abi7-compat"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="
- numpy? ( python )
- ^^ ( abi6-compat abi7-compat )
- python? ( ${PYTHON_REQUIRED_USE} )
-"
-
-RDEPEND="
- dev-libs/boost:=
- dev-libs/c-blosc:=
- dev-libs/jemalloc:=
- dev-libs/log4cplus:=
- media-libs/glfw
- media-libs/openexr:=
- sys-libs/zlib:=
- x11-libs/libXcursor
- x11-libs/libXi
- x11-libs/libXinerama
- x11-libs/libXrandr
- python? (
- ${PYTHON_DEPS}
- $(python_gen_cond_dep '
- dev-libs/boost:=[numpy?,python?,${PYTHON_USEDEP}]
- numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )
- ')
- )
-"
-
-DEPEND="
- ${RDEPEND}
- dev-cpp/tbb
-"
-
-BDEPEND="
- >=dev-util/cmake-3.16.2-r1
- virtual/pkgconfig
- doc? (
- app-doc/doxygen
- dev-texlive/texlive-bibtexextra
- dev-texlive/texlive-fontsextra
- dev-texlive/texlive-fontutils
- dev-texlive/texlive-latex
- dev-texlive/texlive-latexextra
- )
- test? ( dev-util/cppunit )
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-0001-Fix-multilib-header-source.patch"
- "${FILESDIR}/${P}-0002-Fix-doc-install-dir.patch"
-)
-
-pkg_setup() {
- use python && python-single-r1_pkg_setup
-}
-
-src_configure() {
- local myprefix="${EPREFIX}/usr/"
-
- local version
- if use abi6-compat; then
- version=6
- elif use abi7-compat; then
- version=7
- else
- die "Openvdb abi version is not compatible"
- fi
-
- local mycmakeargs=(
- -DCHOST="${CHOST}"
- -DCMAKE_INSTALL_DOCDIR="share/doc/${PF}/"
- -DOPENVDB_ABI_VERSION_NUMBER="${version}"
- -DOPENVDB_BUILD_DOCS=$(usex doc)
- -DOPENVDB_BUILD_UNITTESTS=$(usex test)
- -DOPENVDB_BUILD_VDB_LOD=$(usex !utils)
- -DOPENVDB_BUILD_VDB_RENDER=$(usex !utils)
- -DOPENVDB_BUILD_VDB_VIEW=$(usex !utils)
- -DOPENVDB_CORE_SHARED=ON
- -DOPENVDB_CORE_STATIC=$(usex static-libs)
- -DOPENVDB_ENABLE_RPATH=OFF
- -DUSE_CCACHE=OFF
- -DUSE_COLORED_OUTPUT=ON
- -DUSE_EXR=ON
- -DUSE_LOG4CPLUS=ON
- )
-
- if use python; then
- mycmakeargs+=(
- -DOPENVDB_BUILD_PYTHON_MODULE=ON
- -DUSE_NUMPY=$(usex numpy)
- -DPYOPENVDB_INSTALL_DIRECTORY="$(python_get_sitedir)"
- -DPython_EXECUTABLE="${EPYTHON}"
- )
- fi
-
- if use cpu_flags_x86_avx; then
- mycmakeargs+=( -DOPENVDB_SIMD=AVX )
- elif use cpu_flags_x86_sse4_2; then
- mycmakeargs+=( -DOPENVDB_SIMD=SSE42 )
- fi
-
- cmake_src_configure
-}