summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-28 03:46:08 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-28 04:24:15 +0200
commitc806a5cb8904b6597a44325f482caa9df249eb80 (patch)
treecf647c860f931df149f53dc2445dc86b3ffe6319
parentdev-python/pytest: Bump to 8.2.0 (diff)
downloadgentoo-c806a5cb8904b6597a44325f482caa9df249eb80.tar.gz
gentoo-c806a5cb8904b6597a44325f482caa9df249eb80.tar.bz2
gentoo-c806a5cb8904b6597a44325f482caa9df249eb80.zip
dev-python/uv: Bump to 0.1.39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/uv/Manifest1
-rw-r--r--dev-python/uv/uv-0.1.39.ebuild121
2 files changed, 122 insertions, 0 deletions
diff --git a/dev-python/uv/Manifest b/dev-python/uv/Manifest
index 8e1c2e46c4db..f2d1a804f3ff 100644
--- a/dev-python/uv/Manifest
+++ b/dev-python/uv/Manifest
@@ -6,3 +6,4 @@ DIST uv-0.1.24-crates.tar.xz 64420840 BLAKE2B 7324461092a07c86aadaddf051aaa7454e
DIST uv-0.1.24.gh.tar.gz 899637 BLAKE2B fab26ba9934fc5f586505b5ac1fa386c11f07e51ca2bb2a79f46d5dec9475ba8d75ad8587223d5149df5f2a225146d020a49b7ff81ed26b949cff55892738c2d SHA512 520b47a096b50fce9e7b7af5bca203df9bf4c2d0aafbe28a3dcfe0592d8ddcaa7b58d52300c67454f6aeecfd196f1592be18e45c95b7c67257361917cdb0154d
DIST uv-0.1.38-crates.tar.xz 65881140 BLAKE2B c1a640c44d73d5607c8d07468cefc66c150135b0f0249362148bd2b8f8c99a43c9031a642c0f76140631177df947be7637b49e99e247afbd7efbebb2ad79bcb1 SHA512 99bf6f341f9e6cf8eb0834c436b81453615725cabd3ddc4cca34edb307200bdbb71e913e8ff52a2a1d11e5f1a4abfb4dbdfe40a9c4f114079a7d9fdace0bcaab
DIST uv-0.1.38.gh.tar.gz 1023332 BLAKE2B e62259084fc9122d311bbcac754796b9e0ac28f4865755e03729eb6ad5adab4f9e3f77c41af1dbdbdc3a55d5a4736875aa26ddc7b78b745c8d6fb4d6b8bbd959 SHA512 7dad22d038aad03ad72ee0c5fdb77ccfbf56fc94a38613373a037eb26c2f228bc6c883d542621b45f2a55c8d51b7345fdd919dc1db45aa4d598e368311c72fdd
+DIST uv-0.1.39.gh.tar.gz 1026174 BLAKE2B 857e3f3dd81fae33244bbae5b7e124886ee8c57576f57e5264fb11b89fcb842e18ec07756e70204dc28be0e02ac0368c238d69ae5b1c0a95ab07416a6cf1ccff SHA512 6454fde2eb5166c2097fb44c4b8f505d27344a4a63589589de402887a57c8e1aeed5d52c7e892530d16de9d4a187b6b423f70550016d3c233cec8300b81a8b34
diff --git a/dev-python/uv/uv-0.1.39.ebuild b/dev-python/uv/uv-0.1.39.ebuild
new file mode 100644
index 000000000000..eedac642a89d
--- /dev/null
+++ b/dev-python/uv/uv-0.1.39.ebuild
@@ -0,0 +1,121 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+CRATES="
+"
+
+declare -A GIT_CRATES=(
+ [async_zip]='https://github.com/charliermarsh/rs-async-zip;1dcb40cfe1bf5325a6fd4bfcf9894db40241f585;rs-async-zip-%commit%'
+ [pubgrub]='https://github.com/astral-sh/pubgrub;c26e485213e39582c6f2e4d45c0328422670e7a7;pubgrub-%commit%'
+)
+
+inherit cargo check-reqs
+
+CRATE_P=${PN}-0.1.38
+DESCRIPTION="A Python package installer and resolver, written in Rust"
+HOMEPAGE="
+ https://github.com/astral-sh/uv/
+ https://pypi.org/project/uv/
+"
+# pypi sdist misses scripts/, needed for tests
+SRC_URI="
+ https://github.com/astral-sh/uv/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ ${CARGO_CRATE_URIS}
+"
+if [[ ${PKGBUMPING} != ${PVR} ]]; then
+ SRC_URI+="
+ https://dev.gentoo.org/~mgorny/dist/${CRATE_P}-crates.tar.xz
+ "
+fi
+
+# most of the code
+LICENSE="|| ( Apache-2.0 MIT )"
+# crates/pep508-rs is || ( Apache-2.0 BSD-2 ) which is covered below
+# Dependent crate licenses
+LICENSE+="
+ 0BSD Apache-2.0 Apache-2.0-with-LLVM-exceptions BSD-2 BSD ISC MIT
+ MPL-2.0 Unicode-DFS-2016
+"
+# ring crate
+LICENSE+=" openssl"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="test"
+PROPERTIES="test_network"
+
+DEPEND="
+ dev-libs/libgit2:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=virtual/rust-1.77
+ test? (
+ dev-lang/python:3.8
+ dev-lang/python:3.9
+ dev-lang/python:3.10
+ dev-lang/python:3.11
+ dev-lang/python:3.12
+ )
+"
+
+QA_FLAGS_IGNORED="usr/bin/.*"
+
+check_space() {
+ local CHECKREQS_DISK_BUILD=3G
+ use debug && CHECKREQS_DISK_BUILD=9G
+ check-reqs_pkg_setup
+}
+
+pkg_pretend() {
+ check_space
+}
+
+pkg_setup() {
+ check_space
+}
+
+src_prepare() {
+ default
+
+ # https://github.com/vorot93/tokio-tar/pull/23
+ # (fortunately uv already depends on portable-atomic, so we don't
+ # have to fight Cargo.lock)
+ cd "${WORKDIR}/cargo_home/gentoo/tokio-tar-0.3.1" || die
+ eapply "${FILESDIR}/tokio-tar-0.3.1-ppc.patch"
+}
+
+src_configure() {
+ local myfeatures=(
+ # from upstream defaults
+ flate2/zlib-ng
+ python
+ pypi
+ git
+ maturin
+ # skip tests that require specific patch version of the interpreter:
+ # python-patch
+ )
+
+ cargo_src_configure --no-default-features
+}
+
+src_compile() {
+ cd crates/uv || die
+ cargo_src_compile
+}
+
+src_test() {
+ cd crates/uv || die
+ cargo_src_test --no-fail-fast
+}
+
+src_install() {
+ cd crates/uv || die
+ cargo_src_install
+}