summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-17 07:38:00 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-17 08:25:47 +0200
commitc82cae2c8631299e56579c16af164b11a00d835d (patch)
treef29b43a4727c53f84b18443380f4565e4610ac48
parentdev-python/python-glanceclient: Bump to 4.6.0 (diff)
downloadgentoo-c82cae2c8631299e56579c16af164b11a00d835d.tar.gz
gentoo-c82cae2c8631299e56579c16af164b11a00d835d.tar.bz2
gentoo-c82cae2c8631299e56579c16af164b11a00d835d.zip
dev-python/cliff: Bump to 4.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/cliff/Manifest1
-rw-r--r--dev-python/cliff/cliff-4.7.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/cliff/Manifest b/dev-python/cliff/Manifest
index a884de01fe6c..bfe0f1eeca57 100644
--- a/dev-python/cliff/Manifest
+++ b/dev-python/cliff/Manifest
@@ -1 +1,2 @@
DIST cliff-4.6.0.tar.gz 83765 BLAKE2B a71ec00ac4525b960da4b40135477a3ed3fab8651c12b69af1a48ef19ae6e2eec37c8ab8f83ab23e0a948b002a7bfb152b677fd0ec313deb5e70ee5cb37fdd46 SHA512 59e887eddbdf695927e9ece46749f3f62557fd20bb24d7ff109f174a4ae4886cb3b44994903522c1d31c83b9f7f101f16604f6ffc4167ed6405e49a09f236dd0
+DIST cliff-4.7.0.tar.gz 84250 BLAKE2B e49cb9b5e05ab37885df47b80489e41eaf7662cf39ce61bdcb545a6ef5496b786c94c60c2164af15ae9536af7a9841e723fa62091300b28a49beed8945941dc0 SHA512 f1e6a28fbedb911efae02a3827f019411b99afdc316fcb07b115ca2157dcd23bbcce72d2d63b9850bb5b1cb21a4787575528a26d178943f7aba2a125ed9b55e5
diff --git a/dev-python/cliff/cliff-4.7.0.ebuild b/dev-python/cliff/cliff-4.7.0.ebuild
new file mode 100644
index 000000000000..087b9699e509
--- /dev/null
+++ b/dev-python/cliff/cliff-4.7.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Command Line Interface Formulation Framework"
+HOMEPAGE="
+ https://opendev.org/openstack/cliff/
+ https://github.com/openstack/cliff/
+ https://pypi.org/project/cliff/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/autopage-0.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cmd2-0.8.0[${PYTHON_USEDEP}]
+ dev-python/prettytable[${PYTHON_USEDEP}]
+ >=dev-python/pyparsing-2.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.12.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-2.0.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/fixtures-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/testtools-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/testscenarios-0.4[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest