summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-03 04:28:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-03 04:49:04 +0200
commitc8382a413cd91c1f28283ae1c168111a3766f47e (patch)
tree388fa38f0ecb63acf4d08909ecd8ac935283f9ff
parentpackage.mask: Unmask dev-python/picobox (diff)
downloadgentoo-c8382a413cd91c1f28283ae1c168111a3766f47e.tar.gz
gentoo-c8382a413cd91c1f28283ae1c168111a3766f47e.tar.bz2
gentoo-c8382a413cd91c1f28283ae1c168111a3766f47e.zip
dev-python/python-lsp-server: Bump to 1.7.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-lsp-server/Manifest1
-rw-r--r--dev-python/python-lsp-server/python-lsp-server-1.7.2.ebuild86
2 files changed, 87 insertions, 0 deletions
diff --git a/dev-python/python-lsp-server/Manifest b/dev-python/python-lsp-server/Manifest
index 2aa1448333c8..643efa895fad 100644
--- a/dev-python/python-lsp-server/Manifest
+++ b/dev-python/python-lsp-server/Manifest
@@ -1 +1,2 @@
DIST python-lsp-server-1.7.1.tar.gz 95731 BLAKE2B 0cdcda04ef849cb0c5fa83f1f701e986e22fb1228112eaf355bfedc52cca4fcc5927352c71b74fa3903526d8a1fc80fa57ac3e6ee7bcc2609556c2398dd2bbb8 SHA512 36c90f45071f35d0aeb0a57795eb6e9fb531baf9e8b468031b0d3e9eb2d53bee439893a333c6bf5f9d5b0818ec53675a3824850abef3e866e8ebdcd4a6142c48
+DIST python-lsp-server-1.7.2.tar.gz 97050 BLAKE2B f13503d21dc8b50cfedc711bd01d47830cba7f989c14c908904f639190b883a12fabacab06d107638ec53bc84bf4f43b8aeab353793d98bfe4e8d50ddb2a671d SHA512 aaa31a72391dbf0f6b40ca954cbd2377c4105371a54036d8cbab52ee0360a2400c453d47bbccbe3bea78e3189aa4006aeb7546bd99cad3a8f0bc352a0594e885
diff --git a/dev-python/python-lsp-server/python-lsp-server-1.7.2.ebuild b/dev-python/python-lsp-server/python-lsp-server-1.7.2.ebuild
new file mode 100644
index 000000000000..21e5123fbb22
--- /dev/null
+++ b/dev-python/python-lsp-server/python-lsp-server-1.7.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 optfeature pypi
+
+DESCRIPTION="Python Language Server for the Language Server Protocol"
+HOMEPAGE="https://github.com/python-lsp/python-lsp-server"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="all-plugins"
+
+BDEPEND="
+ test? (
+ >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/flake8-5.0.0[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-6.3.0[${PYTHON_USEDEP}]
+ <dev-python/pydocstyle-6.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ dev-python/QtPy[gui,testlib,${PYTHON_USEDEP}]
+ >=dev-python/rope-1.2.0[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+ >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+RDEPEND="
+ dev-python/docstring-to-markdown[${PYTHON_USEDEP}]
+ >=dev-python/jedi-0.17.2[${PYTHON_USEDEP}]
+ >=dev-python/python-lsp-jsonrpc-1.0.0[${PYTHON_USEDEP}]
+ dev-python/pluggy[${PYTHON_USEDEP}]
+ all-plugins? (
+ >=dev-python/autopep8-1.6.0[${PYTHON_USEDEP}]
+ >=dev-python/flake8-5.0.0[${PYTHON_USEDEP}]
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-6.3.0[${PYTHON_USEDEP}]
+ <dev-python/pydocstyle-6.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/pylint-2.5.0[${PYTHON_USEDEP}]
+ >=dev-python/rope-1.2.0[${PYTHON_USEDEP}]
+ dev-python/yapf[${PYTHON_USEDEP}]
+ >=dev-python/whatthepatch-1.0.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # broken by presence of pathlib2
+ 'test/plugins/test_autoimport.py::test_autoimport_pathlib[completions0]'
+)
+
+python_prepare_all() {
+ # remove pytest-cov dep
+ sed -i -e '/addopts =/d' pyproject.toml || die
+ # unpin all the deps
+ sed -i -e 's:,<[0-9.]*::' pyproject.toml || die
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ optfeature "Automatically format Python code to conform to the PEP 8 style guide" dev-python/autopep8
+ optfeature "A wrapper around PyFlakes, pep8 & mccabe" dev-python/flake8
+ optfeature "flake8 plugin: McCabe complexity checker" dev-python/mccabe
+ optfeature "Python style guide checker (fka pep8)" dev-python/pycodestyle
+ optfeature "Python docstring style checker" dev-python/pydocstyle
+ optfeature "Passive checker for Python programs" dev-python/pyflakes
+ optfeature "Python code static checker" dev-python/pylint
+ optfeature "Python refactoring library" dev-python/rope
+ optfeature "A formatter for Python files" dev-python/yapf
+}