summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-15 08:00:56 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-15 08:07:44 +0200
commitc83eb58827c3b34b29785f87d261248d8f028091 (patch)
tree7e3e9bbdcc3c44035a3949a7beeb954731d2d108
parentdev-python/socksio: Enable py3.11 (diff)
downloadgentoo-c83eb58827c3b34b29785f87d261248d8f028091.tar.gz
gentoo-c83eb58827c3b34b29785f87d261248d8f028091.tar.bz2
gentoo-c83eb58827c3b34b29785f87d261248d8f028091.zip
dev-python/re-assert: Use PEP517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/re-assert/re-assert-1.1.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/re-assert/re-assert-1.1.0-r1.ebuild b/dev-python/re-assert/re-assert-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..b90bdb332c51
--- /dev/null
+++ b/dev-python/re-assert/re-assert-1.1.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Show where your regex match assertion failed"
+HOMEPAGE="
+ https://github.com/asottile/re-assert/
+ https://pypi.org/project/re-assert/
+"
+SRC_URI="
+ https://github.com/asottile/re-assert/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/regex[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest