summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-26 15:25:40 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-26 17:47:18 +0200
commitc84523afbe55c6cfc291122dde1427a8e92bdaf3 (patch)
tree7c8ba98c2b964e1f97bb3e3ef35010055b0dbb97
parentnet-misc/miniupnpd: Bump to 2.1.20190625 (diff)
downloadgentoo-c84523afbe55c6cfc291122dde1427a8e92bdaf3.tar.gz
gentoo-c84523afbe55c6cfc291122dde1427a8e92bdaf3.tar.bz2
gentoo-c84523afbe55c6cfc291122dde1427a8e92bdaf3.zip
net-libs/miniupnpc: Bump to 2.1.20190625
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-libs/miniupnpc/Manifest1
-rw-r--r--net-libs/miniupnpc/miniupnpc-2.1.20190625.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/net-libs/miniupnpc/Manifest b/net-libs/miniupnpc/Manifest
index b427d72ddd31..2f4d80d3671a 100644
--- a/net-libs/miniupnpc/Manifest
+++ b/net-libs/miniupnpc/Manifest
@@ -1,2 +1,3 @@
DIST miniupnpc-2.1.20190210.tar.gz 94125 BLAKE2B 1cb8e4cd4d015d82eb15eec20e93b14a9f280aeabfc54e96ff9511db7fddf9713b9bffd0893c17f29beede29c6bfe73e6a459f7b20c9e4b33c88753b39cb7a0e SHA512 51f662c2a7a78cd99a793ff8b89097d895c80aaca696109c06106f8bb2601465207e068a410134cc66a61b4c0e11d4635bac6e9efdfe3fe8c4f813ac9e7a2fc2
DIST miniupnpc-2.1.20190408.tar.gz 94216 BLAKE2B 19b0bee46d2f738939fda31c465779a6e6c7c04b2e975aed77c3a642bbfd1c61813367da5f2aa3f351fe1e5a71a842bfcd7b54c4faf589e345ddb1551bc322c6 SHA512 faa0f1363ebb59ca636b6c974188c52903ad07652f8268563c9c1a5826fafc2458d9f521efd3546fbbd4b71b3b14a50ba89dda52757adad1db81c31d9ba0987a
+DIST miniupnpc-2.1.20190625.tar.gz 94461 BLAKE2B 26c881c2ef99640e99a5c9cb138cc88dc29a25cd57fffaeaffcf521ded11402fd34ad1001639cd0659fdef9debd247dded5c1903b69f36b74b059c1e282bcdfb SHA512 d55a959bb2fce2c1747fa95da53d9993220403d2c511b12f489b80a7941b28238561f90a1cd60be9fa2bd62777fbfd3cef370db694b9970f73ccbdf3ef49aa48
diff --git a/net-libs/miniupnpc/miniupnpc-2.1.20190625.ebuild b/net-libs/miniupnpc/miniupnpc-2.1.20190625.ebuild
new file mode 100644
index 000000000000..daca72280309
--- /dev/null
+++ b/net-libs/miniupnpc/miniupnpc-2.1.20190625.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="UPnP client library and a simple UPnP client"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/17"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 kernel_linux static-libs"
+
+RDEPEND=""
+DEPEND="kernel_linux? ( sys-apps/lsb-release sys-apps/which )"
+
+src_prepare() {
+ eapply_user
+
+ # These bins are not installed, upnpc-static requires building static lib
+ sed -i -e '/EXECUTABLES =/s/ upnpc-static listdevices//' Makefile || die
+ # Prevent gzipping manpage.
+ sed -i -e '/gzip/d' Makefile || die
+
+ if ! use static-libs; then
+ sed -i \
+ -e '/FILESTOINSTALL =/s/ $(LIBRARY)//' \
+ -e '/$(INSTALL) -m 644 $(LIBRARY) $(DESTDIR)$(INSTALLDIRLIB)/d' \
+ Makefile || die
+ fi
+}
+
+# Upstream cmake causes more trouble than it fixes,
+# so we'll just stay with the Makefile for now.
+
+src_compile() {
+ tc-export CC AR
+ emake upnpc-shared $(usex static-libs upnpc-static '')
+}
+
+src_test() {
+ emake -j1 HAVE_IPV6=$(usex ipv6) check
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr" \
+ INSTALLDIRLIB="${EPREFIX}/usr/$(get_libdir)" \
+ install
+
+ dodoc README Changelog.txt
+}