summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-14 09:13:49 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-14 09:18:37 +0100
commitc84ac3445c7299fd874a2c02ec5ac76c1d3835ea (patch)
tree39cee31d620b0593490991392be1e345c0deba4b
parentdev-python/pytest-helpers-namespace: Enable pypy3 (diff)
downloadgentoo-c84ac3445c7299fd874a2c02ec5ac76c1d3835ea.tar.gz
gentoo-c84ac3445c7299fd874a2c02ec5ac76c1d3835ea.tar.bz2
gentoo-c84ac3445c7299fd874a2c02ec5ac76c1d3835ea.zip
dev-python/noseofyeti: New package, v2.4.6
NIH test dependency for dev-python/dict2xml. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/noseofyeti/Manifest1
-rw-r--r--dev-python/noseofyeti/metadata.xml12
-rw-r--r--dev-python/noseofyeti/noseofyeti-2.4.6.ebuild39
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/noseofyeti/Manifest b/dev-python/noseofyeti/Manifest
new file mode 100644
index 000000000000..30e9c8c79a02
--- /dev/null
+++ b/dev-python/noseofyeti/Manifest
@@ -0,0 +1 @@
+DIST nose-of-yeti-release-2.4.6.gh.tar.gz 44946 BLAKE2B 8a99eb299b389729030d1f5de0f686d4186d1657c41f35aa8712c1a2a8214d808c853e1a435f05a262c676f1f4dcc453fc0541582f45d30f23696a83ec3e9c82 SHA512 276c1ad5d2c67c26ee8d3e3e9184f0881c4084889324e9b45d79897d46d94f64f4fc7267d2578feb76690fd2165633fa217a6bf1588585a5e0cf84dfceaa2a4b
diff --git a/dev-python/noseofyeti/metadata.xml b/dev-python/noseofyeti/metadata.xml
new file mode 100644
index 000000000000..c74af1cdd5de
--- /dev/null
+++ b/dev-python/noseofyeti/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">delfick/nose-of-yeti</remote-id>
+ <remote-id type="pypi">noseOfYeti</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/noseofyeti/noseofyeti-2.4.6.ebuild b/dev-python/noseofyeti/noseofyeti-2.4.6.ebuild
new file mode 100644
index 000000000000..777f4594a622
--- /dev/null
+++ b/dev-python/noseofyeti/noseofyeti-2.4.6.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+MY_P=nose-of-yeti-release-${PV}
+DESCRIPTION="A custom python codec that provides an RSpec style dsl for python"
+HOMEPAGE="
+ https://github.com/delfick/nose-of-yeti/
+ https://pypi.org/project/noseOfYeti/
+"
+SRC_URI="
+ https://github.com/delfick/nose-of-yeti/archive/release-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ dev-python/black[${PYTHON_USEDEP}]
+ dev-python/pytest-helpers-namespace[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # requires alt-pytest-asyncio
+ tests/test_using_pytest.py::TestPyTest::test_it_collects_tests_correctly
+)