summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-02 10:46:29 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-02 11:13:38 +0200
commitc854b3761b3d0bd56d5087f5967bfb579807652a (patch)
tree4274cec53653a9c69223e5c1cd54e9a5dae20c6d
parentmail-mta/postfix: mips keyworded for later releases (diff)
downloadgentoo-c854b376.tar.gz
gentoo-c854b376.tar.bz2
gentoo-c854b376.zip
app-forensics/air: Allow more netcat alternatives (#483438)
Package-Manager: Portage-2.3.27, Repoman-2.3.9
-rw-r--r--app-forensics/air/air-2.0.0-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-forensics/air/air-2.0.0-r2.ebuild b/app-forensics/air/air-2.0.0-r2.ebuild
new file mode 100644
index 000000000000..733bedeb8e4d
--- /dev/null
+++ b/app-forensics/air/air-2.0.0-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A GUI front-end to dd/dc3dd"
+HOMEPAGE="http://air-imager.sourceforge.net/"
+SRC_URI="mirror://sourceforge/air-imager/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="crypt"
+
+# coreutils are needed for /usr/bin/split binary
+COMMON_DEPEND="userland_GNU? ( sys-apps/coreutils )"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-perl/Tk-804.27.0
+ userland_GNU? ( app-arch/sharutils )
+"
+# TODO: air can utilize dc3dd, but it is not in portage ATM
+RDEPEND="${COMMON_DEPEND}
+ || (
+ net-analyzer/netcat6
+ net-analyzer/netcat
+ net-analyzer/gnu-netcat
+ )
+ app-arch/mt-st
+ crypt? ( net-analyzer/cryptcat )
+"
+
+src_install() {
+ export PERLTK_VER=`perl -e 'use Tk;print "$Tk::VERSION";'`
+
+ env INTERACTIVE=no INSTALL_DIR="${D}/usr" TEMP_DIR="${T}" \
+ FINAL_INSTALL_DIR=/usr \
+ ./install-${P} \
+ || die "failed to install - please attach ${T}/air-install.log to a bug report at https://bugs.gentoo.org"
+
+ einstalldocs
+ dodoc "${T}/air-install.log"
+
+ fowners root:users /usr/share/air/logs
+ fperms ug+rwx /usr/share/air/logs
+ fperms a+x /usr/bin/air
+
+ mkfifo "${D}usr/share/air/air-fifo" || die "pipe creation failed"
+ fperms ug+rw /usr/share/air/air-fifo
+ fowners root:users /usr/share/air/air-fifo
+}