summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-30 07:27:17 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-30 08:08:12 +0100
commitc86d46515b7d0bdae57c0b2c3560deff3c21a4e0 (patch)
tree27fa34f7ad349826c896b00fb9ecdf8b66cb0f8a
parentdev-python/icalendar: Bump to 5.0.4 (diff)
downloadgentoo-c86d4651.tar.gz
gentoo-c86d4651.tar.bz2
gentoo-c86d4651.zip
dev-python/lz4: Bump to 4.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/lz4/Manifest1
-rw-r--r--dev-python/lz4/lz4-4.3.1.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/lz4/Manifest b/dev-python/lz4/Manifest
index ab19d8e1c510..ec26456dae2b 100644
--- a/dev-python/lz4/Manifest
+++ b/dev-python/lz4/Manifest
@@ -1 +1,2 @@
DIST lz4-4.0.2.tar.gz 164309 BLAKE2B ea08c9786ee224aaf668a74269413c836a4288ab1a3c27497012621bdda9c8c1729c4cb6ba49cb74e7e5302fabbfddba94f8ed94a9612fdf21018a5cbdc70566 SHA512 f2fdd133b9c7389cd7d45b41e61944093b65bcbf529146740fa3721e683a9b4554166c2ad719298e6153e61facc4a4cb021ffd969cd16d4a5b6555fd8f14728f
+DIST lz4-4.3.1.tar.gz 170970 BLAKE2B dcc2f67860f60a7805c2d302aca3b610198e128e2dbd1c54d78ffb65c4baec3cf4ab7dfe2aebf713397e67d9c8b9a95a0dbb493c16692f2591d657bfe1a3da43 SHA512 4dbb3179892d44fe7d7b5280931c39434d28f5750b4588a16a5547588c756e4279daf8a5f0edcfaf958c7cb25e65188c0a9bb36509d0dc7a7083072a19ee6d55
diff --git a/dev-python/lz4/lz4-4.3.1.ebuild b/dev-python/lz4/lz4-4.3.1.ebuild
new file mode 100644
index 000000000000..358b79f49818
--- /dev/null
+++ b/dev-python/lz4/lz4-4.3.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="
+ https://github.com/python-lz4/python-lz4/
+ https://pypi.org/project/lz4/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ app-arch/lz4:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # lz4.stream is not officially supported and not installed by default
+ # (we do not support installing it at the moment)
+ tests/stream
+)