summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2019-06-05 11:30:47 +0200
committerFabian Groffen <grobian@gentoo.org>2019-06-05 11:30:57 +0200
commitc872ec9942b167d7d42c7d748c88a0827c52f022 (patch)
treef754a553dc49b07e704539859872e8a21b1b9f08
parentnet-im/skypeforlinux: Bump to 8.46.0.60 (diff)
downloadgentoo-c872ec99.tar.gz
gentoo-c872ec99.tar.bz2
gentoo-c872ec99.zip
app-crypt/libb2: fix check to respect CFLAGS, thanks jer
Closes: https://bugs.gentoo.org/687412 Signed-off-by: Fabian Groffen <grobian@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
-rw-r--r--app-crypt/libb2/libb2-0.98.1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/app-crypt/libb2/libb2-0.98.1.ebuild b/app-crypt/libb2/libb2-0.98.1.ebuild
index 1f7105ca4785..440bcd1bb916 100644
--- a/app-crypt/libb2/libb2-0.98.1.ebuild
+++ b/app-crypt/libb2/libb2-0.98.1.ebuild
@@ -45,9 +45,18 @@ src_configure() {
$(use_enable openmp)
}
-src_compile() {
+do_make() {
# respect our CFLAGS when native-cflags is not in effect
- emake $(use native-cflags && echo no)CFLAGS="${CFLAGS}"
+ local openmp=$(use openmp && echo -fopenmp)
+ emake $(use native-cflags && echo no)CFLAGS="${CFLAGS} ${openmp}" "$@"
+}
+
+src_compile() {
+ do_make
+}
+
+src_test() {
+ do_make check
}
src_install() {