summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2018-11-16 23:03:59 +0000
committerJames Le Cuirot <chewi@gentoo.org>2018-11-16 23:04:52 +0000
commitc894be80ab28c389a39a3f7fea974120fff5b83b (patch)
tree4f1a813e3204058c354e2ff47da19afc3d27c9ad
parentdev-libs/weston: Version bump to 5.0.0 (diff)
downloadgentoo-c894be80.tar.gz
gentoo-c894be80.tar.bz2
gentoo-c894be80.zip
dev-libs/weston: Updates to 9999 including remoting USE flag
Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--dev-libs/weston/metadata.xml1
-rw-r--r--dev-libs/weston/weston-9999.ebuild28
2 files changed, 17 insertions, 12 deletions
diff --git a/dev-libs/weston/metadata.xml b/dev-libs/weston/metadata.xml
index c1c3e3956fa3..c976a4437cfc 100644
--- a/dev-libs/weston/metadata.xml
+++ b/dev-libs/weston/metadata.xml
@@ -15,6 +15,7 @@
<flag name="ivi">Enable the IVI shell</flag>
<flag name="launch">Install weston-launch utility</flag>
<flag name="rdp">Enable Remote Desktop Protocol compositor support</flag>
+ <flag name="remoting">Enable plugin to stream output to remote hosts using <pkg>media-libs/gstreamer</pkg></flag>
<flag name="resize-optimization">Increase performance, allocate more RAM. Recommended to disable on Raspberry Pi</flag>
<flag name="screen-sharing">Enable screen-sharing through RDP</flag>
<flag name="unwind">Enable libunwind usage for backtraces</flag>
diff --git a/dev-libs/weston/weston-9999.ebuild b/dev-libs/weston/weston-9999.ebuild
index 44880eb96399..40aa43e4412b 100644
--- a/dev-libs/weston/weston-9999.ebuild
+++ b/dev-libs/weston/weston-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -25,7 +25,7 @@ fi
LICENSE="MIT CC-BY-SA-3.0"
SLOT="0"
-IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi jpeg +launch lcms rdp +resize-optimization screen-sharing static-libs +suid systemd test unwind wayland-compositor webp +X xwayland"
+IUSE="colord dbus +drm editor examples fbdev +gles2 headless ivi jpeg +launch lcms rdp remoting +resize-optimization screen-sharing static-libs +suid systemd test wayland-compositor webp +X xwayland"
REQUIRED_USE="
drm? ( gles2 )
@@ -38,13 +38,13 @@ REQUIRED_USE="
RDEPEND="
>=dev-libs/libinput-0.8.0
>=dev-libs/wayland-1.12.0
- >=dev-libs/wayland-protocols-1.8
+ >=dev-libs/wayland-protocols-1.14
lcms? ( media-libs/lcms:2 )
media-libs/libpng:0=
webp? ( media-libs/libwebp:0= )
jpeg? ( virtual/jpeg:0= )
>=x11-libs/cairo-1.11.3
- >=x11-libs/libdrm-2.4.30
+ >=x11-libs/libdrm-2.4.68
>=x11-libs/libxkbcommon-0.5.0
>=x11-libs/pixman-0.25.2
x11-misc/xkeyboard-config
@@ -55,7 +55,7 @@ RDEPEND="
colord? ( >=x11-misc/colord-0.1.27 )
dbus? ( >=sys-apps/dbus-1.6 )
drm? (
- media-libs/mesa[gbm]
+ >=media-libs/mesa-17.1[gbm]
>=sys-libs/mtdev-1.1.0
>=virtual/udev-136
)
@@ -63,13 +63,16 @@ RDEPEND="
gles2? (
media-libs/mesa[gles2,wayland]
)
- rdp? ( >=net-misc/freerdp-1.1.0_beta1_p20130710 )
+ rdp? ( >=net-misc/freerdp-1.1.0:= )
+ remoting? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )
systemd? (
sys-auth/pambase[systemd]
>=sys-apps/systemd-209[pam]
)
launch? ( sys-auth/pambase )
- unwind? ( sys-libs/libunwind )
X? (
>=x11-libs/libxcb-1.9
x11-libs/libX11
@@ -95,11 +98,12 @@ src_prepare() {
}
src_configure() {
- local myconf
+ local myconf=()
+
if use examples || use test; then
- myconf="--enable-simple-clients"
+ myconf+=( --enable-simple-clients )
else
- myconf="--disable-simple-clients"
+ myconf+=( --disable-simple-clients )
fi
econf \
@@ -116,7 +120,7 @@ src_configure() {
$(use_enable launch weston-launch) \
$(use_enable colord) \
$(use_enable gles2 egl) \
- $(use_enable unwind libunwind) \
+ $(use_enable remoting) \
$(use_enable resize-optimization) \
$(use_enable screen-sharing) \
$(use_enable suid setuid-install) \
@@ -132,7 +136,7 @@ src_configure() {
--disable-simple-dmabuf-v4l-client \
--disable-simple-egl-clients \
--disable-vaapi-recorder \
- ${myconf}
+ "${myconf[@]}"
}
src_test() {