summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-29 01:40:21 +0100
committerSam James <sam@gentoo.org>2023-03-29 01:40:21 +0100
commitc8a078b54534910d57cc5ff47d7740fd44629548 (patch)
treedb63395dca78234e2915ffb5d9114483fbfdb842
parentdev-embedded/platformio: add github upstream metadata (diff)
downloadgentoo-c8a078b54534910d57cc5ff47d7740fd44629548.tar.gz
gentoo-c8a078b54534910d57cc5ff47d7740fd44629548.tar.bz2
gentoo-c8a078b54534910d57cc5ff47d7740fd44629548.zip
dev-embedded/platformio: drop 6.1.5
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-embedded/platformio/Manifest1
-rw-r--r--dev-embedded/platformio/platformio-6.1.5.ebuild113
2 files changed, 0 insertions, 114 deletions
diff --git a/dev-embedded/platformio/Manifest b/dev-embedded/platformio/Manifest
index c1ccf407bba0..f4ae6a7f0739 100644
--- a/dev-embedded/platformio/Manifest
+++ b/dev-embedded/platformio/Manifest
@@ -1,2 +1 @@
-DIST platformio-6.1.5.tar.gz 290684 BLAKE2B 1beca08e70f6a932426e13e6b4755188ad2ac266c4b311b2e6ea560623ccc7479ad5fa1955c09e613eb62682164d1952be3b7f050a26d5a5b6bff26435bb2337 SHA512 43835a40636091d7062a1cbd96950ddb29592aba6c4eaeb80f37288f949bd95f3312cb5f33814cf8521e3b5bd3ceeb2e32e76c294ef5cbf992ed3c674d4a9ab7
DIST platformio-6.1.6.tar.gz 295288 BLAKE2B 4508f3eda25cbb2d2bad6881d7041a9bd8bb87b452564b3cabd58bec0506ca10e53b2552eee8ac1984cb429e5ea52c332d863f1c76a10b5106ab238e6506bb87 SHA512 879fbc759476118473d13375e4dcdbda901f48f5d0d9bb94bdd3ed09de2563603880b91d102e35eaf144e61cd457b132056e0a8293b762b3566a537f3b886078
diff --git a/dev-embedded/platformio/platformio-6.1.5.ebuild b/dev-embedded/platformio/platformio-6.1.5.ebuild
deleted file mode 100644
index bf0d59437b57..000000000000
--- a/dev-embedded/platformio/platformio-6.1.5.ebuild
+++ /dev/null
@@ -1,113 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..10} )
-
-inherit distutils-r1 udev
-
-DESCRIPTION="An open source ecosystem for IoT development"
-HOMEPAGE="https://platformio.org/"
-SRC_URI="https://github.com/platformio/platformio-core/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}"/${PN}-core-${PV}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- $(python_gen_cond_dep '
- =dev-python/aiofiles-22.1*[${PYTHON_USEDEP}]
- dev-python/ajsonrpc[${PYTHON_USEDEP}]
- <dev-python/bottle-0.13[${PYTHON_USEDEP}]
- =dev-python/click-8*[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- >=dev-python/pyserial-3[${PYTHON_USEDEP}]
- <dev-python/pyserial-4[${PYTHON_USEDEP}]
- >=dev-python/zeroconf-0.37[${PYTHON_USEDEP}]
- =dev-python/requests-2*[${PYTHON_USEDEP}]
- >=dev-python/semantic_version-2.9[${PYTHON_USEDEP}]
- <dev-python/semantic_version-3[${PYTHON_USEDEP}]
- =dev-python/tabulate-0.9*[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
- >=dev-python/pyelftools-0.27[${PYTHON_USEDEP}]
- <dev-python/pyelftools-1[${PYTHON_USEDEP}]
- =dev-python/marshmallow-3*[${PYTHON_USEDEP}]
- =dev-python/starlette-0.21*[${PYTHON_USEDEP}]
- =dev-python/uvicorn-0.19*[${PYTHON_USEDEP}]
- dev-python/wsproto[${PYTHON_USEDEP}]
- ')
- virtual/udev"
-DEPEND="virtual/udev"
-BDEPEND="test? ( $(python_gen_cond_dep 'dev-python/jsondiff[${PYTHON_USEDEP}]') )"
-
-# This list could be refined a bit to have individual tests which need network
-# (within EPYTEST_DESELECT) but so many need it that it doesn't seem worth it right now.
-EPYTEST_IGNORE=(
- # Requires network access
- tests/test_builder.py
- tests/package/test_manager.py
- tests/package/test_manifest.py
- tests/commands/test_platform.py
- tests/commands/test_test.py
- tests/commands/test_ci.py
- tests/commands/test_init.py
- tests/commands/test_lib.py
- tests/commands/test_lib_complex.py
- tests/commands/test_boards.py
- tests/commands/test_check.py
- tests/commands/test_run.py
- tests/commands/pkg/test_exec.py
- tests/commands/pkg/test_list.py
- tests/commands/pkg/test_outdated.py
- tests/commands/pkg/test_search.py
- tests/commands/pkg/test_show.py
- tests/commands/pkg/test_install.py
- tests/commands/pkg/test_uninstall.py
- tests/commands/pkg/test_update.py
- tests/misc/ino2cpp/test_ino2cpp.py
- tests/test_maintenance.py
- tests/test_misc.py
-)
-
-EPYTEST_DESELECT=(
- # Requires network access
- tests/misc/test_maintenance.py::test_check_pio_upgrade
- tests/misc/test_misc.py::test_ping_internet_ips
- tests/misc/test_misc.py::test_api_cache
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # Allow newer versions of zeroconf, Bug #831181.
- # Also wsproto.
- # ... and semantic_version, bug #853247.
- sed \
- -e '/zeroconf/s/<[0-9.*]*//' \
- -e '/wsproto/s/==.*/"/' \
- -e '/semantic_version/s/==[0-9.*]*//' \
- -i setup.py || die
-
- default
-}
-
-python_test() {
- epytest -k "not skip_ci"
-}
-
-src_install() {
- distutils-r1_src_install
- udev_dorules scripts/99-platformio-udev.rules
-}
-
-pkg_postinst() {
- udev_reload
-}
-
-pkg_postrm() {
- udev_reload
-}