summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephan Hartmann <sultan@gentoo.org>2021-09-22 08:20:44 +0200
committerStephan Hartmann <sultan@gentoo.org>2021-09-22 08:20:44 +0200
commitc8a2ebd2618b58d76c51027785f0c1cfd51568b2 (patch)
tree5bd373b1193813e62d0b13db1597245172d5af89
parentwww-client/microsoft-edge-dev: remove old (diff)
downloadgentoo-c8a2ebd2618b58d76c51027785f0c1cfd51568b2.tar.gz
gentoo-c8a2ebd2618b58d76c51027785f0c1cfd51568b2.tar.bz2
gentoo-c8a2ebd2618b58d76c51027785f0c1cfd51568b2.zip
www-client/opera: bump to 79.0.4143.50
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Stephan Hartmann <sultan@gentoo.org>
-rw-r--r--www-client/opera/Manifest1
-rw-r--r--www-client/opera/opera-79.0.4143.50.ebuild157
2 files changed, 158 insertions, 0 deletions
diff --git a/www-client/opera/Manifest b/www-client/opera/Manifest
index 81ff3fd98dff..9bce3b93c847 100644
--- a/www-client/opera/Manifest
+++ b/www-client/opera/Manifest
@@ -1,2 +1,3 @@
DIST opera-ffmpeg-codecs-93.0.4573.0.tar.xz 1389664 BLAKE2B 4efc7341655bed294d4c6237dd9e7d005a815c495a45bec6f0b7fcbec40345e22ad5199ec1db3c822c123663d3ce95e6b87af18b1ac6cad31793ae7fdb440918 SHA512 f7c62c6860d1440e91344c41d6c9b3fbef4745cb95262538dcb3af9147406b3b0c71e72605042c423cbdd618a53f902791bcb6b7fcc8a4cae92ebf3cb38e8407
DIST opera-stable_79.0.4143.22_amd64.deb 77553332 BLAKE2B 2f94947198e6e0953ded7cdda0f75be34f9041a65d5f87242e310e2b456299d038497fb00eb0c0bbc906986a97de8272fe8f541ddaba3ef377fd3a7b5c77adb3 SHA512 2d00bc4b63d5dab3d356d27f68f1babbf43033ca909ba83f3ccde1190c5d82a5320881852f1ec6c37c66ccc5e85377c2237ef066c22cd98519b79c56ce98e1ea
+DIST opera-stable_79.0.4143.50_amd64.deb 77519244 BLAKE2B db1d241ba5c1a793428cc2af7229ada3e57bff96c27a186977c894260e4d9d2fc2da58c4b42528a7403d9ecacc25a22ccfeb015674b8272710f581e14d6eaed8 SHA512 8ab2d8ad7bc1dacc9d80208d255a8a44e24563fe1939316734c0fca0a58062b949614833bb63a29cc63febf23a717d50ff68929a83d77766ac2e43a89b170798
diff --git a/www-client/opera/opera-79.0.4143.50.ebuild b/www-client/opera/opera-79.0.4143.50.ebuild
new file mode 100644
index 000000000000..d85e8c828656
--- /dev/null
+++ b/www-client/opera/opera-79.0.4143.50.ebuild
@@ -0,0 +1,157 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+CHROMIUM_LANGS="
+ be bg bn ca cs da de el en-GB en-US es-419 es fil fi fr-CA fr hi hr hu id
+ it ja ko lt lv ms nb nl pl pt-BR pt-PT ro ru sk sr sv sw ta te th tr uk vi
+ zh-CN zh-TW
+"
+
+# These are intended for ebuild maintainer use to force RPM if DEB is not available.
+: ${OPERA_FORCE_RPM=no}
+
+if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ OPERA_UNPACKER="rpm"
+ OPERA_ARCHIVE_EXT="rpm"
+else
+ OPERA_UNPACKER="unpacker"
+ OPERA_ARCHIVE_EXT="deb"
+fi
+
+inherit chromium-2 multilib pax-utils ${OPERA_UNPACKER} xdg
+
+DESCRIPTION="A fast and secure web browser"
+HOMEPAGE="https://www.opera.com/"
+LICENSE="OPERA-2018"
+SLOT="0"
+
+SRC_URI_BASE=(
+ "https://download1.operacdn.com/pub/${PN}"
+ "https://download2.operacdn.com/pub/${PN}"
+ "https://download3.operacdn.com/pub/${PN}"
+ "https://download4.operacdn.com/pub/${PN}"
+)
+
+if [[ ${PN} == opera ]]; then
+ MY_PN=${PN}-stable
+ SRC_URI_BASE=( "${SRC_URI_BASE[@]/%//desktop}" )
+else
+ MY_PN=${PN}
+fi
+
+KEYWORDS="-* ~amd64"
+
+FFMPEG_VERSION="93.0.4573.0"
+
+SRC_URI="${SRC_URI_BASE[@]/%//${PV}/linux/${MY_PN}_${PV}_amd64.${OPERA_ARCHIVE_EXT}}
+ proprietary-codecs? (
+ mirror+https://dev.gentoo.org/~sultan/distfiles/www-client/opera/opera-ffmpeg-codecs-${FFMPEG_VERSION}.tar.xz
+ )"
+
+IUSE="+proprietary-codecs suid"
+RESTRICT="bindist mirror strip"
+
+RDEPEND="
+ app-accessibility/at-spi2-atk:2
+ app-accessibility/at-spi2-core:2
+ dev-libs/atk
+ dev-libs/expat
+ dev-libs/glib:2
+ dev-libs/nspr
+ dev-libs/nss
+ gnome-base/gsettings-desktop-schemas
+ media-libs/alsa-lib
+ media-libs/mesa[gbm(+)]
+ net-misc/curl
+ net-print/cups
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:3
+ x11-libs/libdrm
+ x11-libs/libxcb
+ x11-libs/libxkbcommon
+ x11-libs/libxshmfence
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/pango
+"
+
+QA_PREBUILT="*"
+S=${WORKDIR}
+OPERA_HOME="opt/opera${PN#opera}"
+
+pkg_pretend() {
+ # Protect against people using autounmask overzealously
+ use amd64 || die "opera only works on amd64"
+}
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ :
+}
+
+src_install() {
+ dodir /
+ cd "${ED}" || die
+ if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ rpm_src_unpack "${A[0]}"
+ else
+ unpacker
+ fi
+
+ # move to /opt, bug #573052
+ mkdir -p "${OPERA_HOME%${PN}}"
+ if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ mv "usr/lib64/${PN}" "${OPERA_HOME%${PN}}" || die
+ else
+ mv "usr/lib/x86_64-linux-gnu/${PN}" "${OPERA_HOME%${PN}}" || die
+ fi
+ rm -r "usr/lib" || die
+
+ # disable auto update
+ rm "${OPERA_HOME}/${PN%-*}_autoupdate"{,.licenses,.version} || die
+
+ if [[ ${OPERA_FORCE_RPM} == yes ]]; then
+ rm "${OPERA_HOME}/setup_repo.sh" || die
+ else
+ rm -r "usr/share/lintian" || die
+
+ # fix docs
+ mv usr/share/doc/${MY_PN} usr/share/doc/${PF} || die
+ gzip -d usr/share/doc/${PF}/changelog.gz || die
+ fi
+
+ # fix desktop file
+ sed -i \
+ -e 's|^TargetEnvironment|X-&|g' \
+ usr/share/applications/${PN}.desktop || die
+
+ # remove unused language packs
+ pushd "${OPERA_HOME}/localization" > /dev/null || die
+ chromium_remove_language_paks
+ popd > /dev/null || die
+
+ # setup opera symlink
+ rm "usr/bin/${PN}" || die
+ dosym "../../${OPERA_HOME}/${PN}" "/usr/bin/${PN}"
+
+ # install proprietary codecs
+ rm "${OPERA_HOME}/resources/ffmpeg_preload_config.json" || die
+ if use proprietary-codecs; then
+ mv lib_extra "${OPERA_HOME}"
+ fi
+
+ # pax mark opera, bug #562038
+ pax-mark m "${OPERA_HOME}/opera"
+ # enable suid sandbox if requested
+ use suid && fperms 4711 "${OPERA_HOME}/opera_sandbox"
+}