summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-09-20 09:54:07 +0200
committerMichał Górny <mgorny@gentoo.org>2018-09-20 10:43:07 +0200
commitc8aee497eea5c9cf935a3f06e7c22edbb00210bb (patch)
treec532337880bcad21175038ed809869924fb3d27d
parentx11-themes/numix-icon-theme-circle: Version bump (v18.09.19) (diff)
downloadgentoo-c8aee497eea5c9cf935a3f06e7c22edbb00210bb.tar.gz
gentoo-c8aee497eea5c9cf935a3f06e7c22edbb00210bb.tar.bz2
gentoo-c8aee497eea5c9cf935a3f06e7c22edbb00210bb.zip
dev-python/recommonmark: Bump to 0.5.0_pre20180907
Take a fresh snapshot since upstream did not do a release in some time. It fixes compatibility with new versions of dev-python/CommonMark, enables tests and adds Python 3.7 support. Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/recommonmark/Manifest1
-rw-r--r--dev-python/recommonmark/recommonmark-0.5.0_pre20180907.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/recommonmark/Manifest b/dev-python/recommonmark/Manifest
index 1e1fab1df569..a94d132bddcc 100644
--- a/dev-python/recommonmark/Manifest
+++ b/dev-python/recommonmark/Manifest
@@ -1 +1,2 @@
DIST recommonmark-0.4.0.tar.gz 7112 BLAKE2B d0e0f95f251e859908523c90b012ef2b162823d72b87192651d08a9cb5217a8bf497caf0320cefd3e724f77d3ad4324db446ddb57de55fd308c7739b78f55c04 SHA512 30d900840093c9ee2c1a322aeaba64c06c6f236e4c86a8d7604edc7d9fb0e78d66387f844619364d9253585db3f38d212242d2798153f343bc01ad281c146c9c
+DIST recommonmark-33b5c2a4ec50d18d3f659aa119d3bd11452327da.tar.gz 22085 BLAKE2B 2225f8854eb92f9c905c5943c3d4db1cb56ccf22826f32101c9e8db6ac1a1658a543d58a71bfdd8650f225229be5c47658a6db9c6f535718eab5361589436d77 SHA512 4b4c3c9354c3de223c7d441b1665879d49a2f9f2328532901c69d10f4f8d90ff84e28aab3d1b4884edecd80071193ec69fbdbce735527ec2edc574b5a3d1fe88
diff --git a/dev-python/recommonmark/recommonmark-0.5.0_pre20180907.ebuild b/dev-python/recommonmark/recommonmark-0.5.0_pre20180907.ebuild
new file mode 100644
index 000000000000..620a81e57425
--- /dev/null
+++ b/dev-python/recommonmark/recommonmark-0.5.0_pre20180907.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+EGIT_COMMIT=33b5c2a4ec50d18d3f659aa119d3bd11452327da
+MY_P=${PN}-${EGIT_COMMIT}
+DESCRIPTION="Python docutils-compatibility bridge to CommonMark"
+HOMEPAGE="https://recommonmark.readthedocs.io/"
+SRC_URI="https://github.com/rtfd/recommonmark/archive/${EGIT_COMMIT}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/CommonMark-0.7.3[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.3.1[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}