summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-01-27 22:00:21 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-01-27 22:13:14 -0600
commitc8cb530ea13c0eae626d8ca430e8ac43d08758c9 (patch)
tree9556b89951540c6facb5c5f2d7b59658761ba645
parentdev-python/oslo-serialization: remove ocata (diff)
downloadgentoo-c8cb530e.tar.gz
gentoo-c8cb530e.tar.bz2
gentoo-c8cb530e.zip
dev-python/oslo-serialization: 2.20.2 stable amd64 and x86 with cleanup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/oslo-serialization/Manifest1
-rw-r--r--dev-python/oslo-serialization/oslo-serialization-2.20.1.ebuild76
-rw-r--r--dev-python/oslo-serialization/oslo-serialization-2.20.2.ebuild2
3 files changed, 1 insertions, 78 deletions
diff --git a/dev-python/oslo-serialization/Manifest b/dev-python/oslo-serialization/Manifest
index da0c3dc128db..70dfe6018455 100644
--- a/dev-python/oslo-serialization/Manifest
+++ b/dev-python/oslo-serialization/Manifest
@@ -1,2 +1 @@
-DIST oslo-serialization-2.20.1.tar.gz 28701 BLAKE2B c854f6add39d7a995469faeccb9da63f12741b529143fb5d6e796b7534c58c1cc509ac18b8fac5ca73d4114c80558c42452acd6f4ce896e564d8074140b75c2c SHA512 4844544df91a529744cb8e869592e77fd9bb8bd26ff7b13ee4a37d9b9c31c181205663f98ee4795cb0e593b029744293aa029cc5ffa67851f4a27d27a6cae298
DIST oslo-serialization-2.20.2.tar.gz 29486 BLAKE2B 73fda86ced11c7c6dfb1a15c761645583cee463521285dc194cc1aebd5ef100832190bb0b07f825472286dab8ffc4dbed5cf6183fd86128bd74d51c5d15996a8 SHA512 1bcf50a090a0ec74d1aca7de6cc83f7451778eae7335427d11f732120ec99163441ee0bde13df6e660574c7ac5fcafe746cdbcb421e57f02d782f2405d5e33c7
diff --git a/dev-python/oslo-serialization/oslo-serialization-2.20.1.ebuild b/dev-python/oslo-serialization/oslo-serialization-2.20.1.ebuild
deleted file mode 100644
index aef5577f97d6..000000000000
--- a/dev-python/oslo-serialization/oslo-serialization-2.20.1.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1 vcs-snapshot
-
-MY_PN=${PN/-/.}
-
-DESCRIPTION="Oslo Serialization library"
-HOMEPAGE="https://launchpad.net/oslo"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="doc test"
-
-CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
- !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- ${CDEPEND}
- test? (
- virtual/python-ipaddress[${PYTHON_USEDEP}]
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- >=dev-python/netaddr-0.7.13[${PYTHON_USEDEP}]
- !~dev-python/netaddr-0.7.16[${PYTHON_USEDEP}]
- >=dev-python/oslo-i18n-2.1.0[${PYTHON_USEDEP}]
- !~dev-python/oslo-i18n-3.15.2[${PYTHON_USEDEP}]
- >=dev-python/oslotest-1.10.0[${PYTHON_USEDEP}]
- )
- doc? (
- >=dev-python/sphinx-1.6.2[${PYTHON_USEDEP}]
- >=dev-python/openstackdocstheme-1.16.0[${PYTHON_USEDEP}]
- >=dev-python/reno-1.8.0[${PYTHON_USEDEP}]
- !~dev-python/reno-2.3.1[${PYTHON_USEDEP}]
- )
-"
-RDEPEND="
- ${CDEPEND}
- >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
- >=dev-python/msgpack-0.4.0[${PYTHON_USEDEP}]
- >=dev-python/oslo-utils-3.20.0[${PYTHON_USEDEP}]
- >=dev-python/pytz-2013.6[${PYTHON_USEDEP}]
-"
-
-python_prepare_all() {
- use doc && esetup.py build_sphinx
- distutils-r1_python_prepare_all
-}
-
-# Note: Tests fail due to requiring installation.
-#
-# Installation appears to fail due ot the use of namespace packages but root
-# cause was never truly established.
-RESTRICT="test"
-
-python_test() {
- distutils_install_for_testing
-
- PYTHONPATH="${TEST_DIR}/lib:${PYTHONPATH}"
-
- rm -rf .testrepository || die "couldn't remove '.testrepository' under ${EPTYHON}"
-
- testr init || die "testr init failed under ${EPYTHON}"
- testr run || die "testr run failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/build/html/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/oslo-serialization/oslo-serialization-2.20.2.ebuild b/dev-python/oslo-serialization/oslo-serialization-2.20.2.ebuild
index 156e394f611b..affdc3d0103e 100644
--- a/dev-python/oslo-serialization/oslo-serialization-2.20.2.ebuild
+++ b/dev-python/oslo-serialization/oslo-serialization-2.20.2.ebuild
@@ -15,7 +15,7 @@ SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz -> ${P}.tar.g
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm64 ~x86"
+KEYWORDS="amd64 ~arm64 x86"
IUSE="doc test"
CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]