summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-01-29 10:00:44 +0100
committerJeroen Roovers <jer@gentoo.org>2016-01-29 10:01:35 +0100
commitc8cbc6c40ea223cddf92bb4c3290f474d2d8532d (patch)
treeb7941276c8bf6017523a4fa99e0838b8be1b9581
parentwww-client/opera-developer: Version bump. (diff)
downloadgentoo-c8cbc6c4.tar.gz
gentoo-c8cbc6c4.tar.bz2
gentoo-c8cbc6c4.zip
net-misc/youtube-dl: Version bump.
Package-Manager: portage-2.2.27
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2016.01.27.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index b30d7b43171a..58113e44f6fb 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2016.01.01.tar.gz 1874602 SHA256 732f37c99d71b4239d72d61dd32214b5a5a618671fb0629c8f8deb28209a172c SHA512 fdb022bed426250e5ee1c2bcc1354dd195c0f9793ca479ca8ca4cfe2f71e07ba100b0dbcda2fb9f310308ab130587d06b16a6a86f9036f0d196b317d2e5b5e92 WHIRLPOOL 152e709ba15264c35a89644ea0d4793bb47c82b317e54043ccfff72e40bdf95e42d76605e801233632d3863537a945cfb9ecc2f75245171b8de31b51ce6af801
DIST youtube-dl-2016.01.15.tar.gz 1898595 SHA256 c1e22ca3286aff74a668d1f8ef5c84c37bee2c269824e71ffdb23356a8735c44 SHA512 37cfb097e3345f9775a867d54f61eb60a94ba3408c3ef448ebb895e8bb74915f30f4ae87030d7f5d48bd9dfa2bccff302a6ede28624b7d17c4f164a9561d47db WHIRLPOOL 8a8653e49a043a34934b0e8c68be21a79899be4b391b0c7e6fceb6583f0ec22204349ca4aad0ef56703bb24ce8e4362d1c1cec95bef89cc24743191c6af3c1e8
DIST youtube-dl-2016.01.23.tar.gz 1916234 SHA256 449f4330fac38ed9f2bb2a547f42c1cfd705bab6a8839ff279fc4bd91f233154 SHA512 ca3a7f2024ae97a290869e123d4b67c858f35894ce4309c295c3994c9bac1f406152cd36d893cd48c79bd3ada92b6e5e76ac1a87cbffc321fe03efc131d0445f WHIRLPOOL 9c628d0fd5f3abe1d44dd84a50400e837eb61d597a120d17b3e353430a250becea91bbdfa575b821e6f849092494640d4eac0b3917731c459202d324d00cb522
+DIST youtube-dl-2016.01.27.tar.gz 1918307 SHA256 d06bb62ea19aef3ebb842ac01d98bbeee378e06d9e7c7a2f3bef343205b52ee9 SHA512 a6f38466c5d5c369c487913703348fa04c2272af6cbc300be552eaed5f1e713c0083f6f569dae3fd01a77f30582e36629c90bcd0dfe5641ffded04626c67cc6a WHIRLPOOL fb753cf67fd1142837e78dfbde9e4c14cfc41a499b15b36024647a7eb78763938edf6c9a88c2cd05951071d4e2d66e28fa704188b5b6c553be4bfde243773dfd
diff --git a/net-misc/youtube-dl/youtube-dl-2016.01.27.ebuild b/net-misc/youtube-dl/youtube-dl-2016.01.27.ebuild
new file mode 100644
index 000000000000..5db7401e49ee
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2016.01.27.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=(python{2_7,3_3,3_4,3_5})
+DISTUTILS_SINGLE_IMPL=true
+inherit bash-completion-r1 distutils-r1 eutils
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://rg3.github.com/youtube-dl/"
+SRC_URI="http://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="offensive test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[coverage(+)] )
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ if ! use offensive; then
+ sed -i -e "/__version__/s|'$|-gentoo_no_offensive_sites'|g" \
+ youtube_dl/version.py || die
+ # these have single line import statements
+ local xxx=(
+ alphaporno anysex behindkink chaturbate drtuber eporner eroprofile
+ extremetube fourtube foxgay goshgay hellporno hentaistigma
+ hornbunny keezmovies mofosex motherless porn91 pornhd pornotube
+ pornovoisines pornoxo redtube sexykarma sexu sunporno slutload
+ spankbang spankwire thisav trutube tube8 vporn xbef xnxx xtube
+ xvideos xxxymovies youjizz youporn
+ )
+ # these have multi-line import statements
+ local mxxx=(
+ pornhub xhamster tnaflix
+ )
+ # do single line imports
+ sed -i \
+ -e $( printf '/%s/d;' ${xxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ # do multiple line imports
+ sed -i \
+ -e $( printf '/%s/,/)/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/__init__.py \
+ || die
+
+ sed -i \
+ -e $( printf '/%s/d;' ${mxxx[@]} ) \
+ youtube_dl/extractor/generic.py \
+ youtube_dl/extractor/tumblr.py \
+ || die
+
+ rm \
+ $( printf 'youtube_dl/extractor/%s.py ' ${xxx[@]} ) \
+ $( printf 'youtube_dl/extractor/%s.py ' ${mxxx[@]} ) \
+ test/test_age_restriction.py \
+ || die
+ fi
+
+ epatch_user
+}
+
+src_compile() {
+ distutils-r1_src_compile
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ python_domodule youtube_dl
+ dobin bin/${PN}
+ dodoc README.txt
+ doman ${PN}.1
+ newbashcomp ${PN}.bash-completion ${PN}
+ python_fix_shebang "${ED}"
+}