summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-12-29 04:37:29 +0100
committerMichał Górny <mgorny@gentoo.org>2023-12-29 04:37:29 +0100
commitc8dec06695db4c943758d60ab9836c90b7cb349a (patch)
treea38b78416ba9fc8d27c12fe5ed2c48429b6f15d9
parentdev-python/boto3: Bump to 1.34.10 (diff)
downloadgentoo-c8dec066.tar.gz
gentoo-c8dec066.tar.bz2
gentoo-c8dec066.zip
app-admin/awscli: Bump to 1.32.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-admin/awscli/Manifest1
-rw-r--r--app-admin/awscli/awscli-1.32.10.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index dc79042b411c..71efe28400f6 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,4 +1,5 @@
DIST aws-cli-1.31.11.gh.tar.gz 2605881 BLAKE2B 816846d5dd50a382b837cb25e01be330cb345b55819907ddc8bd3a6623752322d5eb79526a42addb85e9b4dedbf86cee0f064f8ae87d9bd2b3ee996751f37265 SHA512 8147f2c39618317755903a49b02cbfacdc514fd76df31fd354526a684c8da97753d7e2429ca9d46f035fc12263cdec847078f7461dd1ed7948d6614d6408debb
+DIST aws-cli-1.32.10.gh.tar.gz 2620727 BLAKE2B b498422949dcc026dfdcf58f09f1c48327707734cfbb36bc289a0672a3dfb0fb1bc2a4d020b5c7c3025a4e0a451e6913148f3f514c8aeeb13c33d702d9cc821d SHA512 5a399c705c2a6334563b4ae2a4cffaa5b363807ba19b2e25a50765b1a196d1487b0ff237aa9367595ca5f65b800247dbb0258831f0446aceaf619ff0d93b319f
DIST aws-cli-1.32.2.gh.tar.gz 2609043 BLAKE2B 18cf285e54c25605502167e4fa002f522063dd85fc0c09eb44b4513ada49dbe476ca4485bb1cb63e726c5e1bee6934ccfa340ac9c9daecae082abb1abd852426 SHA512 951814c6e5a5dcf74de12e66430c53ca010bae6a8c9984dc11ab456f1cbd4a3f32e5055b3f7587fdf8cff4c224f86bc95858a2556ed5b90981894f706ab1b023
DIST aws-cli-1.32.7.gh.tar.gz 2620400 BLAKE2B dee6686b73100c607eba165f0f8ff91217336b020644c7ef7ee95dad16f57baea0878a3da96fd2f7258271573c1245286921240d141ba3020006b7ca2b37a0b5 SHA512 1df4aa8f2a2924d0e1c84e1187db1d5b974600831d7f668e39cfa17c34896ec51c604ef52d5ce397ca5950e79cac3c2e744c9b048f12164b650aa871e0c489e7
DIST aws-cli-1.32.8.gh.tar.gz 2620170 BLAKE2B 206b166946e36252ed6f4af6c808d4773681708c5d6b31115fb21f72a9723f77d8c9d0c03793d3c4abfc01207006c42239feac8d2e4f87ec430e07d056dfd36f SHA512 d734eeb1cfee8f42e31564985eee797ca07078fae4c3a3acda44f3b1ece8e61d5baebe9b83ac7f1bbdb65969618c243c62baebe04d5474fa669732e87f6cf059
diff --git a/app-admin/awscli/awscli-1.32.10.ebuild b/app-admin/awscli/awscli-1.32.10.ebuild
new file mode 100644
index 000000000000..77feb2d63e3e
--- /dev/null
+++ b/app-admin/awscli/awscli-1.32.10.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y+2).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 2)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=( "${serial_tests[@]}" )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}