summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-18 19:57:43 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-18 19:57:43 +0100
commitc8eb6465a3eeab05296a481a2cb18c61bc57ed68 (patch)
tree84fa4ff8e5dd5052333cfe91bf215c4ed59e92c5
parentdev-python/xdoctest: drop old (diff)
downloadgentoo-c8eb6465a3eeab05296a481a2cb18c61bc57ed68.tar.gz
gentoo-c8eb6465a3eeab05296a481a2cb18c61bc57ed68.tar.bz2
gentoo-c8eb6465a3eeab05296a481a2cb18c61bc57ed68.zip
dev-python/ubelt: bump to 0.9.1, add python3_9
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--dev-python/ubelt/Manifest1
-rw-r--r--dev-python/ubelt/ubelt-0.9.1.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/ubelt/Manifest b/dev-python/ubelt/Manifest
index f7a01d309942..1235f9899f28 100644
--- a/dev-python/ubelt/Manifest
+++ b/dev-python/ubelt/Manifest
@@ -1 +1,2 @@
DIST ubelt-0.8.8.tar.gz 172347 BLAKE2B 94435bf8b5a5f67011540c43dd767393cda6bccf95b963ca74cf3ee72444de43828b87bd2e6aa93001fc2c7cd49e245c459b0bc8f2617f12da906ae4e3f194aa SHA512 f63b3a9de51176d00a12999d540080e381266bb43b15942580f7f60b230b2e52021937b0cb4b31e084e0b77c141ae5cb3b8ae000d7af196e0c2f293a960e7438
+DIST ubelt-0.9.1.tar.gz 174866 BLAKE2B d9825cc266945e76560be0afaeaf28ce2c7ca99a9313f519c9e83fc987599a4d8c2d262af4f13040f522b91e3c73170f8af7fc7dbe9e40128b707d9a571f4b1a SHA512 92edac331602ef292842d48cd03c3ae12aaaec7e5860fd47c83dbe0449dee584e95ce5dd157a0b84b557dc4f4b6a0ee66ccabb669c5923e9b9083daaa2eb92df
diff --git a/dev-python/ubelt/ubelt-0.9.1.ebuild b/dev-python/ubelt/ubelt-0.9.1.ebuild
new file mode 100644
index 000000000000..0801d0bd427d
--- /dev/null
+++ b/dev-python/ubelt/ubelt-0.9.1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A stdlib like feel, and extra batteries. Hashing, Caching, Timing, Progress"
+HOMEPAGE="https://github.com/Erotemic/ubelt"
+SRC_URI="https://github.com/Erotemic/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/ordered-set[${PYTHON_USEDEP}]"
+
+DEPEND="test? ( dev-python/xdoctest[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv tests || die "Tests fail with ${EPYTHON}"
+}