summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2021-04-17 15:39:11 -0700
committerPatrick McLean <chutzpah@gentoo.org>2021-04-17 15:39:31 -0700
commitc8f4de8531b032b79b7ac7992c63fa0b796a8486 (patch)
tree1235372b07e7c09e6410af6bdd24991191e92682
parentnet-libs/libgfbgraph: Depend on gtk-doc for autoreconf (diff)
downloadgentoo-c8f4de85.tar.gz
gentoo-c8f4de85.tar.bz2
gentoo-c8f4de85.zip
app-text/lowdown-0.8.4: Respect LDFLAGS (bug #783393)
Also don't directly call ar, and fix musl support. Closes: https://bugs.gentoo.org/783393 Package-Manager: Portage-3.0.18, Repoman-3.0.3 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
-rw-r--r--app-text/lowdown/lowdown-0.8.4.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/app-text/lowdown/lowdown-0.8.4.ebuild b/app-text/lowdown/lowdown-0.8.4.ebuild
index 6e601e6125f6..dd0f98fee37c 100644
--- a/app-text/lowdown/lowdown-0.8.4.ebuild
+++ b/app-text/lowdown/lowdown-0.8.4.ebuild
@@ -28,6 +28,10 @@ src_configure() {
CC="$(tc-getCC)" ./configure || die "./configure failed"
}
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}" AR="$(tc-getAR)" $(usex elibc_musl UTF8_LOCALE=C.UTF-8 '')
+}
+
src_test() {
emake regress
}