summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-01-28 11:11:32 -0500
committerIonen Wolkens <ionen@gentoo.org>2024-01-28 11:32:24 -0500
commitc8f76077f9166e3d84fe4aafe052010e1530c3e4 (patch)
tree1065e3d08823e17559ac14c5b1613b40f8ebc266
parentx11-drivers/nvidia-drivers: add nvidia-powerd openrc script (diff)
downloadgentoo-c8f76077f9166e3d84fe4aafe052010e1530c3e4.tar.gz
gentoo-c8f76077f9166e3d84fe4aafe052010e1530c3e4.tar.bz2
gentoo-c8f76077f9166e3d84fe4aafe052010e1530c3e4.zip
games-emulation/stella: drop 6.7
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--games-emulation/stella/Manifest1
-rw-r--r--games-emulation/stella/stella-6.7.ebuild74
2 files changed, 0 insertions, 75 deletions
diff --git a/games-emulation/stella/Manifest b/games-emulation/stella/Manifest
index c41798dfcf4c..8d219b984f67 100644
--- a/games-emulation/stella/Manifest
+++ b/games-emulation/stella/Manifest
@@ -1,2 +1 @@
-DIST stella-6.7-src.tar.xz 10280224 BLAKE2B da2920384b6b254edd8f615c665ea1eef79030afffdf1b442f490f026c6f577ba4f7329531159767ba720207aeeb14388b5970bdd3e250b0db54e12d5f791396 SHA512 c20a2e9d98e1330f151e5f7d0e7cf15b2279b0d5f1175269f4084bf4964337b998118800615ae62eabf9d0f8abe0bb9cd02bddd1ee827121a49131888b4946ff
DIST stella-6.7.1-src.tar.xz 10277788 BLAKE2B c40db17c2e91277f3ec4d6db275e9f3c197883888eff44a046fd9405437539f253628777e2230b006ace16105bb2e0d524d86d3b6d3071876d97d190b96dbcb0 SHA512 7ab3c46eb8a1243334222e69a5e6cb33eff18d43f7312f52f660b608dc21992e2c0a0bd43df3a2f1c2a0789e445b960970a866f1f0755edffe2f63ad930a0f3a
diff --git a/games-emulation/stella/stella-6.7.ebuild b/games-emulation/stella/stella-6.7.ebuild
deleted file mode 100644
index db68632d57ca..000000000000
--- a/games-emulation/stella/stella-6.7.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs xdg
-
-DESCRIPTION="Multi-platform Atari 2600 VCS Emulator"
-HOMEPAGE="https://stella-emu.github.io/"
-SRC_URI="https://github.com/stella-emu/stella/releases/download/${PV}/${P}-src.tar.xz"
-
-LICENSE="GPL-2+ BSD MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+joystick png zlib"
-REQUIRED_USE="png? ( zlib )"
-
-RDEPEND="
- dev-db/sqlite:3
- media-libs/libsdl2[joystick?,opengl,sound,video]
- png? ( media-libs/libpng:= )
- zlib? ( sys-libs/zlib:= )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- default
-
- sed -i 's/pkg-config/${PKG_CONFIG}/' configure || die
- sed -i '/CXXFLAGS+=/s/-fomit-frame-pointer//' Makefile || die
-}
-
-src_configure() {
- tc-export CC CXX PKG_CONFIG
-
- # not autotools-based
- local configure=(
- ./configure
- --host=${CHOST}
- --prefix="${EPREFIX}"/usr
- --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
- --use-system-sqlite
- $(use_enable joystick)
- $(use_enable png)
- $(use_enable zlib zip)
- ${EXTRA_ECONF}
- )
-
- echo ${configure[*]}
- "${configure[@]}" || die
-}
-
-src_install() {
- local DOCS=(
- Announce.txt Changes.txt README-SDL.txt
- Readme.txt docs/R77_readme.txt Todo.txt
- )
-
- default
-
- rm "${ED}"/usr/share/doc/${PF}/html/*.txt || die
-}
-
-pkg_postinst() {
- xdg_pkg_postinst
-
- if [[ ${REPLACING_VERSIONS} ]] && ver_test ${REPLACING_VERSIONS} -lt 6.7; then
- elog "With version >=6.7, because of fixes to JSON handling, all remappings"
- elog "will be reset to defaults. If you had custom mappings, they will need"
- elog "to be re-entered again."
- elog
- elog "Furthermore, because of internal changes, all old state files are invalid."
- fi
-}