summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-12-04 00:17:45 +0100
committerAaron Bauman <bman@gentoo.org>2019-12-03 19:51:29 -0500
commitc902106e6752c0dad27fb1760c2d78ee03f7ead5 (patch)
tree38312bc0c8dc178921e8e493af2442163356768b
parentdev-python/python-markdown-math: Remove broken version (diff)
downloadgentoo-c902106e.tar.gz
gentoo-c902106e.tar.bz2
gentoo-c902106e.zip
dev-python/pynacl: Fix tests with >=dev-python/hypothesis-4.0.0
Closes: https://bugs.gentoo.org/701936 Package-Manager: Portage-2.3.80, Repoman-2.3.19 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org> Signed-off-by: Aaron Bauman <bman@gentoo.org>
-rw-r--r--dev-python/pynacl/files/pynacl-1.3.0-hypothesis-4.patch29
-rw-r--r--dev-python/pynacl/pynacl-1.3.0.ebuild2
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/pynacl/files/pynacl-1.3.0-hypothesis-4.patch b/dev-python/pynacl/files/pynacl-1.3.0-hypothesis-4.patch
new file mode 100644
index 000000000000..9b7a5a905d41
--- /dev/null
+++ b/dev-python/pynacl/files/pynacl-1.3.0-hypothesis-4.patch
@@ -0,0 +1,29 @@
+From af2d8c241872318baba42d7f5fbfb1869de91baa Mon Sep 17 00:00:00 2001
+From: Valentin Heidelberger <github@valentinsblog.com>
+Date: Thu, 27 Sep 2018 22:36:34 +0200
+Subject: [PATCH] Remove average_size hypothesis setting from test_bindings.py
+
+---
+ tests/test_bindings.py | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/tests/test_bindings.py b/tests/test_bindings.py
+index 22930cc7..d7951a21 100644
+--- a/tests/test_bindings.py
++++ b/tests/test_bindings.py
+@@ -306,7 +306,6 @@ def test_unpad_not_padded():
+
+
+ @given(binary(min_size=0,
+- average_size=128,
+ max_size=2049),
+ integers(min_value=16,
+ max_value=256)
+@@ -320,7 +319,6 @@ def test_pad_sizes(msg, bl_sz):
+
+
+ @given(binary(min_size=0,
+- average_size=128,
+ max_size=2049),
+ integers(min_value=16,
+ max_value=256)
diff --git a/dev-python/pynacl/pynacl-1.3.0.ebuild b/dev-python/pynacl/pynacl-1.3.0.ebuild
index ce1ea9dec3e2..391ddc755896 100644
--- a/dev-python/pynacl/pynacl-1.3.0.ebuild
+++ b/dev-python/pynacl/pynacl-1.3.0.ebuild
@@ -27,6 +27,8 @@ DEPEND="${RDEPEND}
>=dev-python/pytest-3.2.1[${PYTHON_USEDEP}] )
"
+PATCHES=( "${FILESDIR}/${P}-hypothesis-4.patch" )
+
src_prepare() {
# For not using the bundled libsodium
export SODIUM_INSTALL=system