summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2017-09-28 10:19:10 -0700
committerPatrick McLean <chutzpah@gentoo.org>2017-09-28 10:19:35 -0700
commitc9050c99d18c223561dbedddc4d747bef899508b (patch)
treea3e6d0e378496a4f4fd4321a420e306fe6beedde
parentapp-i18n/libchewing: Stabilize 0.5.1 on amd64/x86. (diff)
downloadgentoo-c9050c99.tar.gz
gentoo-c9050c99.tar.bz2
gentoo-c9050c99.zip
dev-python/python-ebtables: New package, python bindings for ebtables
Package-Manager: Portage-2.3.10, Repoman-2.3.3
-rw-r--r--dev-python/python-ebtables/Manifest1
-rw-r--r--dev-python/python-ebtables/metadata.xml15
-rw-r--r--dev-python/python-ebtables/python-ebtables-0.2.0.ebuild18
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/python-ebtables/Manifest b/dev-python/python-ebtables/Manifest
new file mode 100644
index 000000000000..e1eabc3e8cb0
--- /dev/null
+++ b/dev-python/python-ebtables/Manifest
@@ -0,0 +1 @@
+DIST python-ebtables-0.2.0.tar.gz 20290 SHA256 5d5cc3b84dd7ce3bd3299fa276e71bc2dece4b2cb8a388828b54bd92a5c549b3 SHA512 7051672d205b8318dcf7d08b50c8e0f66d9bb6532794d9292a890c5f75a88845f9e0cd9abf41450bf2a0516623c494eb40330021dc99320e5e0ffa56c75b100a WHIRLPOOL a4ab5845367b530b6184c976f2a8a20438d5ed14053379d3c47d44217cc141d7dd3078605d3ece504843a22f921676cc75cd7481dc2a8ad62ae059451a17b074
diff --git a/dev-python/python-ebtables/metadata.xml b/dev-python/python-ebtables/metadata.xml
new file mode 100644
index 000000000000..25d80baf6f13
--- /dev/null
+++ b/dev-python/python-ebtables/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Ebtables is used for Ethernet bridge frame table administration on Linux.
+ Python-ebtables is a simple Python binding for Ebtables.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">ldx/python-ebtables</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/python-ebtables/python-ebtables-0.2.0.ebuild b/dev-python/python-ebtables/python-ebtables-0.2.0.ebuild
new file mode 100644
index 000000000000..d8bec59d8cf3
--- /dev/null
+++ b/dev-python/python-ebtables/python-ebtables-0.2.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for ebtables"
+HOMEPAGE="https://github.com/ldx/python-iptables"
+SRC_URI="https://github.com/ldx/${PN}/archive/v0.2.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="net-firewall/ebtables[-static]
+ dev-python/cffi[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"