summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2015-08-28 21:46:48 +0800
committerBen de Groot <yngwin@gentoo.org>2015-08-28 21:47:20 +0800
commitc90c8667004a9efe613c36ec93ff8566b401c854 (patch)
tree58577c09e3fdcdf8912dcbff437d0aa95b399bd1
parentkde-frameworks/ktexteditor: Add a subslot operator to libgit2 dependency (diff)
downloadgentoo-c90c8667004a9efe613c36ec93ff8566b401c854.tar.gz
gentoo-c90c8667004a9efe613c36ec93ff8566b401c854.tar.bz2
gentoo-c90c8667004a9efe613c36ec93ff8566b401c854.zip
media-libs/ganv: fix compilation with USE=-fdgl
Upstream patch supplied by Karl Lindén. Adding him as proxy maintainer. Bug: 556518 Package-Manager: portage-2.2.20.1
-rw-r--r--media-libs/ganv/files/ganv-1.4.2-no-fdgl.patch42
-rw-r--r--media-libs/ganv/ganv-1.4.2.ebuild6
-rw-r--r--media-libs/ganv/metadata.xml4
3 files changed, 51 insertions, 1 deletions
diff --git a/media-libs/ganv/files/ganv-1.4.2-no-fdgl.patch b/media-libs/ganv/files/ganv-1.4.2-no-fdgl.patch
new file mode 100644
index 000000000000..17cc2432d0ec
--- /dev/null
+++ b/media-libs/ganv/files/ganv-1.4.2-no-fdgl.patch
@@ -0,0 +1,42 @@
+Index: src/Canvas.cpp
+===================================================================
+--- src/Canvas.cpp (revision 5479)
++++ src/Canvas.cpp (revision 5480)
+@@ -760,6 +760,18 @@
+ }
+ #endif
+
++inline uint64_t
++get_monotonic_time()
++{
++#if GLIB_CHECK_VERSION(2, 28, 0)
++ return g_get_monotonic_time();
++#else
++ GTimeVal time;
++ g_get_current_time(&time);
++ return time.tv_sec + time.tv_usec;
++#endif
++}
++
+ #ifdef GANV_FDGL
+
+ inline Region
+@@ -788,18 +800,6 @@
+ b->impl->force = vec_sub(b->impl->force, f);
+ }
+
+-inline uint64_t
+-get_monotonic_time()
+-{
+-#if GLIB_CHECK_VERSION(2, 28, 0)
+- return g_get_monotonic_time();
+-#else
+- GTimeVal time;
+- g_get_current_time(&time);
+- return time.tv_sec + time.tv_usec;
+-#endif
+-}
+-
+ gboolean
+ GanvCanvasImpl::layout_iteration()
+ {
diff --git a/media-libs/ganv/ganv-1.4.2.ebuild b/media-libs/ganv/ganv-1.4.2.ebuild
index 11adbd7c2949..d29a09de0eea 100644
--- a/media-libs/ganv/ganv-1.4.2.ebuild
+++ b/media-libs/ganv/ganv-1.4.2.ebuild
@@ -5,7 +5,7 @@
EAPI=5
PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE='threads(+)'
-inherit waf-utils python-any-r1
+inherit eutils waf-utils python-any-r1
DESCRIPTION="A GTK+ widget for interactive graph-like environments"
HOMEPAGE="http://drobilla.net/software/ganv/"
@@ -27,6 +27,10 @@ DEPEND="${RDEPEND}
DOCS=( AUTHORS NEWS README )
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-no-fdgl.patch
+}
+
src_configure() {
waf-utils_src_configure \
$(use graphviz || echo "--no-graphviz") \
diff --git a/media-libs/ganv/metadata.xml b/media-libs/ganv/metadata.xml
index bd43bef08dd3..8f0e433951ee 100644
--- a/media-libs/ganv/metadata.xml
+++ b/media-libs/ganv/metadata.xml
@@ -1,6 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+ <maintainer>
+ <email>karl.j.linden@gmail.com</email>
+ <name>Karl Lindén</name>
+ </maintainer>
<herd>proaudio</herd>
<use>
<flag name="fdgl">Use experimental force-directed graph layout</flag>