summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-03-06 16:04:04 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-03-06 16:46:23 +0100
commitc91de974f8a68bd9216b70858117c20212b9de0c (patch)
treedcc8da6ad8b64fc77290e24edd21b375ba4d6584
parentkde-plasma/plasma-disks: 6.0.1 version bump (diff)
downloadgentoo-c91de974f8a68bd9216b70858117c20212b9de0c.tar.gz
gentoo-c91de974f8a68bd9216b70858117c20212b9de0c.tar.bz2
gentoo-c91de974f8a68bd9216b70858117c20212b9de0c.zip
kde-plasma/plasma-firewall: 6.0.1 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/plasma-firewall/Manifest1
-rw-r--r--kde-plasma/plasma-firewall/plasma-firewall-6.0.1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/kde-plasma/plasma-firewall/Manifest b/kde-plasma/plasma-firewall/Manifest
index aeaef641544a..f478866869e6 100644
--- a/kde-plasma/plasma-firewall/Manifest
+++ b/kde-plasma/plasma-firewall/Manifest
@@ -1,2 +1,3 @@
DIST plasma-firewall-5.27.10.tar.xz 363288 BLAKE2B abebad4476e270ec5da39a4a8791382fe287d058e0e8bd2fe381204300cf41213adaa8125ca1c585d457ab969beadcd6122119798ae6c8bda0ad6660d2d14217 SHA512 350d44e26b6a9100b3f6ac9022b2e653f2ff55ec62f8efbef7b747eac006d8a0eb7182f8161a587cafadc07d5126fc0ea439e0624e578911ddba718fc99856d4
DIST plasma-firewall-6.0.0.tar.xz 367816 BLAKE2B 7e963187401722e27822760e1610fc04396febb96fcfd915d90a7ffea98c7d6ad41a753f749ff2abdb91141ed0871fc71e7f4b1d0d17cfa79eaff35af96076d5 SHA512 446283ef553498430858bf509e3b585517d69b71e66aedab3cf8963863668bc82cc90407c90b918e4aa961eac4e361bd8cd0070049d204aa41d7e988df7bdacb
+DIST plasma-firewall-6.0.1.tar.xz 368664 BLAKE2B 13444325d835c49fb50f6262b2d097a122b921189bc3b1013283e3dde60bd686c38810dfa22b87a9d34894fb3e5aa7161609cb38dd0431fb4a84298c713bbf70 SHA512 c767e117699a5987b35f08112097e8ca91034e4104518f0d0a57f87f85106652867c1947901b6c66a7cc4e05e47a69ef34bb971bd5a180501f635ad2cee0a865
diff --git a/kde-plasma/plasma-firewall/plasma-firewall-6.0.1.ebuild b/kde-plasma/plasma-firewall/plasma-firewall-6.0.1.ebuild
new file mode 100644
index 000000000000..b32a35aa7769
--- /dev/null
+++ b/kde-plasma/plasma-firewall/plasma-firewall-6.0.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="forceoptional"
+PYTHON_COMPAT=( python3_{10..12} )
+KFMIN=6.0
+QTMIN=6.6.2
+inherit ecm plasma.kde.org python-single-r1
+
+DESCRIPTION="Plasma frontend for Firewalld or UFW"
+HOMEPAGE="https://invent.kde.org/network/plasma-firewall"
+
+LICENSE="GPL-2+"
+SLOT="6"
+KEYWORDS="~amd64"
+IUSE="firewalld +ufw"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE} || ( firewalld ufw )"
+
+DEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[dbus,gui,network,xml]
+ >=dev-qt/qtdeclarative-${QTMIN}:6
+ >=kde-frameworks/kauth-${KFMIN}:6
+ >=kde-frameworks/kcmutils-${KFMIN}:6
+ >=kde-frameworks/kconfig-${KFMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/ki18n-${KFMIN}:6
+"
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ firewalld? ( net-firewall/firewalld )
+ ufw? ( net-firewall/ufw )
+"
+BDEPEND=">=kde-frameworks/kcmutils-${KFMIN}:6"
+
+src_prepare() {
+ ecm_src_prepare
+ # this kind of cmake magic doesn't work for us at all.
+ sed -e "1 s:^.*$:\#\!/usr/bin/env ${EPYTHON}:" \
+ -i kcm/backends/ufw/helper/kcm_ufw_helper.py.cmake || die
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_FIREWALLD_BACKEND=$(usex firewalld)
+ -DBUILD_UFW_BACKEND=$(usex ufw)
+ )
+ ecm_src_configure
+}
+
+pkg_postinst () {
+ ecm_pkg_postinst
+
+ if ! has_version sys-apps/systemd; then
+ ewarn "${PN} is not functional without sys-apps/systemd at this point."
+ ewarn "See also: https://bugs.gentoo.org/778527"
+ fi
+}